Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001744KdenliveEffectspublic2010-08-13 18:262010-09-05 05:52
Reportertidris769 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusacknowledgedResolutionopen 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.10
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001744: Pan and zoom effect trouble on a long clip
DescriptionPan and Zoom doesn't work right on long clips.

In the attached project I am using keyframes to zoom and pan a 9 minutes long clip, but the image stops zooming & panning once the position goes a little over 4 minutes. Also in some of the frames the image turns double and slanted (see attached frame.png).
Steps To Reproduce1- Open the attached project t.kdenlive.
2- Click the clip in the timeline to active the pan & zoom UI.
3- Drag the position rectangle slowly from left to right. Note the problems I mentioned above.
Additional Informationkdenlive svn 4714 + today's mlt from git
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filesgz file icon bug.tar.gz [^] (457,870 bytes) 2010-08-13 18:26
gz file icon bug1.tar.gz [^] (80,208 bytes) 2010-08-13 19:17

- Relationships

-  Notes
(0005619)
tidris769 (reporter)
2010-08-13 19:19
edited on: 2010-08-13 19:20

The bug.tar.gz has the t.kdenlive & frame.png mentioned above.

I have also attached bug1.tar.gz. This has project t1.kdenlive that shows a different but I think related problem. In this project there is a 1 minute long clip where adding the pan & zoom effect produces an entirely black image. No keyframes have been added to the effect and the red rectangle is at 100% size in its default position.

(0005637)
j-b-m (administrator)
2010-08-16 13:57

I can confirm. I think it's an MLT issue, will try to find a way to reproduce using melt when I have time...
(0005647)
tidris769 (reporter)
2010-08-19 19:41

I also think it's an MLT issue. I can see trouble when playing the sample projects in melt.
(0005752)
ttill (developer)
2010-09-02 18:19
edited on: 2010-09-02 18:20

I just send a patch to the MLT mailing list which should solve the problem with the pan & zoom effect stopping to work. In fact it stopped working at frame 15000.
The other 2 bugs still exist.

@jb: I hope you did not already work on this one.

(0005778)
tidris769 (reporter)
2010-09-05 05:52

So with today's kdenlive + today's mlt I see two of the three problems I reported here are fixed. The problem that remains is the image doubling + slanted on many of the video frames. See frame.png in bug.tar.gz for an example of that.

- Issue History
Date Modified Username Field Change
2010-08-13 18:26 tidris769 New Issue
2010-08-13 18:26 tidris769 File Added: bug.tar.gz
2010-08-13 19:17 tidris769 File Added: bug1.tar.gz
2010-08-13 19:19 tidris769 Note Added: 0005619
2010-08-13 19:20 tidris769 Note Edited: 0005619 View Revisions
2010-08-16 13:57 j-b-m Note Added: 0005637
2010-08-16 13:57 j-b-m Assigned To => j-b-m
2010-08-16 13:57 j-b-m Status new => acknowledged
2010-08-19 19:41 tidris769 Note Added: 0005647
2010-09-02 18:19 ttill Note Added: 0005752
2010-09-02 18:20 ttill Note Edited: 0005752 View Revisions
2010-09-05 05:52 tidris769 Note Added: 0005778


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker