Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001750KdenliveUser Interfacepublic2010-08-16 03:132010-08-16 12:32
ReporterHuvants Tuneau 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilitysometimes
StatusfeedbackResolutionopen 
PlatformVirtual Machine (VMware Player)OSMint 9 (isadora)OS Version9 ker 2.6.32-21
Product Version0.7.7.1 
Target VersionFixed in Version 
Summary0001750: UI Crashes when selecting Title Clip in Project Tree
DescriptionWhile paused in a video clip, showing it on the Project Monitor, I selected the Title Clip that is first in the Project in the Clip window.

The above crash can be reproduced some of the time.

Could not reopen saved Project file without immediate crash until after I loaded the KDE Dev Environment 4.4.2 at the behest of the Crash Manager desiring "useful" information. Heisenberg rides again...

Two subsequent crashes have not affected reopening the Project files, but then I didn't uninstall the Dev libs.
Steps To ReproduceNothing special, just the act of selecting the Project tab and clicking on a Title Clip.

The first time it happened, I couldn't reload the saved Project file: KDEnlive would crash as soon as I hit Open. This was both the current one and one I'd saved a few minutes before that was similar. I rebooted, no joy. I loaded the debug packages that it wanted, and it then would open the files again (which leaves me wondering if there is some functional differences in the std vs debug lib files?). I fiddled about for awhile and then went back to what I was doing - finding the best begin point in the first video clip to match the title clip that preceded it, when it crashed again. This time I'm able to reopen the file and go back and try it again; this time no crash for one trial, so "some of the time" fits... The end of the Zone green bar is fairly close to the Position line when it failed (probably not pertinent).

The third time it happened was a couple of hours of editing later. I'd done the same operation numerous times without fault until then. I can upload that crash report too if desired.
Additional InformationNote: the environment is a Linux Mint 9 Virtual Machine, running in VMware Player v.3.0.1 build-227600, running on top of Windows 7 64-bit as the host OS (latest patches applied). VMware Tools in the VM (and thus its device drivers) are relatively recent.

The VM is afforded 2 cores and 1.6GB of memory. The processor is an AMD Phenom II 910 in an HP E990Y. Work folders and Files are saved outside the VM via "shared folders" to the host file structure.

UI performance in the VM is adequate, clips do play properly. Rendering may not be blazing, but I'm only doing short projects, so it doesn't matter.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon kdenlive-20100815.kcrash [^] (6,772 bytes) 2010-08-16 03:13 [Show Content]
? file icon kdenlive-20100815b.kcrash [^] (6,017 bytes) 2010-08-16 03:18 [Show Content]

- Relationships

-  Notes
(0005633)
Huvants Tuneau (reporter)
2010-08-16 03:20

Correction: PC is HP E9220Y, not that it matters much as this is in a VM.
(0005635)
j-b-m (administrator)
2010-08-16 12:32

Seems like an issue with the UI config file. Can you check if you have a file:

$HOME/.kde/share/apps/kdenlive/kdenliveui.rc ?

If yes, try to delete it and restart Kdenlive
You can also try to remove your custom transcoding profiles if you have some:

$HOME/.kde/share/config/kdenlivetranscodingrc

- Issue History
Date Modified Username Field Change
2010-08-16 03:13 Huvants Tuneau New Issue
2010-08-16 03:13 Huvants Tuneau File Added: kdenlive-20100815.kcrash
2010-08-16 03:18 Huvants Tuneau File Added: kdenlive-20100815b.kcrash
2010-08-16 03:20 Huvants Tuneau Note Added: 0005633
2010-08-16 12:32 j-b-m Note Added: 0005635
2010-08-16 12:32 j-b-m Assigned To => j-b-m
2010-08-16 12:32 j-b-m Status new => feedback


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker