Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001757KdenliveUser Interfacepublic2010-08-21 10:402010-09-22 17:54
ReporterGranjow 
Assigned Tottill 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.7.8Fixed in Version0.7.8 
Summary0001757: Curves widget with color background
DescriptionCould you perhaps make the curves widget use ColorTools::rgbCurvePlane?
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filespng file icon r-plane.png [^] (1,640 bytes) 2010-08-21 10:40


png file icon red-half.png [^] (8,258 bytes) 2010-08-24 23:00


png file icon gimp-curves.png [^] (49,000 bytes) 2010-08-24 23:02

- Relationships
parent of 0001793closedGranjow RGB Plane produces wrong results if scaling <255 
related to 0002000closedttill Use spline interpolation for the Curves effect 

-  Notes
(0005655)
ttill (developer)
2010-08-21 22:50

Done in svn r4742. What about Luma?
(0005656)
ttill (developer)
2010-08-21 22:52

I will eventually try to make the frei0r curves filter support more (up to 256) points during the next weeks. Should be much more useful then.
(0005658)
Granjow (developer)
2010-08-22 20:52

Nice, thank you!

Luma is basically just a gradient with black at the bottom and white at the top. I can add it as well before feature freeze.

More points would be nice. Basically there are 3 things that should be improved in the Curves widget:
* As said, more points
* More room for the curves. Very limited at the moment, and accurate editing is very difficult. I'm thinking of something like half screen size, really big. so that you can edit the nodes comfortably.
* Other interpolation method. The current one is using splines which is not suitable imho. The method used in GIMP is much better because changing a node's value does not change the curve between other nodes (or only slightly).
(0005665)
Granjow (developer)
2010-08-24 23:00

r4755: Luma added.

Also, perhaps the scaling is worth a look (Planes can be exported via Vectorscope ? Context menu ? Export background).

And yes, I know changing the interpolation method would a) cause incompatibility and b) be a lot of work, but I think it is worth it. Also by adding more points it wouldn't become that much more usable.
(0005666)
Granjow (developer)
2010-08-24 23:03

gimp-curves shows an extreme situation. Trying this in the curves widget with spline interpolation … well, try yourself :D
(0005689)
ttill (developer)
2010-08-27 17:41

Luma should now also display in svn r4765 as curve background.
I do not use the scaling yet because it does not work well with the width being much larger than the height. For example export a scaled background with width 1000 and height 800. The higher the difference the worse the result.
The widget should also use space better now.

Is it okay for you if the curve gets a bit thicker but therefore antialiased?
(0005690)
Granjow (developer)
2010-08-27 19:46

Oh no! Thanks for pointing that out. Will try to fix that tomorrow.

Antialiasing would be fine!
(0005760)
Granjow (developer)
2010-09-03 10:36

Fixed.
(0005797)
ttill (developer)
2010-09-06 22:04

I added Antialiasing somewhere in the meantime.
May I close this?
The more points + better interpolation things are probably better suited in a new report.
(0005827)
Granjow (developer)
2010-09-13 16:01

Agree, thanks! Looks fine now.

- Issue History
Date Modified Username Field Change
2010-08-21 10:40 Granjow New Issue
2010-08-21 10:40 Granjow Status new => assigned
2010-08-21 10:40 Granjow Assigned To => ttill
2010-08-21 10:40 Granjow File Added: r-plane.png
2010-08-21 22:50 ttill Note Added: 0005655
2010-08-21 22:52 ttill Note Added: 0005656
2010-08-21 22:53 ttill Status assigned => feedback
2010-08-22 20:52 Granjow Note Added: 0005658
2010-08-22 20:52 Granjow Status feedback => assigned
2010-08-24 23:00 Granjow Note Added: 0005665
2010-08-24 23:00 Granjow File Added: red-half.png
2010-08-24 23:02 Granjow File Added: gimp-curves.png
2010-08-24 23:03 Granjow Note Added: 0005666
2010-08-27 17:41 ttill Note Added: 0005689
2010-08-27 19:46 Granjow Note Added: 0005690
2010-09-03 10:36 Granjow Relationship added parent of 0001793
2010-09-03 10:36 Granjow Note Added: 0005760
2010-09-06 22:04 ttill Note Added: 0005797
2010-09-06 22:04 ttill Status assigned => feedback
2010-09-13 16:01 Granjow Note Added: 0005827
2010-09-13 16:01 Granjow Status feedback => assigned
2010-09-13 16:01 Granjow Status assigned => resolved
2010-09-13 16:01 Granjow Fixed in Version => Recent git
2010-09-13 16:01 Granjow Resolution open => fixed
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed
2010-09-22 17:54 Granjow Target Version future version => 0.7.8
2011-02-03 13:32 Granjow Relationship added related to 0002000


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker