Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001758KdenliveUser Interfacepublic2010-08-23 09:022011-11-01 18:56
Reporterpolbrian 
Assigned Tottill 
PrioritynormalSeveritycrashReproducibilityrandom
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSOpenSUSEOS Version11.0
Product Version0.7.7.1 
Target VersionFixed in Version0.8.2 
Summary0001758: crashes on moving split audio clip
DescriptionCrash on moving a clip with audio split.
-see attached file
On restarting kdenlive, recovering last changes, I hear a quantity of sounds bits from the clip which I moved when the crash occurs, at sundry parts of the timeline.
I quit and relaunch kdenlive, the phantom sounds are now visible on the timeline, I can delete them and no more trouble.
Steps To ReproduceCrashes happen randomly.
TagsNo tags attached.
Build/Install Method(select)
Attached Files? file icon kdenlive_2010-08-21.kcrash [^] (1,076 bytes) 2010-08-23 09:02 [Show Content]

- Relationships

-  Notes
(0005728)
ttill (developer)
2010-08-31 23:02

There have been a lot of changes to groups (split audio is also a group) in the upcoming Kdenlive 0.7.8 and I have not experienced group corruptions in the last few weeks (using development version of Kdenlive), so this is probably already fixed.
Would of course be helpful if you find a case were this is always reproducible.
(0005751)
polbrian (reporter)
2010-09-02 17:19

The "phantom sound bits" problem also happens without any crash. Can't reproduce, when I quit kdenlive and restart, the "phantom soundbits" appear on the timeline and I can delete them.
It's quite annoying, because it happens during relatively complex edits, this way:

-- "A" VIDEO --|------ "B" VIDEO only --|-- "D" VIDEO only --|-- "E" VIDEO ---
-- "A" SYNC AUDIO --|.............|------------------------ "E" SYNC AUDIO ---
.................. |-- "C" AUDIO --|
First I get a clip error "can't resize clip" trying to adjust "C" AUDIO or "E" SYNC AUDIO; then when I persist as there does not appear to be any reason, I begin to hear sounds that I did not set and that the timeline does not show either.
At restart all the tracks are grouped, I have to ungroup them and regroup the sync audio to its video (that is quite annoying when there are many edits).
(0005916)
ttill (developer)
2010-09-25 22:00

I did some tests with a similar setup and could not reproduce.
Could you maybe try to update to Kdenlive 0.7.8?
(0006160)
ttill (developer)
2010-12-11 22:18

Group operations should be pretty stable in 0.7.8 in contrast to prior versions.
If you have still problems feel free to open a new report.

- Issue History
Date Modified Username Field Change
2010-08-23 09:02 polbrian New Issue
2010-08-23 09:02 polbrian File Added: kdenlive_2010-08-21.kcrash
2010-08-31 23:02 ttill Note Added: 0005728
2010-08-31 23:02 ttill Assigned To => ttill
2010-08-31 23:02 ttill Status new => feedback
2010-09-02 17:19 polbrian Note Added: 0005751
2010-09-02 17:19 polbrian Status feedback => assigned
2010-09-25 22:00 ttill Note Added: 0005916
2010-12-11 22:18 ttill Note Added: 0006160
2010-12-11 22:19 ttill Status assigned => resolved
2010-12-11 22:19 ttill Resolution open => fixed
2010-12-11 22:19 ttill Fixed in Version => 0.7.8
2011-07-05 12:15 j-b-m Fixed in Version 0.7.8 => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker