Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001785KdenliveUser Interfacepublic2010-08-31 10:342010-09-14 23:01
ReporterGranjow 
Assigned Toj-b-m 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.8 
Summary0001785: Volume (keyframable) has no effect
DescriptionAlso when setting the volume to 0 the sound is still audible (same volume).
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files? file icon Haselbogen.kdenlive [^] (215,716 bytes) 2010-08-31 10:34

- Relationships

-  Notes
(0005724)
j-b-m (administrator)
2010-08-31 20:09
edited on: 2010-08-31 20:26

Ok, I think I found the problem. Occurs when moving a keyframe with effect stack slider. Will try to fix tonight or tomorrow.

EDIT:
After a quick test, I realised I was wrong. The problem is that you have a "volume" effect in one of your tracks (line 1867).

Looks like having a "volume" effect on track cancels the clip's volume effect. Have to check that in MLT. It also highlights the fact that we need to find a clearer way to indicate track effects or users will get lost in such cases...

(0005725)
Granjow (developer)
2010-08-31 20:22

Deleted them, volume is still constant.

However the effect itself is not broken; I've opened an old file which is using it, and there it's working.
(0005730)
j-b-m (administrator)
2010-08-31 23:06

Did some testing and it seems like a bug or a limitation of the volume effect. As I said in my previous comment, the issue is related to the "volume" effect you have on the track.

Looks like when there are 2 different volume effects on the same clip, instead of using the output of the first effect for the second effect, MLT uses the original sound for the second effect, so that the first effect is completely useless.

I can reproduce with following:

melt -track attach volume gain=1 myclip.mpg -attach volume gain=0

Here, the audio plays normally, when it should be muted. The track effect is applied after the clip effect and results in a normal 100% audio.

Forwarding issue on the MLT mailing list for Dan...
(0005736)
ddennedy (developer)
2010-09-01 08:19

Fixed in mlt git commit 5c885c.
(0005763)
Granjow (developer)
2010-09-03 20:06

Thank you, working correctly now!

- Issue History
Date Modified Username Field Change
2010-08-31 10:34 Granjow New Issue
2010-08-31 10:34 Granjow File Added: Haselbogen.kdenlive
2010-08-31 20:09 j-b-m Note Added: 0005724
2010-08-31 20:09 j-b-m Assigned To => j-b-m
2010-08-31 20:09 j-b-m Status new => feedback
2010-08-31 20:21 j-b-m Note Edited: 0005724 View Revisions
2010-08-31 20:22 Granjow Note Added: 0005725
2010-08-31 20:22 Granjow Status feedback => assigned
2010-08-31 20:25 j-b-m Note Edited: 0005724 View Revisions
2010-08-31 20:26 j-b-m Note Edited: 0005724 View Revisions
2010-08-31 23:06 j-b-m Note Added: 0005730
2010-09-01 08:19 ddennedy Note Added: 0005736
2010-09-01 08:19 ddennedy Status assigned => resolved
2010-09-01 08:19 ddennedy Fixed in Version => Recent git
2010-09-01 08:19 ddennedy Resolution open => fixed
2010-09-03 20:06 Granjow Note Added: 0005763
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker