Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001786KdenliveMLTpublic2010-08-31 15:452010-09-14 23:01
Reportertidris769 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform32-bit intelOSubuntu linuxOS Version9.10
Product VersionRecent git 
Target VersionFixed in Version0.7.8 
Summary0001786: Image transparency lost with grayscale effect + affine transition
DescriptionUsing an image with transparent background as top clip + affine transition + red color as bottom clip. Adding the grayscale effect to the top clip results in the transparent background drawn white over the bottom clip when project is played in kdenlive or melt. If project is rendered to MPEG-4 the transparent background is drawn black instead of white over the bottom clip. This problem doesn't happen if the transition is composite instead of affine.

Using svn 4796 + today's MLT but also happens in previous versions.
Steps To Reproduce- Play attached project in kdenlive and melt. First half uses affine transition, second half uses composite transition. Note white background during first half.
- Render project to MPEG-4. Note black background during first half.
- Disable grayscale effect on top clip and play again. Note the white background is gone during first half.
TagsNo tags attached.
Build/Install Method(select)
Attached Filesgz file icon bug3.tar.gz [^] (364,386 bytes) 2010-08-31 15:45
png file icon composite.png [^] (148,963 bytes) 2010-09-04 23:57


png file icon affine.png [^] (159,742 bytes) 2010-09-04 23:57

- Relationships

-  Notes
(0005775)
j-b-m (administrator)
2010-09-04 23:58
edited on: 2010-09-05 00:00

Issue can be reproduced with MLT:

melt colour:red -track transparent.png -attach sepia -transition composite in=0 out=200 progressive=1

gives the attached image composite.png

melt colour:red -track transparent.png -attach sepia -transition affine in=0 out=200 progressive=1

gives the attached image affine.png

Looks like the affine transition has issues with alpha channel.
The problem only occurs if you attach an effect to the last track...

Dan, could you have a look?

(0005791)
ddennedy (developer)
2010-09-06 08:38

Fixed in mlt git commit f9dbf1.
Thank you for the good bug report. This bug actually had a much larger impact than just this isolated case.

- Issue History
Date Modified Username Field Change
2010-08-31 15:45 tidris769 New Issue
2010-08-31 15:45 tidris769 File Added: bug3.tar.gz
2010-09-04 23:47 j-b-m Status new => acknowledged
2010-09-04 23:47 j-b-m Category Transitions => MLT
2010-09-04 23:57 j-b-m File Added: composite.png
2010-09-04 23:57 j-b-m File Added: affine.png
2010-09-04 23:58 j-b-m Note Added: 0005775
2010-09-05 00:00 j-b-m Note Edited: 0005775 View Revisions
2010-09-06 08:38 ddennedy Note Added: 0005791
2010-09-06 08:38 ddennedy Status acknowledged => resolved
2010-09-06 08:38 ddennedy Fixed in Version => Recent git
2010-09-06 08:38 ddennedy Resolution open => fixed
2010-09-06 08:38 ddennedy Assigned To => ddennedy
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker