Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001790KdenliveMLTpublic2010-09-01 02:012011-11-01 18:56
Reportermrbumpy4096 
Assigned Toddennedy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionnot fixable 
Platform32 bit intel and alikeOSKubuntu LinuxOS Version10.04
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0001790: sound on MP4 file only plays through once
DescriptionIn Kdenlive, if I play any MP4 clip shot with my Flip UltraHD video recorder, the sound will only work on the first playthrough; playing the video again results in silence. Also, if I play the video to 35%, for example, then rewind and play from the beginning, then the video will start at the beginning, but the audio will continue from 35%. Basically, once the audio part of the video has played through 100%, it will no longer play any more audio from that video or any other videos shot from my Flip recorder until I restart Kdenlive.

If I play other types of files (I tried a random MPG file on my PC) the sound works as expected, even if I play the MPG right after I stopped getting sound from the Flip's MP4 files.

FYI, I tried to add my camcorder to the list, but the manufacturer (Cisco) is not on the list, and I didn't know what to do. I did upload a video for testing, though (see below in the reproducing steps).
Steps To Reproduce1. Download the attached video (suspended-leaf.mp4).
2. Import the clip into Kdenlive and play it.
3. After it finishes, rewind the clip (CTRL-Home) and play again. Is there sound?
4. Try playing the clip halfway through, then rewind and play again. Does the sound start over again from the beginning or does it resume from where you left off before rewinding?
Additional Information** My System **
Motherboard: MSI K9N SLI Platinum (nForce 570 SLI chipset)
CPU: AMD Athlon(tm) 64 Processor 4000+ (2.6 GHz)
RAM: 2GB DDR2
Video: Dell NVIDIA GeForce 7800 GTX w/ 256 MB RAM (PCI Express)
OS: Kubuntu 10.04 i386 w/ KDE SC 4.5.0 from Kubuntu PPA
Linux Kernel: 2.6.32-24-lowlatency
NVIDIA driver: 256.52
Screen Resolution: 1280 x 960
X.org: 7.5
Qt: 4.7.0 beta2
Kdenlive: 0.7.7.1+svn20100828.r4776-0ubuntu0~sunab~lucid1 (i386)
MLT: 0.5.7+git20100828.c88a9078-0ubuntu0~sunab~lucid1 (i386)
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files? file icon suspended-leaf.mp4 [^] (11,891,691 bytes) 2010-09-01 02:01

- Relationships

-  Notes
(0005796)
ttill (developer)
2010-09-06 22:01

Cannot reproduce.
Do you have a recent version of ffmpeg?
(0005803)
mrbumpy4096 (reporter)
2010-09-07 00:56

My ffmpeg version as reported by dpkg: 4:SVN-r25054-1

This version was just installed today, but the problem remains. I have discovered that the videos will work fine if I change the container to .mkv using the following command:
ffmpeg -i input.mp4 -acodec copy -vcodec copy output.mkv

A file created with the following command still has the sound glitch:
ffmpeg -i input.mp4 -acodec copy -vcodec copy output.mp4

I can make an MP4 file that works fine if I re-encode the video but pass through the audio with the "-acodec copy" flag.

Please let me know if you need any more information.
(0005883)
ddennedy (developer)
2010-09-22 05:47

ffplay demonstrates problems seeking too. There is nothing we can do; it is a problem in ffmpeg or possibly the "tool" generating the file.

- Issue History
Date Modified Username Field Change
2010-09-01 02:01 mrbumpy4096 New Issue
2010-09-01 02:01 mrbumpy4096 File Added: suspended-leaf.mp4
2010-09-06 22:01 ttill Note Added: 0005796
2010-09-06 22:01 ttill Status new => feedback
2010-09-07 00:56 mrbumpy4096 Note Added: 0005803
2010-09-07 00:56 mrbumpy4096 Status feedback => new
2010-09-22 05:47 ddennedy Note Added: 0005883
2010-09-22 05:47 ddennedy Status new => resolved
2010-09-22 05:47 ddennedy Resolution open => not fixable
2010-09-22 05:47 ddennedy Assigned To => ddennedy
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker