Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001810KdenliveMLTpublic2010-09-11 23:082010-09-18 21:45
Reportermcfrisk 
Assigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusnewResolutionopen 
Platformx86OSDebian LinuxOS Versionunstable
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001810: audio related crash
DescriptionHit this while previewing a timeline with two wav files on audio tracks and some JPG images with pan and zoom and transitions in between.
Steps To ReproduceDon't know exactly, maybe timing related.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filestxt file icon kdenlive_crash_20100911_03.txt [^] (32,208 bytes) 2010-09-11 23:08 [Show Content]
txt file icon melt_crash_20100912.txt [^] (27,536 bytes) 2010-09-11 23:57 [Show Content]
txt file icon kdenlive_crash_20100913.txt [^] (21,855 bytes) 2010-09-13 20:29 [Show Content]
txt file icon melt_crash_20100915.txt [^] (8,847 bytes) 2010-09-15 16:49 [Show Content]

- Relationships

-  Notes
(0005813)
mcfrisk (reporter)
2010-09-11 23:57

The crash repeats when rendering with melt version 7a0a48a713e0a03fbbd9cd940c7a50a127fd32ff.
(0005814)
mcfrisk (reporter)
2010-09-12 13:23

Rendering with melt v0.5.6 succeeds without problems.
(0005829)
mcfrisk (reporter)
2010-09-13 18:19

Latest melt no longer crashes, this is now fixed. I used commit 10151cdd8dd97f9554add8222275ac340f8c7365.
(0005832)
mcfrisk (reporter)
2010-09-13 20:29

Blah, don't know if this is fixed after all. melt can render my project but kdenlive crashes when opening it.
(0005844)
mcfrisk (reporter)
2010-09-15 16:49

Also melt from commit 10151cdd8dd97f9554add8222275ac340f8c7365 crashed on me. Maybe this is a timing related race. Hopefully one of my rendering tries will succeed.
(0005845)
mcfrisk (reporter)
2010-09-16 08:17

Full debug log and backtrace and gdb stuff (this == NULL in producer_avformat.c:1924) of melt rendering my project is here:

http://mcfrisk.kapsi.fi/media/2010/melt_audio_crash_trace.txt.gz [^]

This has something to do with audio clip handling and wav files, maybe concurrency within avformat module or hopefully not deeper in mlt.
(0005846)
mcfrisk (reporter)
2010-09-16 14:05

Tried rendering with mlt v0.5.6 and it succeeds but timeline is not the same, clips have moved here and there and in and out points have changed. Maybe the mlt and kdenlive project files should be checked to be compatible with differenct mlt and kdenlive versions.
(0005857)
mcfrisk (reporter)
2010-09-18 21:45

Found a workaround: deleted one audio track completely as it only contained a few wav clips in mute mode. Now rendering succeeds though I can see a few rendering bugs when
clip changes from video to a jpg image.

- Issue History
Date Modified Username Field Change
2010-09-11 23:08 mcfrisk New Issue
2010-09-11 23:08 mcfrisk File Added: kdenlive_crash_20100911_03.txt
2010-09-11 23:57 mcfrisk File Added: melt_crash_20100912.txt
2010-09-11 23:57 mcfrisk Note Added: 0005813
2010-09-12 13:23 mcfrisk Note Added: 0005814
2010-09-13 18:19 mcfrisk Note Added: 0005829
2010-09-13 20:29 mcfrisk Note Added: 0005832
2010-09-13 20:29 mcfrisk File Added: kdenlive_crash_20100913.txt
2010-09-15 16:49 mcfrisk Note Added: 0005844
2010-09-15 16:49 mcfrisk File Added: melt_crash_20100915.txt
2010-09-16 08:17 mcfrisk Note Added: 0005845
2010-09-16 14:05 mcfrisk Note Added: 0005846
2010-09-18 21:45 mcfrisk Note Added: 0005857


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker