Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001813KdenliveMLTpublic2010-09-14 09:522011-11-01 18:57
ReporterGranjow 
Assigned ToGranjow 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0001813: FLAC file remains silent
DescriptionTo reproduce:

1. Download the following files to /tmp:
   http://granjow.net/uploads/bugs/Colorscopes.kdenlive [^]
   http://granjow.net/uploads/bugs/Musikdose-24bit.flac [^]
2. Open the project, use placeholders for the missing clips.
3. Press «Play». The flac file (should already be under the cursor) should play.
4. While playing, move the flac file about 1 second ahead (e.g. to 1:24).
   Sound disappears. No way to regain it again except for reloading the project.
Tagsold
Build/Install MethodManual build from SVN
Attached Files

- Relationships
duplicate of 0000416closedddennedy FLAC files - just doesn't work 
has duplicate 0002030closedGranjow FLAC Audio refuses to play after it has been paused in clip monitor / project monitor / timeline but plays first time 

-  Notes
(0005842)
ddennedy (developer)
2010-09-15 05:49

ffmpeg does not support seeking on flac even when muxed into mkv or avi, so that is useless in Kdenlive. Try it ffplay.
(0005879)
ddennedy (developer)
2010-09-22 05:30

I do not plan to make a FLAC producer in MLT. FLAC in mkv or mov does not work either. This will have to wait until there is another mega-producer based on libquicktime, gstreamer, xine, or vlc. The only one I can see coming anytime soon is gstreamer. I can add an audio transcode preset.
(0005893)
ddennedy (developer)
2010-09-22 06:26

I noticed there is a WAV transcode preset, but it is coercing output to 48 KHz.
(0006332)
Granjow (developer)
2011-01-22 17:24

I've had similar problems with WAV a few weeks ago, but now they are gone. I'll close this bug, is this okay?

About the preset, I think 48 kHz is fine, also since source audio is usually WAV anyway and does not need to be transcoded.
(0006852)
Granjow (developer)
2011-06-10 10:45

Tried again (exported the FLAC file from audacity as 24-bit). Worked.

- Issue History
Date Modified Username Field Change
2010-09-14 09:52 Granjow New Issue
2010-09-15 05:49 ddennedy Note Added: 0005842
2010-09-22 05:30 ddennedy Note Added: 0005879
2010-09-22 06:26 ddennedy Note Added: 0005893
2011-01-22 17:20 Granjow Tag Attached: old
2011-01-22 17:24 Granjow Note Added: 0006332
2011-01-22 17:24 Granjow Assigned To => Granjow
2011-01-22 17:24 Granjow Status new => feedback
2011-03-03 06:42 ddennedy Relationship added has duplicate 0002030
2011-03-03 06:44 ddennedy Relationship added duplicate of 0000416
2011-06-10 10:45 Granjow Note Added: 0006852
2011-06-10 10:45 Granjow Status feedback => assigned
2011-06-10 10:45 Granjow Status assigned => resolved
2011-06-10 10:45 Granjow Resolution open => no change required
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:57 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker