Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001825KdenliveFile Loadingpublic2010-09-24 19:362011-06-10 10:49
Reporterfarid 
Assigned Toj-b-m 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64bitOSArchlinuxOS Version
Product Version0.7.8 
Target VersionFixed in Version0.8 
Summary0001825: Segmentation recovering project
Descriptioni got this error while recovering a project:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffd58d8710 (LWP 2826)]
0x00007fffd979957a in consumer_thread () from /usr/lib/mlt/libmltsdl.so

(gdb) bt
#0 0x00007fffd979957a in consumer_thread () from /usr/lib/mlt/libmltsdl.so
#1 0x00007ffff548bcb0 in start_thread () from /lib/libpthread.so.0
0000002 0x00007ffff3db97ad in clone () from /lib/libc.so.6
0000003 0x0000000000000000 in ?? ()

Additional Information(gdb) run
Starting program: /usr/bin/kdenlive
[Thread debugging using libthread_db enabled]
File given: true
Color mode changed to 0
File given: true
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[New Thread 0x7fffd6f3d710 (LWP 2800)]
[New Thread 0x7fffd673c710 (LWP 2801)]
[Thread 0x7fffd6f3d710 (LWP 2800) exited]
[Thread 0x7fffd673c710 (LWP 2801) exited]
[New Thread 0x7fffd673c710 (LWP 2802)]
[New Thread 0x7fffd6f3d710 (LWP 2803)]
[Thread 0x7fffd673c710 (LWP 2802) exited]
[Thread 0x7fffd6f3d710 (LWP 2803) exited]
[New Thread 0x7fffd6f3d710 (LWP 2804)]
[New Thread 0x7fffd673c710 (LWP 2805)]
[Thread 0x7fffd6f3d710 (LWP 2804) exited]
[Thread 0x7fffd673c710 (LWP 2805) exited]
[New Thread 0x7fffd673c710 (LWP 2806)]
[New Thread 0x7fffd6f3d710 (LWP 2807)]
[Thread 0x7fffd673c710 (LWP 2806) exited]
[Thread 0x7fffd6f3d710 (LWP 2807) exited]
[New Thread 0x7fffd6f3d710 (LWP 2808)]
[New Thread 0x7fffd673c710 (LWP 2809)]
[Thread 0x7fffd6f3d710 (LWP 2808) exited]
[Thread 0x7fffd673c710 (LWP 2809) exited]
[New Thread 0x7fffd673c710 (LWP 2810)]
[New Thread 0x7fffd6f3d710 (LWP 2811)]
[Thread 0x7fffd673c710 (LWP 2810) exited]
[Thread 0x7fffd6f3d710 (LWP 2811) exited]
[New Thread 0x7fffd6f3d710 (LWP 2812)]
[New Thread 0x7fffd673c710 (LWP 2813)]
[Thread 0x7fffd6f3d710 (LWP 2812) exited]
[Thread 0x7fffd673c710 (LWP 2813) exited]
[New Thread 0x7fffd673c710 (LWP 2814)]
[New Thread 0x7fffd6f3d710 (LWP 2815)]
[New Thread 0x7fffd58d8710 (LWP 2826)]
[New Thread 0x7fffd50d7710 (LWP 2827)]
[Thread 0x7fffd673c710 (LWP 2814) exited]
[Thread 0x7fffd6f3d710 (LWP 2815) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffd58d8710 (LWP 2826)]
0x00007fffd979957a in consumer_thread () from /usr/lib/mlt/libmltsdl.so
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships
related to 0001711closedddennedy Crash when loading project 

-  Notes
(0005937)
j-b-m (administrator)
2010-09-29 20:44

The crash info is not useful. My guess is that it could be a duplicate of issue 0001711 (SDL concurrency related crash) that was just fixed in MLT. Unless we have other details that would say it is something else, I will close the bug in 1 week.

- Issue History
Date Modified Username Field Change
2010-09-24 19:36 farid New Issue
2010-09-29 20:42 j-b-m Relationship added related to 0001711
2010-09-29 20:44 j-b-m Note Added: 0005937
2010-09-29 20:44 j-b-m Assigned To => j-b-m
2010-09-29 20:44 j-b-m Status new => feedback
2011-03-11 22:32 ttill Status feedback => resolved
2011-03-11 22:32 ttill Resolution open => fixed
2011-03-11 22:32 ttill Fixed in Version => Recent git
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:49 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker