Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001830KdenliveRenderingpublic2010-09-26 23:582011-08-07 22:02
Reporterghomem 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionreopened 
Platform64 bitOSMandriva LinuxOS Version2009
Product Version0.7.7.1 
Target VersionFixed in Version0.7.8 
Summary0001830: artifact storm on certain DNxHD converted videos
DescriptionWe are using ffmpeg to convert from H264 (as produced by a Canon EOS 7D camera) to DNxHD. It works fine most of the times in the sense that:

- kaffeine, mplayer, vlc play the converted videos nicely
- kdenlive imports, edits and renders to h264, mpeg4, mpeg2, etc without any problems.

But on *certain* videos kdenlive imports puts a storm of artifacts both on the preview and on the rendered result in any format.

This doesn't seem to be a problem with ffmpeg as even the files kdenlive has problems with play nicelty with kaffein, mplayer and vlc.

What do these videos have in common? They're all filmed with low light conditions.
Steps To Reproduce- shoot in low light conditions
- convert to DNxHD
- check that it plays fine on regular media players
- import into kdenlive
- observe artifacts on the preview
- observe artifacts on the rendered file

All the relevant information including the project, raw files and rendered file is here:

http://angulosolido.pt/temp/artifact-bug.tar [^]
Additional InformationConversion to DNxHD is done using:

ffmpeg -y -s $RES -r pal -b $BITRATE -threads $THREADS -vcodec dnxhd -qmax $QMAX -acodec copy output/$file -i $file;
TagsNo tags attached.
Build/Install Method(select)
Attached Filespng file icon artifacts.png [^] (806,178 bytes) 2011-03-02 02:47

- Relationships
duplicate of 0001509closedddennedy Each render contains artifacts (white little dots) 

-  Notes
(0005936)
j-b-m (administrator)
2010-09-29 20:38

This was a bug in MLT, which is fixed in current MLT's version. I tested your project and it renders fine with Kdenlive 0.7.8 / MLT 0.5.10
(0006510)
ghomem (reporter)
2011-03-02 02:43
edited on: 2011-03-02 02:46

I upgraded kdenlive and the problem still happens.

Here is the version info:

kdenlive-0.7.8-1xcm14
mlt-0.6.2-1xcm14
ffmpeg-0.6.1-0.1plf14

Note that appart from the extreme example that was referred in this bug report (clip shot in total darkness with a bright smartphone screen appearing) the problem happened previsouly on kdenlive 0.7.7.1 just as the current atachment shows. It happens in *some* dark areas of *some* clips.

(0007149)
ghomem (reporter)
2011-08-07 22:02

Just to let you know that the problem persists (as reported above) and is easily reproducible with different videos.

- Issue History
Date Modified Username Field Change
2010-09-26 23:58 ghomem New Issue
2010-09-29 20:38 j-b-m Note Added: 0005936
2010-09-29 20:38 j-b-m Relationship added duplicate of 0001509
2010-09-29 20:38 j-b-m Status new => resolved
2010-09-29 20:38 j-b-m Fixed in Version => 0.7.8
2010-09-29 20:38 j-b-m Resolution open => duplicate
2010-09-29 20:38 j-b-m Assigned To => j-b-m
2011-03-02 02:43 ghomem Note Added: 0006510
2011-03-02 02:43 ghomem Status resolved => feedback
2011-03-02 02:43 ghomem Resolution duplicate => reopened
2011-03-02 02:46 ghomem Note Edited: 0006510 View Revisions
2011-03-02 02:47 ghomem File Added: artifacts.png
2011-08-07 22:02 ghomem Note Added: 0007149
2011-08-07 22:02 ghomem Status feedback => assigned


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker