Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001845KdenliveUser Interfacepublic2010-10-15 15:092011-06-10 10:48
Reporternadavkav 
Assigned To 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionnot fixable 
Platform64 bitOSDebian LinuxOS Version4.0
Product Version0.7.8 
Target VersionFixed in Version0.8 
Summary0001845: support mplayer-mt
Descriptionwhen i play captured MOV files from my D5 cannon camera inside kdenlive it is played jerky (allot of skip frames and hang ups) when i use mplayer-mt it works great.

i would like to be able to choose the player for the monitor window
Tagscanon, h264, mov, mplayer
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0005968)
nadavkav (reporter)
2010-10-16 00:36

here is the video file details, from the mplayer-mt version:

MPlayer git-ab94fc6-4.4.3 (C) 2000-2010 MPlayer Team

libavformat file format detected.
ID_VIDEO_ID=0
[lavf] stream 0: video (h264), -vid 0
ID_AUDIO_ID=0
[lavf] stream 1: audio (pcm_s16le), -aid 0, -alang eng
VIDEO: [H264] 1920x1088 24bpp 23.976 fps 46400.4 kbps (5664.1 kbyte/s)
Clip info:
 major_brand: qt
ID_CLIP_INFO_NAME0=major_brand
ID_CLIP_INFO_VALUE0=qt
 minor_version: 537331968
ID_CLIP_INFO_NAME1=minor_version
ID_CLIP_INFO_VALUE1=537331968
 compatible_brands: qt CAEP
ID_CLIP_INFO_NAME2=compatible_brands
ID_CLIP_INFO_VALUE2=qt CAEP
ID_CLIP_INFO_N=3
ID_FILENAME=/root/video/hd-samples/avishag - 100EOS5D/MVI_6206.MOV
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=H264
ID_VIDEO_BITRATE=46400416
ID_VIDEO_FPS=23.976
ID_AUDIO_FORMAT=1
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_SEEKABLE=1
ID_CHAPTERS=0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
ID_VIDEO_CODEC=ffh264
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 48000 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->192000)
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=pcm
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 1920x1088 => 1920x1088 Planar YV12
(0005969)
nadavkav (reporter)
2010-10-16 00:42

this is the kind of video Canon D5 Mark II can generate:
(http://www.dpreview.com/news/0809/08091705canon_5dmarkII.asp [^])

• 1920 x 1080 (16:9) up to 12 mins (Quicktime 1080p H.264; 38.6 Mbits/sec)
• 640 x 480 (4:3) up to 24 mins (Quicktime 480p H.264; 17.3 Mbits/sec)
• Max file size 4 GB
• Quicktime MOV format (H.264 video, PCM sound)
• 30 fps
(0006020)
ttill (developer)
2010-11-04 21:38

Playback is done through a MLT module (SDL), but the problem is not the output itself but rather the different requirements. Therefore even if it was possible to redirect the frame generated by MLT to mplayer there would be no advantage.
In video editing you have to have frame accurate seeking which is not important for a media player.
Anyways MLT will get the "mt" (multi threaded) part too in the near future.
(0006021)
nadavkav (reporter)
2010-11-04 22:05

"MLT will get the "mt" (multi threaded) part too in the near future. "

Excellent news!

Thanks :-)

(please close this issue)

- Issue History
Date Modified Username Field Change
2010-10-15 15:09 nadavkav New Issue
2010-10-16 00:36 nadavkav Note Added: 0005968
2010-10-16 00:42 nadavkav Note Added: 0005969
2010-10-16 00:45 nadavkav Tag Attached: canon
2010-10-16 00:45 nadavkav Tag Attached: h264
2010-10-16 00:45 nadavkav Tag Attached: mov
2010-10-16 00:45 nadavkav Tag Attached: mplayer
2010-11-04 21:38 ttill Note Added: 0006020
2010-11-04 22:05 nadavkav Note Added: 0006021
2010-11-04 22:17 ttill Status new => resolved
2010-11-04 22:17 ttill Resolution open => not fixable
2010-11-04 22:17 ttill Fixed in Version => Recent git
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:48 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker