Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000185KdenliveRenderingpublic2008-10-08 09:032008-11-12 22:22
Reportermtxd 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.0Fixed in Version0.7.0 
Summary0000185: Rendering does not start
DescriptionI added several *.m2t files to the project -> pressed Render -> selected mpeg4 -> pressed start, but nothing happens. The path for saving has write permissions.

P.S. There is no mpeg4 16:9 render profiles either.
Additional InformationRevision: 2437
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0000327)
administrator (administrator)
2008-10-08 10:14
edited on: 2008-10-08 10:15

What do you mean: does not start ? you should at least see a popup message saying that the rendering started...
Is it a duplicate of bug 183 (see http://www.kdenlive.org/mantis/view.php?id=183 [^] )?

(0000329)
mtxd (reporter)
2008-10-08 10:21
edited on: 2008-10-08 10:25

I don't think it is a duplicate.
I mean no messages, no popups. Just a pressed button effect.
MLT is the latest (1183), but it doesn't help.

(0000334)
mtxd (reporter)
2008-10-08 12:35
edited on: 2008-10-08 12:36

Compiled with MLT 1184, but it doesn't help. I press start button, and nothing happens. Running from console doesn't show anything as well.

(0000336)
volker_holthaus (reporter)
2008-10-08 12:51

When i rendering a project there are also no dialog or message displayed, but kdenlive render the movie in the background.
You can close the dialog and view the rendering process in a filemanager (the filesize increase).
(0000337)
mtxd (reporter)
2008-10-08 12:56

Shouldn't it show a progress bar or something? No file was created.
(0000339)
mtxd (reporter)
2008-10-08 13:17
edited on: 2008-10-08 13:19

Can it be because of incorrect options? Running
ffmpeg -f avi -minrate 0 -b 8000k -ab 384000 -ar 48000 -s 720x576 -vcodec mpeg4 -mbd 2 -mv4 1 progressive=1 -i /archive/video/camera/kdenlive/temp/dvgrab-2008.09.09_20-06-53.m2t /archive/video/camera/capture.avi
from console went fine. These are slightly modified options for mpeg4 720x576 from kdenlive rendering templates. Or maybe it just cant find ffmpeg because of incorrect location? Anyway, it should show some kind of error...

(0000342)
administrator (administrator)
2008-10-08 13:26

You can see the progress of a rendering job if you start the "kuiserver" application before starting to render. kuiserver is supposed to be an applet to manage all jobs in KDE4, but is currently not finished and should be functionnal in KDE 4.2. However it works fine for Kdenlive, but you need to start it manually.

The rendering should report an error if it crashes. Can you check the path to inigo defined in Kdenlive Settings (page Environment) ? Is the app really in that place ?

Then you can try the following command:

inigo /archive/video/camera/kdenlive/temp/dvgrab-2008.09.09_20-06-53.m2t -consumer avformat:test.avi f=avi minrate=0 b=600k ab=128000 ar=32000 s=160x120 vcodec=mpeg4 mbd=2 trell=1 mv4=1 progressive=1

This is the command issued by kdenlive to render a project...
(0000343)
mtxd (reporter)
2008-10-08 13:59
edited on: 2008-10-08 14:16

inigo '...options...' starts, counts "Current Position" and exits. The output file is correct. kuiserver doesn't show any progress when I press Start button in render window.

> Can you check the path to inigo defined in Kdenlive Settings
It wasn't...

Now it starts rendering, but never stops with no output file.

By the way, everything was compiled using your scripts in 0000172 bug report.

(0000347)
mtxd (reporter)
2008-10-10 10:16

Any thoughts on how to make it render project in a normal way?
(0000348)
administrator (administrator)
2008-10-10 12:19

NO, I am a bit puzzled here. Can you try the same inigo command I wrote in my previous comment, but instead of the m2t file, give your .kdenlive project file, like this:

inigo project.kdenlive -consumer avformat:test.avi f=avi minrate=0 b=600k ab=128000 ar=32000 s=160x120 vcodec=mpeg4 mbd=2 trell=1 mv4=1 progressive=1

Does it work?
(0000350)
mtxd (reporter)
2008-10-10 13:01

The test.avi file has been successfully generated.
(0000390)
mtxd (reporter)
2008-10-13 21:39

What can I try more? It's really weird, all parts of compilation work fine. Separately :)
(0000392)
administrator (administrator)
2008-10-13 22:06

Ok, I just updated the Kdenlive source to give more debug info. Please update to latest svn revision (2465)

Then, start Kdenlive from a terminal, add a colour clip to timeline and press the render->start button.

In the terminal, you should see a line like this:

//STARTING RENDERING: true , "/usr/local//bin/inigo" , "hdv_1080_50i" , "avformat" , "-" , "/tmp/kde-xxx/kdenliveO16056.westley" , "/home/xxx/untitled.m2t" , () , ("f=mpegts", "vcodec=mpeg2video", "s=1440x1080", "b=19700k", "ab=384000", "g=12", "ildct=1", "ilme=1", "profile=hdv_1080_50i") , -1 , -1

Please copy & paste your output here.
(0000397)
mtxd (reporter)
2008-10-14 07:57
edited on: 2008-10-14 08:16

It works now. You should add some checks if inigo and other part exist.

(0000400)
administrator (administrator)
2008-10-14 09:31

Check for inigo added

- Issue History
Date Modified Username Field Change
2008-10-08 09:03 mtxd New Issue
2008-10-08 10:14 administrator Note Added: 0000327
2008-10-08 10:15 administrator Note Edited: 0000327
2008-10-08 10:21 mtxd Note Added: 0000329
2008-10-08 10:23 mtxd Note Edited: 0000329
2008-10-08 10:25 mtxd Note Edited: 0000329
2008-10-08 12:35 mtxd Note Added: 0000334
2008-10-08 12:36 mtxd Note Edited: 0000334
2008-10-08 12:51 volker_holthaus Note Added: 0000336
2008-10-08 12:56 mtxd Note Added: 0000337
2008-10-08 13:17 mtxd Note Added: 0000339
2008-10-08 13:19 mtxd Note Edited: 0000339
2008-10-08 13:26 administrator Note Added: 0000342
2008-10-08 13:59 mtxd Note Added: 0000343
2008-10-08 14:03 mtxd Note Edited: 0000343
2008-10-08 14:07 mtxd Note Edited: 0000343
2008-10-08 14:09 mtxd Note Edited: 0000343
2008-10-08 14:11 mtxd Note Edited: 0000343
2008-10-08 14:16 mtxd Note Edited: 0000343
2008-10-10 10:16 mtxd Note Added: 0000347
2008-10-10 12:19 administrator Note Added: 0000348
2008-10-10 13:01 mtxd Note Added: 0000350
2008-10-13 21:39 mtxd Note Added: 0000390
2008-10-13 22:06 administrator Note Added: 0000392
2008-10-14 07:57 mtxd Note Added: 0000397
2008-10-14 08:16 mtxd Note Edited: 0000397
2008-10-14 09:31 administrator Note Added: 0000400
2008-10-14 09:31 administrator Status new => resolved
2008-10-14 09:31 administrator Resolution open => fixed
2008-10-23 00:20 madsdyd Target Version => 0.7.0
2008-10-23 00:22 madsdyd Status resolved => closed
2008-11-12 22:22 madsdyd Fixed in Version => 0.7.0


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker