Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001868KdenliveUser Interfacepublic2010-11-01 22:222011-11-01 18:56
Reporterrhk 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
Platform64-bitOSKubuntuOS Version10.10
Product Version0.7.8 
Target VersionFixed in Version0.8.2 
Summary0001868: Crash on start
DescriptionCrash on start.

Application: kdenlive (0.7.8)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu 10.10


The crash can be reproduced every time.

-- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[KCrash Handler]
0000006 mlt_properties_find (this=0x0, name=0x705fec "resize") at mlt_properties.c:348
0000007 mlt_properties_fetch (this=0x0, name=0x705fec "resize") at mlt_properties.c:414
0000008 0x00007f41ae7e46ac in mlt_properties_set_int (this=0x0, name=0x705fec "resize", value=0) at mlt_properties.c:738
0000009 0x00007f41ae5ca76c in Mlt::Properties::set(char const*, int) () from /usr/local/lib/libmlt++.so.3
0000010 0x00000000004a6fed in Render::buildConsumer (this=0x170a6e0, profileName=<value optimized out>) at /build/buildd/kdenlive-0.7.8/src/renderer.cpp:199
0000011 0x00000000004a7c98 in Render::Render (this=0x170a6e0, rendererName=..., winid=<value optimized out>, profile=..., parent=<value optimized out>) at /build/buildd/kdenlive-0.7.8/src/renderer.cpp:104
0000012 0x000000000048c449 in Monitor::Monitor (this=0x1796b40, name=..., manager=<value optimized out>, profile=..., parent=<value optimized out>) at /build/buildd/kdenlive-0.7.8/src/monitor.cpp:149
0000013 0x000000000046402c in MainWindow::MainWindow (this=0x15eb190, MltPath=<value optimized out>, Url=<value optimized out>, parent=<value optimized out>, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /build/buildd/kdenlive-0.7.8/src/mainwindow.cpp:181
0000014 0x0000000000449e3c in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/kdenlive-0.7.8/src/main.cpp:83
Steps To ReproduceFirst installed kdenlive from Ubuntu repositories to bump into this: https://bugs.launchpad.net/ubuntu/+source/kdenlive/+bug/363430?comments=all [^]

Then added sunab PPA and installed from there to bump in to the crash-on-start, reported here.
Additional InformationPackage: kdenlive
Source: kdenlive
Priority: optional
Section: video
Installed-Size: 3616
Maintainer: Olivier Banus <sunab@free.fr>
Architecture: amd64
Version: 0.7.8-0ubuntu0~sunab~maverick1
Replaces: kdenlive-data (<< 0.7)
Depends: kdebase-runtime, libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libkdecore5 (>= 4:4.4.85), libkdeui5 (>= 4:4.3.4), libkio5 (>= 4:4.5.1), libknewstuff3-4 (>= 4:4.4.0), libknotifyconfig4 (>= 4:4.3.4), libkrossui4 (>= 4:4.3.4), libmlt++3 (>= 0.5.10), libmlt2 (>= 0.5.10), libqt4-dbus (>= 4:4.6), libqt4-network (>= 4:4.6), libqt4-svg (>= 4:4.6), libqt4-xml (>= 4:4.6), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.2), libstdc++6 (>= 4.2.1), libx11-6, libxau6, libxdmcp6, kdenlive-data (= 0.7.8-0ubuntu0~sunab~maverick1), melt (>= 0.5.10), libmlt-data (>= 0.5.10), ffmpeg, libavdevice-extra-52, libavfilter-extra-1, libswscale-extra-0, libpostproc-extra-51, swh-plugins, dvgrab, frei0r-plugins, recordmydesktop, dvdauthor, genisoimage
Filename: pool/main/k/kdenlive/kdenlive_0.7.8-0ubuntu0~sunab~maverick1_amd64.deb
Size: 1357458
MD5sum: 502fd29527cbc0e8f1f244122c930d66
SHA1: b484211b08c72dc10d6dcab06aedfbe28016e2ae
Description: a non-linear video editor
 Kdenlive is a non-linear video editing suite, which supports DV, HDC and much
 more formats.
 It main features are:
 Guides and marker for organizing timelines
 Copy and paste support for clips, effects and transitions
 Real time changes
 Firewire and Video4Linux capture
 Screen grabbing
 Exporting to any by FFMPEG supported format
Original-Maintainer: Patrick Matthäi <pmatthaei@debian.org>
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0006032)
ddennedy (developer)
2010-11-12 05:21

The MLT SDL plugin is not loading on your system for some reason. What is the output of
ldd /usr/lib/mlt/libmltsdl.so
(0006038)
rhk (reporter)
2010-11-12 05:59

linux-vdso.so.1 => (0x00007fff9313c000)
        libmlt.so.2 => /usr/local/lib/libmlt.so.2 (0x00007fd29fd98000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00007fd29fb7b000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fd29f844000)
        libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0x00007fd29f5af000)
        libc.so.6 => /lib/libc.so.6 (0x00007fd29f22c000)
        libdl.so.2 => /lib/libdl.so.2 (0x00007fd29f027000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fd2a01f7000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fd29ee0a000)
        libm.so.6 => /lib/libm.so.6 (0x00007fd29eb87000)
        libpulse-simple.so.0 => /usr/lib/libpulse-simple.so.0 (0x00007fd29e982000)
        libpulse.so.0 => /usr/lib/libpulse.so.0 (0x00007fd29e741000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fd29e53e000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fd29e337000)
        libpulsecommon-0.9.21.so => /usr/lib/libpulsecommon-0.9.21.so (0x00007fd29e0eb000)
        librt.so.1 => /lib/librt.so.1 (0x00007fd29dee3000)
        libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0x00007fd29dce0000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x00007fd29dac5000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x00007fd29d8bc000)
        libXtst.so.6 => /usr/lib/libXtst.so.6 (0x00007fd29d6b4000)
        libxcb-atom.so.1 => /usr/lib/libxcb-atom.so.1 (0x00007fd29d4af000)
        libwrap.so.0 => /lib/libwrap.so.0 (0x00007fd29d2a4000)
        libsndfile.so.1 => /usr/lib/libsndfile.so.1 (0x00007fd29d03e000)
        libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00007fd29cdfc000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x00007fd29cbf6000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fd29c9e4000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x00007fd29c7d4000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x00007fd29c5ba000)
        libFLAC.so.8 => /usr/lib/libFLAC.so.8 (0x00007fd29c36f000)
        libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x00007fd29bea0000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007fd29bc74000)
        libogg.so.0 => /usr/lib/libogg.so.0 (0x00007fd29ba6c000)
(0006041)
ddennedy (developer)
2010-11-12 07:04

hmm that looks ok
Does 'melt some.video' play? If not, does 'ffplay some.video' (which also uses SDL)?
(0006053)
rhk (reporter)
2010-11-14 21:50

ffplay works, melt tells me 'failed to load "movie.mov"'
(0006062)
ddennedy (developer)
2010-11-14 23:21

Your ffmpeg plugin for MLT is broken. Maybe you installed some set of incompatible ffmpeg packages.

To check if SDL is also a problem in MLT (to verify my original guess), run 'melt noise:'
(0006068)
rhk (reporter)
2010-11-15 22:05

melt noise:
and
melt noise
give me absolutely nothing.

I guess it's possible that I have something weird installed.. Will check.. (=reinstall everything..) Thanks anyway..
(0006101)
ddennedy (developer)
2010-11-20 08:59

bad environment/install - not a bug

- Issue History
Date Modified Username Field Change
2010-11-01 22:22 rhk New Issue
2010-11-12 05:21 ddennedy Note Added: 0006032
2010-11-12 05:59 rhk Note Added: 0006038
2010-11-12 07:04 ddennedy Note Added: 0006041
2010-11-14 21:50 rhk Note Added: 0006053
2010-11-14 23:21 ddennedy Note Added: 0006062
2010-11-15 22:05 rhk Note Added: 0006068
2010-11-20 08:59 ddennedy Note Added: 0006101
2010-11-20 08:59 ddennedy Status new => resolved
2010-11-20 08:59 ddennedy Resolution open => no change required
2010-11-20 08:59 ddennedy Assigned To => ddennedy
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker