Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001869KdenliveUser Interfacepublic2010-11-03 04:462013-04-07 08:45
Reportergholtslander 
Assigned Toptitmain 
PriorityurgentSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSopensuseOS Version11.3
Product Version0.7.8 
Target VersionFixed in Version0.9.6 
Summary0001869: opening a pre-existing project file crahses kdenlive immediately when opening a pre-existing 0.7.7 project file
Descriptionopening a pre-existing project file crahses kdenlive immediately
Steps To Reproduceopen any pre-existing project file done with previous version of kdenlive and program crashes
Additional InformationDoes not crash if a new project is created and saved and then re-opened.

I have a large number of projects that need revisions so this is a serious isssue
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files? file icon kdenlive-20101102.kcrash [^] (8,202 bytes) 2010-11-03 04:46 [Show Content]

- Relationships

-  Notes
(0006018)
jem (reporter)
2010-11-03 10:15
edited on: 2010-11-04 07:52

This looks exactly like bug 0001711, which should be fixed in SVN.

The bug is caused by a race condition in the mlt code, and is not related to with which version the project is created. You could try to work around the problem in the following way: start kdenlive without loading a project, close the project and clip monitor views, and then open the project. Now you can re-open the views, and the program should work without crashing.

(0008785)
ptitmain (developer)
2012-12-14 23:50

Hi,

@gholtslander: did you manage to load your projects using the advice of jem ?

Maybe more recent versions of kdenlive are able to open old projects.
(0009192)
ptitmain (developer)
2013-02-06 07:26

Hi,
as we have no more feedback about this bug, I think we should close this bug. I hope that gholtslander succeeded in opening old files.

- Issue History
Date Modified Username Field Change
2010-11-03 04:46 gholtslander New Issue
2010-11-03 04:46 gholtslander File Added: kdenlive-20101102.kcrash
2010-11-03 10:15 jem Note Added: 0006018
2010-11-04 07:52 jem Note Edited: 0006018 View Revisions
2012-12-14 23:50 ptitmain Note Added: 0008785
2012-12-14 23:50 ptitmain Assigned To => ptitmain
2012-12-14 23:50 ptitmain Status new => feedback
2013-02-06 07:26 ptitmain Note Added: 0009192
2013-02-06 07:26 ptitmain Status feedback => resolved
2013-02-06 07:26 ptitmain Resolution open => fixed
2013-04-07 08:45 j-b-m Fixed in Version => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker