Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001880KdenliveEffectspublic2010-11-16 15:342011-06-10 10:50
Reporterjjfro 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntu LinuxOS Version10.04
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0001880: Adding Pan & Zoom effect to a title clip causes the text to stretch horizonally.
DescriptionI have title clips that contain just text and when I add the Pan & Zoom effect to the clips, it stretches the text horizontally, even though I don't change any other properties of the effect; i.e., it is still sized as 100%.
Steps To ReproduceCreate a title clip with one line of text that stretches across most of the editor window.
Center the text and click OK.
Add it to the timeline.
Add the same clip again to the timeline right next to this one.
Add the Pan & Zoom effect to the first clip and just leave the defaults.
Play both clips and you will see how the text is stretched in the one with the effect and not with the raw clip.
Additional InformationBug was not present in 0.7.8.
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Files

- Relationships

-  Notes
(0006076)
jjfro (reporter)
2010-11-19 01:11

This appears to be an issue with MLT 0.5.11. After I first discovered the problem, I downgraded back to Kdenlive 0.7.8 by uninstalling 0.7.9, changing the PPA and reinstalling. When I reloaded my project in Kdenlive and put the playhead on one of the title clips that had the Pan & Zoom effect, I could see that the text was still stretched. So I checked the version of MLT and it was still 0.5.11. So I uninstalled and reinstalled to get back to 0.5.10. Then when I loaded my project and looked at the clips in question, they were no longer stretched.
(0006090)
ddennedy (developer)
2010-11-20 06:58

Unable to reproduce using a HD 720p 29.97 project setting. I am using mlt git head (probably newer than your pre-release 0.5.11 package). What project setting are you using? There was some rework in the plugin behind Pan & Zoom to fix some other bugs that could have affected this, but your package could have grabbed MLT at an interim point, or it could be affected by your project setting.
(0006091)
ddennedy (developer)
2010-11-20 07:10

I reproduced this with a DV NTSC project.
(0006092)
ddennedy (developer)
2010-11-20 07:22

Fixed in MLT git commit 40c6306.

- Issue History
Date Modified Username Field Change
2010-11-16 15:34 jjfro New Issue
2010-11-19 01:11 jjfro Note Added: 0006076
2010-11-20 06:58 ddennedy Note Added: 0006090
2010-11-20 06:58 ddennedy Assigned To => ddennedy
2010-11-20 06:58 ddennedy Status new => feedback
2010-11-20 07:10 ddennedy Note Added: 0006091
2010-11-20 07:22 ddennedy Note Added: 0006092
2010-11-20 07:22 ddennedy Status feedback => resolved
2010-11-20 07:22 ddennedy Fixed in Version => 0.7.9
2010-11-20 07:22 ddennedy Resolution open => fixed
2011-04-26 21:57 j-b-m Fixed in Version 0.7.9 => 0.8
2011-06-10 10:50 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker