Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001884KdenliveEffectspublic2010-11-17 15:072011-06-10 10:50
Reporterstreumix 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.04
Product Version0.7.8 
Target VersionFixed in Version0.8 
Summary0001884: f0r_param_color of frei0r plugins is swapping R/B channels in case of F0R_COLOR_MODEL_BGRA8888
DescriptionAccording to the frei0r spec, http://frei0r.dyne.org/codedoc/html/structf0r__param__color.html, [^] the color parameter should be independant of the choosen color model. It's defined as

typedef struct f0r_param_color
{
 float r;
 float g;
 float b;
} f0r_param_color_t;

In case of F0R_COLOR_MODEL_RGBA8888, it's working correct. But once a plugin is defined with F0R_COLOR_MODEL_BGRA8888, R and B channel is swapped.
Steps To ReproduceIt's not possible to reproduce the issue with offical frei0r filters at the moment, because the only one using f0r_param_color in combination with F0R_COLOR_MODEL_BGRA8888 is tehroxx0r, which seems to be missing in kdenlive. Please see bug 0001883.

Additional InformationIf required, I can prepare and upload a custom (dummy) filter to demonstrate the issue.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0006074)
streumix (reporter)
2010-11-17 21:12

Further testing turned out that it's not the f0r_param_color being mixed up,
it's the pixel format itself in case of requesting the BGRA888 color model. Browsing the code of the responsible frei0r host, mlt, I couldn't find any reference to either F0R_COLOR_MODEL_BGRA8888 or F0R_COLOR_MODEL_RGBA8888. Therefore, I'm suspecting mlt to ignore the requested color model.

I'm going to place a bug report for mlt, too.
(0006075)
ddennedy (developer)
2010-11-18 08:46

Fixed in mlt git. See the bug there:
https://sourceforge.net/tracker/?func=detail&atid=613414&aid=3111014&group_id=96039 [^]

- Issue History
Date Modified Username Field Change
2010-11-17 15:07 streumix New Issue
2010-11-17 21:12 streumix Note Added: 0006074
2010-11-18 08:46 ddennedy Note Added: 0006075
2010-11-18 08:46 ddennedy Status new => resolved
2010-11-18 08:46 ddennedy Fixed in Version => 0.7.9
2010-11-18 08:46 ddennedy Resolution open => fixed
2010-11-18 08:46 ddennedy Assigned To => ddennedy
2011-04-26 21:57 j-b-m Fixed in Version 0.7.9 => 0.8
2011-06-10 10:50 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker