Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001886KdenliveFile Loadingpublic2010-11-18 04:022011-11-01 18:56
Reporterglenns530 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
Platform32bit AMDOSMandriva LinuxOS Version2010.1
Product Version0.7.7.1 
Target VersionFixed in Version0.8.2 
Summary0001886: Importing mpeg-2 clip crashing Kdenlive.
DescriptionWhen I try to import an mpeg-2 video file as a clip, Kdenlive crashes everytime. I was able to import a .mov file.
Camera is a Panasonic SDR-T55K.
File imported using ModCopy in wine or simple copy with dolphin and rename extension to mpeg.
Using FFMPEG from plf.
Steps To ReproduceImport mpeg file from Camera.
Create new HD 720p 29.97fps project.
Click add clip.
Select the clip in the open file dialog.
Click Open.
Application crashes.
Additional InformationApplication: Kdenlive (kdenlive), signal: Illegal instruction
[Current thread is 1 (Thread 0xb4ebe6d0 (LWP 25517))]

Thread 3 (Thread 0xb0a81b70 (LWP 25529)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0xb69f3fa2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
0000002 0xb77c3259 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
0000003 0xb77c33b8 in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.2
0000004 0xb2168634 in ?? () from /usr/lib/mlt/libmltsdl.so
0000005 0xb69efae5 in start_thread () from /lib/i686/libpthread.so.0
0000006 0xb5d5703e in clone () from /lib/i686/libc.so.6

Thread 2 (Thread 0xb1282b70 (LWP 25530)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0xb69f3c75 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
0000002 0xb2167edb in ?? () from /usr/lib/mlt/libmltsdl.so
0000003 0xb69efae5 in start_thread () from /lib/i686/libpthread.so.0
0000004 0xb5d5703e in clone () from /lib/i686/libc.so.6

Thread 1 (Thread 0xb4ebe6d0 (LWP 25517)):
[KCrash Handler]
0000006 0xb4c21678 in ?? () from /usr/lib/mlt/libmltxine.so
0000007 0xb4c22fb5 in filter_plane () from /usr/lib/mlt/libmltxine.so
0000008 0xb4c23980 in deinterlace_yadif () from /usr/lib/mlt/libmltxine.so
0000009 0xb4c23c5a in ?? () from /usr/lib/mlt/libmltxine.so
0000010 0xb77b4a76 in mlt_frame_get_image () from /usr/lib/libmlt.so.2
0000011 0xb26fc242 in ?? () from /usr/lib/mlt/libmltcore.so
0000012 0xb77b4a76 in mlt_frame_get_image () from /usr/lib/libmlt.so.2
0000013 0xb26fc841 in ?? () from /usr/lib/mlt/libmltcore.so
0000014 0xb77b4a76 in mlt_frame_get_image () from /usr/lib/libmlt.so.2
0000015 0xb779d307 in Mlt::Frame::get_image(mlt_image_format&, int&, int&, int) () from /usr/lib/libmlt++.so.3
0000016 0x080d3f9c in ?? ()
0000017 0x080d507b in ?? ()
0000018 0xb6b70ded in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
0000019 0xb6b7fc5a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
0000020 0x080a6627 in ?? ()
0000021 0x080abcda in ?? ()
0000022 0x080b0bf8 in ?? ()
0000023 0xb6b70ded in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
0000024 0xb6b7fc5a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
0000025 0xb6bd2b75 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
0000026 0xb6b87fa6 in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
0000027 0xb6b7c764 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
0000028 0xb6029f1c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000029 0xb6030d58 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000030 0xb74c74a1 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000031 0xb6b6ba9e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000032 0xb6b9bc8a in ?? () from /usr/lib/libQtCore.so.4
0000033 0xb6b988f2 in ?? () from /usr/lib/libQtCore.so.4
0000034 0xb55becbe in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000035 0xb55c29f8 in ?? () from /usr/lib/libglib-2.0.so.0
0000036 0xb55c2b9e in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000037 0xb6b985c1 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000038 0xb60eabda in ?? () from /usr/lib/libQtGui.so.4
0000039 0xb6b6a0fd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000040 0xb6b6a549 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000041 0xb6b6e6d0 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000042 0xb6029fc4 in QApplication::exec() () from /usr/lib/libQtGui.so.4
0000043 0x08080649 in ?? ()
0000044 0xb5c95b96 in __libc_start_main () from /lib/i686/libc.so.6
0000045 0x080780c1 in _start ()
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon MOV-20101112-202516.MPG [^] (11,712,512 bytes) 2010-11-18 04:02

- Relationships

-  Notes
(0006089)
ddennedy (developer)
2010-11-20 06:52

Unable to reproduce using clip uploaded. I am using MLT git head and Kdenlive svn head with FFmpeg SVN-r25146.

You say you are using ffmpeg from the PLF repo, but where did you get MLT? MLT needs to be built against the same version of FFmpeg that you are using.
(0006105)
glenns530 (reporter)
2010-11-21 02:23

I'm using the Mandriva build RPM for MLT. They don't have FFMPEG, but PLF does. PLF does not appear to have MLT.
I'm transcoding the files to mov files for now.
(0006130)
glenns530 (reporter)
2010-11-28 19:50

I found RPMS with new versions of MLT and Kdenlive for Mandriva 2010.1. Installing them has resolved this issue.

- Issue History
Date Modified Username Field Change
2010-11-18 04:02 glenns530 New Issue
2010-11-18 04:02 glenns530 File Added: MOV-20101112-202516.MPG
2010-11-20 06:52 ddennedy Note Added: 0006089
2010-11-20 08:39 ddennedy Assigned To => ddennedy
2010-11-20 08:39 ddennedy Status new => assigned
2010-11-21 02:23 glenns530 Note Added: 0006105
2010-11-28 19:50 glenns530 Note Added: 0006130
2010-11-29 05:51 ddennedy Status assigned => resolved
2010-11-29 05:51 ddennedy Resolution open => no change required
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker