Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001890KdenliveUser Interfacepublic2010-11-19 20:262011-06-10 10:50
Reportereddrog 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32bit intel Ubuntu 10.10OSOS Version
Product Version0.7.8 
Target VersionFixed in Version0.8 
Summary0001890: Crash on deselecting "force pixel ration" in the clip properties
DescriptionThere are to reasons that cause a crash o kdenlive:

1) Entering a number with a "." instead of "," in Clip-Properties->Extended->Force Pixel Ratio e.g. 1.33 instead of 1,33
(Sorry, I've translated from german)

2) Selecting Clip-Properties->Extended->Force Pixel Ratio e.g. 1,33 works fine. Saving -> ok. If I deselect this check box and try to save it kdenlive crashes. I've tried this several times it always crashed.
Additional InformationApplication: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7833710 (LWP 5606))]

Thread 6 (Thread 0xb7472b70 (LWP 5607)):
#0 0x0057b416 in __kernel_vsyscall ()
#1 0x02542df6 in poll () from /lib/libc.so.6
0000002 0x0120ea1b in g_poll () from /lib/libglib-2.0.so.0
0000003 0x0120143c in ?? () from /lib/libglib-2.0.so.0
0000004 0x01201ba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
0000005 0x067806b4 in ?? () from /usr/lib/libgio-2.0.so.0
0000006 0x0122848f in ?? () from /lib/libglib-2.0.so.0
0000007 0x0021ecc9 in start_thread () from /lib/libpthread.so.0
0000008 0x025516be in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb07fbb70 (LWP 6146)):
#0 0x0057b416 in __kernel_vsyscall ()
#1 0x00223884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0x02c9ab3f in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xb3137b70 (LWP 6148)):
#0 0x0798c6d7 in ?? () from /usr/lib/libQtCore.so.4
#1 0x0798c72a in ?? () from /usr/lib/libQtCore.so.4
0000002 0x0798a7a8 in ?? () from /usr/lib/libQtCore.so.4
0000003 0x0798a83d in ?? () from /usr/lib/libQtCore.so.4
0000004 0x01200e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
0000005 0x01201279 in ?? () from /lib/libglib-2.0.so.0
0000006 0x01201848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000007 0x0798a59f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000008 0x0795a609 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000009 0x0795aa8a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000010 0x07856b7e in QThread::exec() () from /usr/lib/libQtCore.so.4
0000011 0x02a8f81a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
0000012 0x07859df9 in ?? () from /usr/lib/libQtCore.so.4
0000013 0x0021ecc9 in start_thread () from /lib/libpthread.so.0
0000014 0x025516be in clone () from /lib/libc.so.6

Thread 3 (Thread 0x91042b70 (LWP 7309)):
#0 0x0057b416 in __kernel_vsyscall ()
#1 0x00223884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0x00282749 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
0000003 0x910421b8 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0x85c2fb70 (LWP 7310)):
#0 0x0057b416 in __kernel_vsyscall ()
#1 0x002234dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
0000002 0x01ce210f in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb7833710 (LWP 5606)):
[KCrash Handler]
0000007 0x024b5c33 in ?? () from /lib/libc.so.6
0000008 0x024b3510 in strtod () from /lib/libc.so.6
0000009 0x00000000 in ?? ()
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filespng file icon clip-props-01.png [^] (26,374 bytes) 2010-11-19 20:26

- Relationships

-  Notes
(0006088)
ddennedy (developer)
2010-11-20 06:45

Fixed in mlt git commit 5420aee07 on Oct 18. Also, FYI, since then, I have changed this area to take a display aspect ratio.

- Issue History
Date Modified Username Field Change
2010-11-19 20:26 eddrog New Issue
2010-11-19 20:26 eddrog File Added: clip-props-01.png
2010-11-20 06:45 ddennedy Note Added: 0006088
2010-11-20 06:45 ddennedy Status new => resolved
2010-11-20 06:45 ddennedy Fixed in Version => 0.7.9
2010-11-20 06:45 ddennedy Resolution open => fixed
2010-11-20 06:45 ddennedy Assigned To => ddennedy
2011-04-26 21:57 j-b-m Fixed in Version 0.7.9 => 0.8
2011-06-10 10:50 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker