Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001898KdenliveBuild Systempublic2010-11-28 23:062011-11-01 18:56
Reportergsking1 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSFedora LinuxOS Version14
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0001898: Build error [src/cmake_bindir/CMakeFiles/kdenlive.dir/renderer.o] Error 1
DescriptionI tried building the latest SVN 5113 and got the error below. The tarball of 0.7.8 compiles fine. Using latest SVN frei0r and mlt 0.5.10.

/home/gsking/programs/src/svn/kdenlive/src/blackmagic/include/DeckLinkAPI.h:719:1: warning: ‘class IDeckLink’ has virtual functions and accessible non-virtual destructor
/home/gsking/programs/src/svn/kdenlive/src/renderer.h: In constructor ‘Render::Render(const QString&, int, QString, QWidget*)’:
/home/gsking/programs/src/svn/kdenlive/src/renderer.h:259:10: warning: ‘Render::sendFrameForAnalysis’ will be initialized after
/home/gsking/programs/src/svn/kdenlive/src/renderer.h:257:10: warning: ‘bool Render::analyseAudio’
/home/gsking/programs/src/svn/kdenlive/src/renderer.cpp:95:1: warning: when initialized here
/home/gsking/programs/src/svn/kdenlive/src/renderer.cpp: In member function ‘void Render::buildConsumer(QString)’:
/home/gsking/programs/src/svn/kdenlive/src/renderer.cpp:186:34: error: ‘struct mlt_profile_s’ has no member named ‘is_explicit’
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/renderer.o] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from /home/gsking/programs/src/svn/kdenlive/src/stopmotion/../blackmagic/include/DeckLinkAPI.h:34:0,
                 from /home/gsking/programs/src/svn/kdenlive/src/stopmotion/../blackmagic/capture.h:4,
                 from /home/gsking/programs/src/svn/kdenlive/src/stopmotion/stopmotion.h:22,
                 from /home/gsking/programs/src/svn/kdenlive/src/mainwindow.h:47,
                 from /home/gsking/programs/src/svn/kdenlive/src/kdenlivedoc.cpp:28:
/home/gsking/programs/src/svn/kdenlive/src/stopmotion/../blackmagic/include/LinuxCOM.h:90:1: warning: ‘class IUnknown’ has virtual functions and accessible non-virtual destructor
In file included from /home/gsking/programs/src/svn/kdenlive/src/stopmotion/../blackmagic/capture.h:4:0,
                 from /home/gsking/programs/src/svn/kdenlive/src/stopmotion/stopmotion.h:22,
                 from /home/gsking/programs/src/svn/kdenlive/src/mainwindow.h:47,
                 from /home/gsking/programs/src/svn/kdenlive/src/kdenlivedoc.cpp:28:
/home/gsking/programs/src/svn/kdenlive/src/stopmotion/../blackmagic/include/DeckLinkAPI.h:643:1: warning: ‘class IDeckLinkMemoryAllocator’ has virtual functions and accessible non-virtual destructor
/home/gsking/programs/src/svn/kdenlive/src/stopmotion/../blackmagic/include/DeckLinkAPI.h:656:1: warning: ‘class IDeckLinkAudioOutputCallback’ has virtual functions and accessible non-virtual destructor
/home/gsking/programs/src/svn/kdenlive/src/stopmotion/../blackmagic/include/DeckLinkAPI.h:665:1: warning: ‘class IDeckLinkIterator’ has virtual functions and accessible non-virtual destructor
/home/gsking/programs/src/svn/kdenlive/src/stopmotion/../blackmagic/include/DeckLinkAPI.h:719:1: warning: ‘class IDeckLink’ has virtual functions and accessible non-virtual destructor
make[1]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Error 2
make: *** [all] Error 2
Steps To ReproduceCompile SVN like normal.
cmake .. -DCMAKE_INSTALL_PREFIX=/usr/local
make -j4
etc..
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0006139)
j-b-m (administrator)
2010-11-30 00:18

You need MLT's development version (from git repo) to compile latest Kdenlive since Kdenlive and MLT are closely related and new features from MLT are usually quickly integrated in Kdenlive.

- Issue History
Date Modified Username Field Change
2010-11-28 23:06 gsking1 New Issue
2010-11-30 00:18 j-b-m Note Added: 0006139
2010-11-30 00:18 j-b-m Status new => resolved
2010-11-30 00:18 j-b-m Resolution open => fixed
2010-11-30 00:18 j-b-m Assigned To => j-b-m
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker