Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001943KdenliveFile Loadingpublic2010-12-25 20:282011-11-01 18:56
Reporterneoarttec 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
Platform32 bit intel and alikeOSOpenSUSEOS Version11.3
Product Version0.7.8 
Target VersionFixed in Version0.8.2 
Summary0001943: Add Clip to Project Tree Ignores Photo EXIF Orientation Metadata
DescriptionAdd Clip to Project Tree Ignores Photo EXIF Orientation Metadata
Image is not rotated and displays with the wrong orientation.
Steps To ReproduceImport an image EXIF Orientation that specifies that the image should be rotated.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filesjpg file icon IMG_4731.JPG [^] (5,953,643 bytes) 2011-01-06 04:55

- Relationships

-  Notes
(0006239)
j-b-m (administrator)
2010-12-26 12:39
edited on: 2010-12-26 12:40

This is probably a packaging issue. This feature is integrated into MLT, but MLT needs to be compiled with libexif to work. I guess the packager did not compile with libexif.

To be sure, could you attach one sample picture so that I can test on my system?

(0006299)
neoarttec (reporter)
2011-01-06 04:58

The attached file "IMG_4731.JPG" is unprocessed (no Gimp / Photoshop) and copied from the digital camera card, hence its size. I have imported this into Kdenlive and the EXIF rotation is ignored. I have also tried with others.
(0006300)
j-b-m (administrator)
2011-01-07 12:08

I can confirm that the image appears correctly rotated for me in Kdenlive. So the problem is that your version of MLT was not compiled with libexif support. If you are using official packages, you should contact the packager to request a new version with libexif support.
(0006938)
neoarttec (reporter)
2011-06-22 14:29

That is a fix

- Issue History
Date Modified Username Field Change
2010-12-25 20:28 neoarttec New Issue
2010-12-26 12:39 j-b-m Note Added: 0006239
2010-12-26 12:39 j-b-m Assigned To => j-b-m
2010-12-26 12:39 j-b-m Status new => feedback
2010-12-26 12:40 j-b-m Note Edited: 0006239 View Revisions
2011-01-06 04:55 neoarttec File Added: IMG_4731.JPG
2011-01-06 04:58 neoarttec Note Added: 0006299
2011-01-06 04:58 neoarttec Status feedback => assigned
2011-01-07 12:08 j-b-m Note Added: 0006300
2011-06-22 14:29 neoarttec Note Added: 0006938
2011-06-22 21:01 j-b-m Status assigned => resolved
2011-06-22 21:01 j-b-m Fixed in Version => Recent git
2011-06-22 21:01 j-b-m Resolution open => no change required
2011-07-05 12:15 j-b-m Fixed in Version Recent git => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker