Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001971KdenliveUser Interfacepublic2011-01-07 12:482011-06-10 10:48
Reporterttill 
Assigned ToGranjow 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSArch LinuxOS Versioncurrent
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0001971: Crash in AudioSpectrum when leaving Kdenlive open for some time
DescriptionThe audio spectrum is visible but "auto refresh" is turned off.
I open Kdenlive to do some quick tests not involving the spectrum and then switch back to Kdevelop often leaving Kdenlive running.
After some time it crashes.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filestxt file icon kdenlive-20110105-202332.kcrash.txt [^] (1,791 bytes) 2011-01-07 12:48 [Show Content]

- Relationships

-  Notes
(0006303)
Granjow (developer)
2011-01-07 14:24

Strange. I have no idea how this can happen.

if (m_aTrackMouse->isChecked() && m_mouseWithinWidget && mouseX < m_innerScopeRect.width()-1) {

m_aTrackMouse should only be deleted when kdenlive is closed. So why should this trigger a segfault?

Are all audio scopes switched off (including the volume widget) or hidden?
How long is «some time» usually?
(0006305)
Granjow (developer)
2011-01-08 07:35

PS: I tried to reproduce it (with qtcreator). Even after waiting 10+ minutes I did not get this crash.
Wonder what it might be ...
(0006316)
ttill (developer)
2011-01-09 21:36

All audio scopes are switched off. They are tabbed together with the audio spectrum so only this one is visible.
The height is very very small, much to small to be usable.
Mouse tracking is checked.
The time varies: I would say from 3 to 15 minutes.
I am just doing some tests...
(0006317)
ttill (developer)
2011-01-09 22:34

Test somehow failed.
No instance of Kdenlive crashed (the day I reported this every instance crashed) however two processes remained open with 100% CPU usage although the windows were closed. Either an endless loop or a hidden benchmark to find out the best the playback settings ;)
(0006318)
ttill (developer)
2011-01-10 15:02

Today it crashes all the time again.
Yesterday I opened Kdenlive, added a clip, moved it to the timeline, and then waited.
Today to test out a widget I am currently working on I add a clip, move it to the timeline, add a (video-)effect and play a bit with the widget. The main difference is that the frame gets updated very often in a short time because of me changing a parameter value very fast.
(0006319)
Granjow (developer)
2011-01-11 09:03

Should be fixed in r3517.
Reason:
for (int i = 0; i < size; i++) with size < 0.
(0006352)
ttill (developer)
2011-01-26 07:39

Did not crash again since then.
Thanks.

- Issue History
Date Modified Username Field Change
2011-01-07 12:48 ttill New Issue
2011-01-07 12:48 ttill Status new => assigned
2011-01-07 12:48 ttill Assigned To => Granjow
2011-01-07 12:48 ttill File Added: kdenlive-20110105-202332.kcrash.txt
2011-01-07 14:24 Granjow Note Added: 0006303
2011-01-08 07:35 Granjow Note Added: 0006305
2011-01-09 21:36 ttill Note Added: 0006316
2011-01-09 22:34 ttill Note Added: 0006317
2011-01-10 15:02 ttill Note Added: 0006318
2011-01-11 09:03 Granjow Note Added: 0006319
2011-01-11 09:03 Granjow Status assigned => feedback
2011-01-26 07:39 ttill Note Added: 0006352
2011-01-26 07:39 ttill Status feedback => assigned
2011-01-26 07:39 ttill Status assigned => resolved
2011-01-26 07:39 ttill Fixed in Version => Recent git
2011-01-26 07:39 ttill Resolution open => fixed
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:48 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker