Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001997KdenliveEffectspublic2011-02-01 20:282011-06-10 10:48
Reporterttill 
Assigned ToGranjow 
PrioritynormalSeveritytweakReproducibilityN/A
StatusclosedResolutionfixed 
Platform64 bitOSArch LinuxOS Versioncurrent
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0001997: Background for new curve modes
DescriptionBackground images for new modes in the Bézier curves filter would be great.
Especially for hue it would be very helpful.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0006373)
Granjow (developer)
2011-02-02 08:46

Sorry, I cannot do this atm. kdenlive crashes when adding the Bézier Curves effect, kdenlive crashes when selecting a clip with a certain effect assigned, kdenlive crashes when trying to change the values of an effect, at least it does not crash directly on startup.

But a question regarding the Bézier curves filter -- I did not notice it before today when pulling frei0r from git. Is this the new widget, and Curves is still the old one?
(0006374)
ttill (developer)
2011-02-02 22:24

The Bézier curves GUI will only show up if version 0.2 of the filter is detected.
I raised the number in one of the commits recently merged into the official frei0r repository to make it easy to detect the features available.
The already (since 0.7.8) existing curves GUI remained untouched. I think we cannot hide it even if 0.2 is available since then existing projects might cause trouble.

Can you post a backtrace of the crash you get when adding a (Bézier) curves effect?
(0006375)
Granjow (developer)
2011-02-03 13:21

No, I cannot. It works fine now :D
Whew, is this cool. Never seen a sexier Curves dialog so far.
(0006380)
ttill (developer)
2011-02-03 16:40

Then you did not see Fresh Curves yet:
http://www.frischluft.com/curves/index.php [^]
Especially keyframes and relative curves are awesome.
Here is the manual describing some of the features (for users):
http://www.frischluft.com/download/FreshCurves_v1.0.pdf [^]
(0006472)
Granjow (developer)
2011-02-21 17:11

Indeed, really cool! Didn't know these yet :)

Can you make the curve for Hue and Saturation be a horizontal line in neutral position? I added a hue background in r5445. If you want I can change it such that it suits the current curve (lower left to upper right), but a horizontal line would be much better for editing.

Saturation will come soon. Regarding Luma, no idea what to use here, for a greyscale plane it is the same, I think?
... or not?
(0006477)
Granjow (developer)
2011-02-22 15:20

Saturation added. I'm not sure whether it is the one you want. I just used the HSV model there, but is this what you're doing as well?
(0006530)
ttill (developer)
2011-03-04 22:04
edited on: 2011-03-04 22:05

Finally:
Yes it might be easier to edit, but currently I simply assign hue value to hue value (from 0 to 360 on both axes) and therefore no special case GUI wise is necessary. And I do not have the time to add such a special case before 0.8.
The saturation plane you created would fit a curve changing saturation based on hue (what is called relative curve in Fresh Curves). The saturation curve in frei0r.curves however assigns saturation to saturation. I am not sure if this can be described with a bg plane. But I am sure that the curve described by your plane would be more useful than the current one ;). Might have a look at this some time in the future...
Anyways thanks for your efforts!

(0006569)
Granjow (developer)
2011-03-12 17:18

I updated the function to allow saturation/saturation planes:
static QImage hsvCurvePlane(const QSize &size, const QColor &baseColor, const ComponentsHSV &xVariant, const ComponentsHSV &yVariant);
baseColor describes the basic HSV color to use, in case of saturation on both x and y axis it would use hue and value from this color.
Unfortunately I've got no better idea of how to solve this

Horizontal would be very cool for after 0.8 :)
(0006590)
ttill (developer)
2011-03-18 18:56

Thanks. I will have a look at the saturation planes.
Could you please rotate the hue plane so that it fits the curve for the release?
Without the plane the hue curve is pretty hard to use ;)
(0006593)
Granjow (developer)
2011-03-18 19:02

Sure. Rotate it which way?
(0006595)
ttill (developer)
2011-03-18 19:34

45° counter-clockwise. (if I didn't get something wrong)
(0006597)
Granjow (developer)
2011-03-18 19:51

Ah! Right, it is not a horizontal line. But I need to shear it, rotating won't work since hue is on the x axis and not on a 45° axis, isn't it?
(0006600)
ttill (developer)
2011-03-18 20:14

Puhh. I have no idea atm ;)
If you uncomment lines 132 + 133 in src/beziercurve/beziersplinewidget.cpp and test it against an image containing multiple hues you can maybe find out?
(0006601)
Granjow (developer)
2011-03-18 20:51

Hm, tested it, it seems that no rotation is required at all. The curve (0,0)->(1,1) passes all hue values, and if I change a certain point (e.g. blue), then the blues change.
I can make my skin look like an Avatar ;)

And I think for Saturation this is not required either.

Nevertheless added in r5503, perhaps we can make use of it later.
(0006602)
ttill (developer)
2011-03-18 21:46

Nice (I did only test with hsvHueShiftPlane).
So for saturation we have to choose a color, right?
(0006607)
Granjow (developer)
2011-03-19 15:02

Yes.
Or leave the background away completely :)

- Issue History
Date Modified Username Field Change
2011-02-01 20:28 ttill New Issue
2011-02-01 20:28 ttill Status new => assigned
2011-02-01 20:28 ttill Assigned To => Granjow
2011-02-02 08:46 Granjow Note Added: 0006373
2011-02-02 22:24 ttill Note Added: 0006374
2011-02-03 13:21 Granjow Note Added: 0006375
2011-02-03 16:40 ttill Note Added: 0006380
2011-02-21 17:11 Granjow Note Added: 0006472
2011-02-22 15:20 Granjow Note Added: 0006477
2011-03-04 22:04 ttill Note Added: 0006530
2011-03-04 22:05 ttill Note Edited: 0006530 View Revisions
2011-03-12 17:18 Granjow Note Added: 0006569
2011-03-17 15:11 Granjow Status assigned => feedback
2011-03-18 18:56 ttill Note Added: 0006590
2011-03-18 18:56 ttill Status feedback => assigned
2011-03-18 19:02 Granjow Note Added: 0006593
2011-03-18 19:34 ttill Note Added: 0006595
2011-03-18 19:51 Granjow Note Added: 0006597
2011-03-18 20:14 ttill Note Added: 0006600
2011-03-18 20:51 Granjow Note Added: 0006601
2011-03-18 21:46 ttill Note Added: 0006602
2011-03-19 15:02 Granjow Note Added: 0006607
2011-04-27 23:37 ttill Status assigned => resolved
2011-04-27 23:37 ttill Resolution open => fixed
2011-04-27 23:37 ttill Fixed in Version => 0.8
2011-06-10 10:48 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker