Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002015KdenliveEffectspublic2011-02-13 18:242011-11-01 18:56
Reporteryellow 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionwon't fix 
Platform64bit Maverick MeerkatOSSunabs svn PPAOS Version
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002015: Crop Effect - Cropping parameters don't seem to work correctly
DescriptionI'm trying to create a typical 2:35:1 frame 806 high out of 1080P frame by simply setting a top crop of 131 & a bottom crop of 132 but just adding the first crop to the top immediately gives me a 60 pixel crop top and bottom and scales the image up. This is without the Auto Centre Crop Ticked.

I can the frame is scaled up because if I extract the cropped frame and overlay it in Gimp on the same frame extracted without the crop active, set the opacity to 50% I see strong ghosting clearly showing the cropped frame has been scaled up.

Additional InformationI've got to say I think that any auto scaling by default on any of the effects is totally wrong and hope this is a bug not a default. Although I see similar auto scaling with Pan & Zoom which also doesn't appear to work correctly, I've reported that on a separate bug report.

Any auto scaling operation for any filter/effect/import really should be off by default and implicitly 'switched on' or applied if required by the user

TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0006534)
ttill (developer)
2011-03-04 23:18

Unable to reproduce.
Cropping from top centers the frame but nothing is removed from the bottom.
(0006543)
sunab (developer)
2011-03-05 15:51

Using the same packages as yellow.
Using 1080p footage.

Cropping 131 pixels on top -> 131 pixels removed from top (nothing is removed from bottom), the frame it automatically centered resulting in equal top/bottom 65 pixels black borders. This behavior is only expected if "Auto center crop" is ticked, but it's not. For me that is the issue.

But i don't see any kind of scaling.

By the way it seems I found another bug using crop and proxy files (I will open a new bug report).
(0006567)
ddennedy (developer)
2011-03-12 01:15

This is by design. It is edge cropping. After taking N from the top, the aspect ratio no longer is the same, so it is padded to fill the frame by centering the image. It is not cropping N/2 from opposing edges; it only takes it from the edge you request.

Overall it works like this: crop edges as requested from the source image, deinterlace if needed, scale to project resolution while keeping aspect ratio, center and pad with black. Then, all other effects are applied. I am sorry if you do not like it, but that is the design of MLT, take it or leave it.

- Issue History
Date Modified Username Field Change
2011-02-13 18:24 yellow New Issue
2011-03-04 23:18 ttill Note Added: 0006534
2011-03-04 23:18 ttill Status new => feedback
2011-03-05 15:51 sunab Note Added: 0006543
2011-03-12 01:15 ddennedy Note Added: 0006567
2011-03-12 01:15 ddennedy Status feedback => resolved
2011-03-12 01:15 ddennedy Resolution open => won't fix
2011-03-12 01:15 ddennedy Assigned To => ddennedy
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker