Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002019KdenliveUser Interfacepublic2011-02-15 12:202011-06-10 10:49
Reporteralphazo 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform64-bitOSArchLinuxOS Version2011-02-15
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0002019: Unable to delete/move cut clips
DescriptionI'm using SVN version 0.7.9 (rev. 5398) and have hard time dealing with segments of clips cut using the scissor tool. I end up with clips on the timeline that can't be deleted or moved.
Steps To Reproduce- Create HD 720P 25fps project
- Import a MKV (previously transcoded from MP4 with KDEnlive) 50fps clip
- Place the clip on the time line
- Cut the clip in three sections
- The two last segments can be moved or deleted
- The first segment is locked and cannot be moved around or even deleted.
Additional InformationI also tried with the original MP4 or changed the project FPS to 50 but it gives the same issue.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filestxt file icon segfault.txt [^] (2,710 bytes) 2011-02-15 17:04 [Show Content]

- Relationships

-  Notes
(0006422)
alphazo (reporter)
2011-02-15 17:04

This is not specific to HD content. If I start a blank project using DVD PAL template and then import a .MOV file containing motion JPEGs I get pretty much the same result.
- Import to time line
- Cut at 1/3 and 2/3
- Unable to move or delete segment 1

Now I don't know if this is related but if at that point I try to Undo 3 times in a row then I get seg fault. This can be reproduced all the times. I'm attaching the trace I received.
(0006423)
j-b-m (administrator)
2011-02-15 23:03
edited on: 2011-02-15 23:03

In svn rev. 5404 I fixed an issue that produced corrupted timeline as you describe.
The bug was triggered when creating a new project that had a different fps than the default project profile defined in Kdenlive Settings dialog.

Do you think it could be your problem? Can you try changing the default project profile (in Kdenlive Settings dialog -> Project Defaults) to DVD PAL. Then quit Kdenlive, restart it and try to reproduce the issue described in your last comment. If the issue is not present anymore, then your problem is fixed in current svn.

(0006424)
alphazo (reporter)
2011-02-16 09:43

Bingo. That was it (what a nasty one). I was able to move/delete split clips by changing the default project settings to match the project I wanted to create (under .5398). Then I switched to .5411 and the problem was gone.
Thanks a lot for this fix. This bug can be closed.
Is there any donation button I can click on?

- Issue History
Date Modified Username Field Change
2011-02-15 12:20 alphazo New Issue
2011-02-15 17:04 alphazo Note Added: 0006422
2011-02-15 17:04 alphazo File Added: segfault.txt
2011-02-15 23:03 j-b-m Note Added: 0006423
2011-02-15 23:03 j-b-m Assigned To => j-b-m
2011-02-15 23:03 j-b-m Status new => feedback
2011-02-15 23:03 j-b-m Note Edited: 0006423 View Revisions
2011-02-16 09:43 alphazo Note Added: 0006424
2011-02-16 09:43 alphazo Status feedback => assigned
2011-02-16 14:55 j-b-m Status assigned => resolved
2011-02-16 14:55 j-b-m Fixed in Version => Recent git
2011-02-16 14:55 j-b-m Resolution open => fixed
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:49 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker