Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002029KdenliveMLTpublic2011-02-17 22:362011-03-03 06:35
ReporterGranjow 
Assigned To 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0002029: Memleak in MLT?
DescriptionI just rendered a project with several H.264 clips. No transitions, just a bunch of videos on a single track. When rendering, memory usage constantly rises until about 42% shortly before rendering is finished. (2 GB here.)

Is this normal?

Problem is, this also happens in kdenlive, when editing for a longer time. Then (I have no swap partition) kdenlive just gets killed by the kernel.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0006519)
ddennedy (developer)
2011-03-03 06:35

Periodically, for clients and specific bug reports, I do memory leak testing in MLT. For example, they have playlists for up to 24 hours that I run for several days continuously. There is no known problem at this time; however, that does not mean I just ran some tests. It has been a couple of months.

Increasing memory usage can be normal due to caching. For example, without VDPAU, MLT caches up to 10 instances of the avformat producer - with VDPAU, just 5. Then, for resident avformat instance, MLT caches the most recent 10 images produced. So, it is normal for memory to go up as the clips are used and obviously HD is going to use more. Also, the new parallel consumer consumes more mem with each worker thread added.

- Issue History
Date Modified Username Field Change
2011-02-17 22:36 Granjow New Issue
2011-03-03 06:35 ddennedy Note Added: 0006519


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker