Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002034KdenliveUser Interfacepublic2011-02-20 17:002011-06-10 10:49
ReporterGranjow 
Assigned Tottill 
PrioritynormalSeverityblockReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.8 
Summary0002034: Segfault when working with Composite effect and titles
DescriptionTitle with transparent PNG on the first track, more clips on the second track, Composite transition between. I'm not sure yet what exactly causes the crash.

Application: Kdenlive (kdenlive), signal: Segmentation fault

Thread 1 (Thread 0x7f4d144007a0 (LWP 6505)):
[KCrash Handler]
0000005 0x000000000051cb76 in CustomTrackView::mouseMoveEvent (this=0x359a0a0, event=0x7fff46b84f10) at /data/cworkspace/kdenlive.git/kdenlive/src/customtrackview.cpp:624
0000006 0x00007f4d0eb7028f in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000007 0x00007f4d0ef17716 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000008 0x00007f4d0f15ac1b in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
0000009 0x00007f4d134044b7 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000010 0x00007f4d0eb1a2fc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000011 0x00007f4d0eb20fdb in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000012 0x00007f4d12e777a6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000013 0x00007f4d1340509c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000014 0x00007f4d0eb201be in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
0000015 0x00007f4d0eba007b in ?? () from /usr/lib/libQtGui.so.4
0000016 0x00007f4d0eb9e9dc in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
0000017 0x00007f4d0ebca5a2 in ?? () from /usr/lib/libQtGui.so.4
0000018 0x00007f4d0d0052e2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000019 0x00007f4d0d0099a8 in ?? () from /lib/libglib-2.0.so.0
0000020 0x00007f4d0d009b5c in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000021 0x00007f4d1342e6b3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000022 0x00007f4d0ebca19e in ?? () from /usr/lib/libQtGui.so.4
0000023 0x00007f4d134039c2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000024 0x00007f4d13403d9c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000025 0x00007f4d13408a2b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000026 0x000000000045f1cf in main (argc=1, argv=0x7fff46b860a8) at /data/cworkspace/kdenlive.git/kdenlive/src/main.cpp:90
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0006461)
Granjow (developer)
2011-02-20 17:04

customtrackview.cpp:624
message = i18n("Crop from start: ") + m_document->timecode().getDisplayTimecode(ci->cropStart(), KdenliveSettings::frametimecode());

Segfault here. I just MOVE my mouse over the timeline. Nothing else.
(0006462)
ttill (developer)
2011-02-20 17:16

Could you please try again with r5439?
(0006463)
Granjow (developer)
2011-02-20 17:21
edited on: 2011-02-20 17:21

o.O

I was still trying to find the reason for the segfault when you already fixed it. How did you find out the initialization was incorrect?

(I won't mark it as resolved until you tell me }:-) )

(0006464)
ttill (developer)
2011-02-20 19:16

1. I worked on this code just yesterday: http://kdenlive.svn.sourceforge.net/viewvc/kdenlive?view=revision&revision=5432 [^]
2. I had a similar problem earlier today (though unrelated to this issue)

So no magic involved :( ...
(0006465)
Granjow (developer)
2011-02-20 20:29

Ah, I see ...
The segfault was kind of unexpected since I tested whether cp was a null pointer, but I did not think of an uninitialized variable. I'll know this for next time. Perhaps :D

Thanks for fixing btw!

- Issue History
Date Modified Username Field Change
2011-02-20 17:00 Granjow New Issue
2011-02-20 17:04 Granjow Note Added: 0006461
2011-02-20 17:16 ttill Note Added: 0006462
2011-02-20 17:21 Granjow Note Added: 0006463
2011-02-20 17:21 Granjow Note Edited: 0006463 View Revisions
2011-02-20 19:16 ttill Note Added: 0006464
2011-02-20 20:29 Granjow Note Added: 0006465
2011-02-20 20:29 Granjow Status new => resolved
2011-02-20 20:29 Granjow Fixed in Version => Recent git
2011-02-20 20:29 Granjow Resolution open => fixed
2011-02-20 20:29 Granjow Assigned To => ttill
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:49 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker