Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002056KdenliveEffectspublic2011-03-05 16:152011-06-10 10:48
Reportersunab 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformi386OSUbuntu LinuxOS Version10.10
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0002056: crop effect removes too much pixels in monitor when used on a clip with proxy enabled
DescriptionWhen cropping 100 pixels a 1080p clip it results with 980 pixels results. But when activating proxy option, the project monitor shows a much larger crop.

In my opinion it computes crop using the resolution of the proxy files : 270 pixels.
Steps To Reproduce-new project (proxy disabled)
-add 1080p clip to timeline
-add crop effect to the clip with 100 pixels removal from top
-see the result in project monitor
-then activate proxy option
-the result in project monitor is very different.

note : the clip is always auto-centered, issue 2015? http://www.kdenlive.org/mantis/view.php?id=2015 [^]
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships

-  Notes
(0006578)
ddennedy (developer)
2011-03-15 04:09

A property was added to the crop filter in MLT to allow expressing pixel units in terms of project resolution instead of clip resolution. Till confirmed it works, but a change is also needed in Kdenlive...

This is not the same as 2015.
(0006589)
ttill (developer)
2011-03-18 18:49

Parameter "use project resolution" added in r5501. It is not checked by default because it would then also be used by existing projects.
(0006591)
ddennedy (developer)
2011-03-18 18:59

is there any intelligence to enable it automatically with proxies? I believe that is safe because it is broken on proxies otherwise. I suppose someone could have compensated for the brokenness, but there has not yet been a release with proxies yet.
(0006659)
ttill (developer)
2011-04-20 13:11

r5542: Setting will default to true on clips if proxy (for specific clip) is enabled
r5543: Setting will default to true on tracks if proxy setting for project is enabled

I hope it is fine now

- Issue History
Date Modified Username Field Change
2011-03-05 16:15 sunab New Issue
2011-03-11 16:41 ttill Status new => acknowledged
2011-03-15 04:09 ddennedy Note Added: 0006578
2011-03-18 18:49 ttill Note Added: 0006589
2011-03-18 18:59 ddennedy Note Added: 0006591
2011-04-20 13:11 ttill Note Added: 0006659
2011-04-27 23:25 ttill Assigned To => ddennedy
2011-04-27 23:25 ttill Status acknowledged => resolved
2011-04-27 23:25 ttill Resolution open => fixed
2011-04-27 23:25 ttill Fixed in Version => 0.8
2011-06-10 10:48 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker