Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002077KdenliveBuild Systempublic2011-03-26 22:272011-06-10 10:49
Reporterfleury 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bits i686OSLinux Kubuntu 10.10OS Version2.6.35
Product VersionRecent git 
Target VersionFixed in Version0.8 
Summary0002077: Fix for all existing warnings while compiling
DescriptionThe attached patch fixes most warnings that I see when compiling from SVN.
They are mainly signed/unsigned comparisons, a missing virtual destructor and some unused or uninitialized variables. 2 problems stand out though:
- the write frame in blackmagic code may actually loose data if the system interrupts the write call. I have written a function that does not loose this data, but I have no such device so I can't test the code.
- many definitions of unions in the videodev2.h file actually define a _type_ and not a data structure (it would need a name to the union to do so). This also means that said unions are probably not used anywhere, but adding names to them may change the memory size of these so I did not touch them.

I think that it would be worth fixing those as well before the release. I am happy to do it as another patch, bu commenting the unions out probably.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filesgz file icon fix_warnings.patch.gz [^] (1,799 bytes) 2011-03-26 22:27

- Relationships

-  Notes
(0006669)
j-b-m (administrator)
2011-04-26 21:55

Thanks a lot, your fixes have been committed, (without the last change to blackmagic/include/LinuxCOM.h because it caused startup crashes).

- Issue History
Date Modified Username Field Change
2011-03-26 22:27 fleury New Issue
2011-03-26 22:27 fleury File Added: fix_warnings.patch.gz
2011-04-26 21:55 j-b-m Note Added: 0006669
2011-04-26 21:55 j-b-m Status new => resolved
2011-04-26 21:55 j-b-m Fixed in Version => Recent git
2011-04-26 21:55 j-b-m Resolution open => fixed
2011-04-26 21:55 j-b-m Assigned To => j-b-m
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:49 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker