Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002093KdenliveEffectspublic2011-04-16 23:592011-04-17 10:38
Reporteralphazo 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
Platform64-bitOSArchLinuxOS Versionrolling
Product VersionRecent git 
Target VersionFixed in Version 
Summary0002093: RGB adjustment broken in SVN version
DescriptionWhen using RGB adjustment filter, moving RGB sliders from 0 to 999 (keep contrast, adjust gamma) doesn't change the picture. Only a weird solarized result can be seen. The only value that works is 1000 but it doesn't give any way to adjust the amount of effect applied.
Steps To ReproduceYou can try it for yourself with the attached test project that only contains one picture.

1) Kdenlive 0.7.8-3 (Mar 20011) + mlt 0.7.0-3
- Load the project
- Select the clip in the timeline and change the RGB adjustments (keep contrast, adjust gamma)
- When you move slider from 0 to 1000 on any channel, you will see the color cast changing without any artifact. You can finely adjust green and blue cast in a linear way.
- On this specific underwater picture you can put green and blue slider close to zero and red in the high values to get a more realistic picture

2) Kdenlive SVN 5539 + mlt git (20110416)
- Load the project
- Select the clip in the timeline and change the RGB adjustments (keep contrast, adjust gamma)
- Trying to move any one of the R, G or B from 0 to 999. No change can be seen on the picture except the same weird colors (solarized).
- Now if you put the R slider to 1000 (and only this value) then the the Green and Blue casts are gone but not precise adjustment can be made.

Again, even if the video filter hasn't changed for a while I strongly believe there is a problem with the way sliders are treated under SVN version and recent mlt git. Now I don't know if the problem comes from kdenlive or mlt!
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Fileszip file icon testcolor-correction.zip [^] (1,515,733 bytes) 2011-04-16 23:59

- Relationships

-  Notes
(0006655)
alphazo (reporter)
2011-04-17 00:13

FYI, I also tried with Kdenlive SVN 5539 + mlt 0.7.0-3 and I had the same problem. So that may put mlt out of the problem considering that the same version works fine with kdenlive 0.7.8-3.
(0006656)
alphazo (reporter)
2011-04-17 00:23

I made a mistake. The problem occurs on both 0.7.8-3 and SVN versions but not on 0.7.8-2

I confirm that there is a problem with 0.7.8-3 and SVN version of kdenlive.

1) Kdenlive 0.7.8-2 (Jan 2011) + mlt 0.6.0-1
- Load the project
- Select the clip in the timeline and change the RGB adjustments (keep contrast, adjust gamma)
- When you move slider from 0 to 1000 on any channel, you will see the color cast changing without any artifact. You can finely adjust green and blue cast in a linear way.
- On this specific underwater picture you can put green and blue slider close to zero and red in the high values to get a more realistic picture

2) Kdenlive 0.7.8-3 + mlt 0.7.0-3 and Kdenlive SVN 5539 + mlt git (also tried with mlt 0.7.0-3)
- Load the project
- Select the clip in the timeline and change the RGB adjustments (keep contrast, adjust gamma)
- Trying to move any one of the R, G or B from 0 to 999. No change can be seen on the picture except the same weird colors (solarized).
- Now if you put the R slider to 1000 (and only this value) then the the Green and Blue casts are gone but not precise adjustment can be made.
(0006657)
alphazo (reporter)
2011-04-17 10:38

It was late yesterday when I tested that. It appears that the problem comes from mlt-git. When installing kdenlive-svn under Archlinux it requires to compile latest mlt from git. This is where the problem show up with the sliders. Now if I force mlt to version 0.7.0-3 then I can use RGB color adjust under kdenlive-svn.

Sorry for the confusion.
Alphazo

- Issue History
Date Modified Username Field Change
2011-04-16 23:59 alphazo New Issue
2011-04-16 23:59 alphazo File Added: testcolor-correction.zip
2011-04-17 00:13 alphazo Note Added: 0006655
2011-04-17 00:23 alphazo Note Added: 0006656
2011-04-17 10:38 alphazo Note Added: 0006657


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker