Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002142KdenliveUser Interfacepublic2011-05-26 20:332011-11-01 18:56
Reporteroldpink 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformIntel Core2-QuadOSLinux 64-bitOS VersionSlackware 13.37
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002142: I am completely unable to use kdenlive
DescriptionI built kdenlive using the latest libraries, including MLT, FFMpeg, etc, and it built without any indication of problems.
When I try to start it, it fails entirely with a cryptic crash popup.
I have no idea what the problem is, but my debug output seems to indicate that the problem is lurking within MLT.
As per the instructions on the site (http://www.kdenlive.org/bug-reports [^]), I tested the four steps at the top of this page, finding that I have only one version of MLT (step #1) installed, ffplay works (step 0000002), but I am completely unable to play any movie files using melt, or even the sample test_file.kdenlive provided (steps 0000003 & 0000004).
I even went so far as to try running from pre-built binaries (slackware) of MLT and kdenlive, but it crashed all the same, so I deleted those binaries and rebuilt them from svn and git repositories, the problem persisting, and the debug output I will insert is from those builds.
Steps To ReproduceAll that is necessary to reproduce this crash is to start kdenlive, and it crashes without even beginning to give a clean screen.
Additional Informationgdb ./src/cmake_bindir/kdenlive
GNU gdb (GDB) 7.2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> [^]
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-slackware-linux".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>... [^]
Reading symbols from /root/kdenlive/build/src/cmake_bindir/kdenlive...done.
(gdb) run
Starting program: /root/kdenlive/build/src/cmake_bindir/kdenlive
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7bc5279 in ?? () from /usr/lib64/libmlt.so.4
(gdb) thread apply all bt

Thread 1 (Thread 0x7ffff7f9a7a0 (LWP 10709)):
#0 0x00007ffff7bc5279 in ?? () from /usr/lib64/libmlt.so.4
#1 0x00007ffff7bc6cac in mlt_properties_set_int () from /usr/lib64/libmlt.so.4
0000002 0x00007ffff79adbae in Mlt::Properties::set(char const*, int) ()
   from /usr/lib64/libmlt++.so.3
0000003 0x00000000004bab52 in Render::buildConsumer (this=0xd054d0,
    profileName=<value optimized out>) at /root/kdenlive/src/renderer.cpp:243
0000004 0x00000000004bb53e in Render::Render (this=0xd054d0, rendererName=...,
    winid=41943152, profile=..., parent=<value optimized out>)
    at /root/kdenlive/src/renderer.cpp:113
0000005 0x00000000004a9a57 in Monitor::Monitor (this=0xd44bf0, name=...,
    manager=<value optimized out>, profile=<value optimized out>,
    parent=<value optimized out>) at /root/kdenlive/src/monitor.cpp:170
0000006 0x000000000047d9c7 in MainWindow::MainWindow (this=0xa9fc00,
    MltPath=<value optimized out>, Url=..., clipsToLoad=...,
    parent=<value optimized out>, __in_chrg=<value optimized out>,
    __vtt_parm=<value optimized out>) at /root/kdenlive/src/mainwindow.cpp:201
0000007 0x0000000000450803 in main (argc=1, argv=0x7fffffffde38)
    at /root/kdenlive/src/main.cpp:84
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0006746)
j-b-m (administrator)
2011-05-27 10:35

Can you please post the result of the following command in a terminal:

melt -query consumers

Also try playing a simple colour clip:

melt colour:red
(0006750)
oldpink (reporter)
2011-05-27 22:47

--- BEGIN TEXT ---
melt -query consumers
---
consumers:
  - libdv
  - xml
  - sdi
  - decklink
  - avformat
  - null
  - gtk2_preview
  - mvcp
...
--- END TEXT ---

Executing "melt colour:red" results in no output at all, even when executed with the "-verbose" flag.
As I suspect, there must be something badly wrong with MLT, but since I didn't get any fatal errors building it, I have no clue what it could be.
Thanks for giving this a shot thus far.
(0006751)
j-b-m (administrator)
2011-05-27 23:29

Ok, that's what I thought. You are missing the SDL consumers, you should have:

  - sdl
  - sdl_audio
  - sdl_preview
  - sdl_still

You need to install the development versions of your SDL packages, should be called something like: libsdl1.2-dev and libsdl-image1.2-dev

After that you need to configure, compile and reinstall MLT and it should work.
(0006752)
oldpink (reporter)
2011-05-28 02:20

I guess I am forced to plead ignorance this time.
I went to the SDL site and downloaded the latest version via Mercurial, then built and installed it, next getting the latest GIT version of MLT, building and installing it, then getting the latest SVN of KDEnlive.
All to no avail.
I also am still unable to get any output at all from "melt colour:red."

I have no idea where to get sdl_audio, sdl_preview, or sdl_still, unless they are buried somewhere within the SDL version I downloaded, or if they are available in separate source code that I simply have no clue where to find.
Sorry, and thanks again for your help, but I just don't have enough to go on here.
(0006753)
j-b-m (administrator)
2011-05-28 09:13

Well until you really know what you are doing, you should not compile everything by yourself. Your distro does provide pre-compiled binaried for SDL, so it's better to use those.

When compiling by yourself, you may not correctly configure the packages, and you also must be sure where to install. Usually, when compiling and installing yourself it goes in /usr/local, but when using pre-compiled packages, it is installed in /usr, which may explain why SDL does not work for you.

When configuring MLT, you should see a warning message if SDL is missing:
./configure --enable-gpl

But again, unless you are experienced, I would recommand to use distro packages for everything, and compile only MLT and Kdenlive.
(0006754)
oldpink (reporter)
2011-05-28 10:41

I know you are unaware of this, but I'm a fairly experienced Linux user, having operated exclusively with it for the last over ten years, usually compiling most of my own applications from source packages over that time.
While my current system has a foundation in Slackware, and much of the basic system is from Slackware packages, I run a kernel that I customized and built for my specific system, so I'm not really a novice.
And even though I'm not a programming expert by any stretch, I have often been able to get troublesome software source code to compile by sometimes modifying specific lines causing build failures, commenting out others, or tracking down broken includes, so I'm probably better than the average Linux user in that area, although I wish I had the expertise to perform detailed fixes in that area.
I go to the trouble to tell you all this so you know that I am perfectly able to build my own required packages, given information about where to get them and reasonably well written source code.
For what it's worth, I had not a single error building SDL, and I easily caught the need to include the "--include-gpl" flag to the configure line when I built it.
Also, while Slackware does include SDL packages, I'm not so sure it includes the sdl_audio, sdl_preview, and sdl_still packages you mentioned.
Or am I incorrect in believing those three are in separate packages, with the truth being that they are actually part of the base SDL source package?
I tried to do a search on them, but I found nothing specific about them, and I didn't see any specific compile time switch to build them.
As I said, I greatly appreciate you taking the time and effort to help this far along, so don't take this as me being cross with you.
I just need to know exactly what I need to get this working, and I figure it might help others who are likely to run across the same problem I have.
So far, I have built from source SDL, MLT, FFMpeg, Kdenlive, libdv, and several other optional packages.
I just need to know what else specifically need to get it working, and I note that melt does not work at all, even though it neither crashes by itself nor gives me any kind of warning in the process.
(0006755)
oldpink (reporter)
2011-05-28 10:45

By the way, I ALWAYS set the "--prefix=/usr" and "--libdir=/usr/lib64" (I'm running a 64-bit CPU) to my configure lines to ensure I don't run across several different libraries and includes in conflict with each other.
(0006756)
j-b-m (administrator)
2011-05-28 10:59

Ok, I just wanted to make sure that you don't screw up your system with a mix of binaries and self compiled stuff.

So if you want to go further, the configure script for the MLT SDL modules does the following:

sdl-config --version

That should print out the current SDL version (mine is at 1.2.14)

Then it tests that the image include exists, like:

ls `sdl-config --prefix`/include/SDL/SDL_image.h

If you get an error with one of those 2 commands, then there is something wrong with your SDL install
(0006757)
oldpink (reporter)
2011-05-28 14:52

"sdl-config --version" returns "1.3.0"

"ls `sdl-config --prefix`/include/SDL/SDL_image.h" returns "/usr/include/SDL/SDL_image.h"

Sure is weird, isn't it?
(0006758)
j-b-m (administrator)
2011-05-28 20:16

SDL 1.3 was not yet officially released. It is a major version change and I am not sure that MLT supports it. I think you should use the stable 1.2.x version.
(0006760)
oldpink (reporter)
2011-05-28 22:28

Well, I did a "make uninstall" within my existing unstable (1.3x) version of SDL to remove it entirely from my system, then downloaded the latest stable release (1.2.14), compiling and installing that without a hitch.
I then pulled down the latest GIT version from source of MLT and compiled and installed that without a problem.
However, nothing changes one bit.
I am still incapable of using melt to play a single file, and "melt colour:red" returns nothing, not even an error message.
Here is the output when I enable the "-verbose" flag with melt on an MPEG-2 file.

melt -verbose test.mpg
[mpeg @ 0x86c580] max_analyze_duration reached
[mpeg @ 0x86fb80] max_analyze_duration reached
[mpeg @ 0x870bc0] max_analyze_duration reached
[mpeg @ 0x8a1940] max_analyze_duration reached
[mpeg @ 0x8a2de0] max_analyze_duration reached
[mpeg @ 0x8a56e0] max_analyze_duration reached
[producer avformat] audio: total_streams 1 max_stream 0 total_channels 2 max_channels 2
[mpeg @ 0x8b36b0] max_analyze_duration reached
[mpeg @ 0x8a4dc0] max_analyze_duration reached
[mpeg @ 0x8a5e00] max_analyze_duration reached

As I said, MLT just doesn't want to work at all.
Thanks again so far.
(0006763)
j-b-m (administrator)
2011-05-29 12:14

Does MLT now report the SDL consumer?

melt -query consumers

As a last resource, you could try the build script by Dan that downloads & compiles the latest FFmpeg, MLT and kdenlive in an isolated folder without the need to install, see:

http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/installing-source [^]
(0006765)
oldpink (reporter)
2011-05-29 14:01

melt -query consumers
---
consumers:
  - libdv
  - xml
  - sdi
  - decklink
  - avformat
  - null
  - gtk2_preview
  - mvcp
...

It's frustrating to put it mildly.
I suppose I could try your suggestion, but I bet even that won't work.
:(
(0006767)
j-b-m (administrator)
2011-05-29 15:04

Do you have a file called "disable-sdl" in the mlt/src/modules directory? If you do, try deleting it and configure again mlt.

You can also check if the MLT module was installed in $prefix/lib/mlt:

ls -la /usr/local/lib/mlt


Mine gives:

libmltavformat.so
libmltcore.so
libmltdecklink.so
libmltdgraft.so
libmlteffectv.so
libmltfrei0r.so
libmltgtk2.so
libmltjackrack.so
libmltkdenlive.so
libmltkino.so
libmltlinsys.so
libmltmelt.so
libmltmotion_est.so
libmltnormalize.so
libmltoldfilm.so
libmltplus.so
libmltqimage.so
libmltresample.so
libmltrotoscoping.so
libmltsdl.so
libmltsox.so
libmltvmfx.so
libmltvorbis.so
libmltxine.so
libmltxml.so
(0006779)
j-b-m (administrator)
2011-05-29 21:18

I made a quick search and the SDL Image library is not included in the basic SDL package, but can be found here:

http://www.libsdl.org/projects/SDL_image/ [^]

Also, I am not sure if audio is integrated in the main package... The SDL packages are widely used and should be available for your distro. Maybe it's easier if you try to install from your distro packages, because I never compiled SDL myself and cannot offer help on that, which is I think the cause of your problems.

regards
(0006782)
oldpink (reporter)
2011-05-30 02:31

Bingo!
Once I compiled and installed SDL_image, I was suddenly able to get some interesting output from "melt colour:red" and was also easily able to play a sample MPEG-2 file.
And, yes, this time Kdenlive started up and allowed me to configure it without a hitch.
Thanks so much!
At last, I have an alternative to Kino for DV-C captures.

*high fives*

-Scott

- Issue History
Date Modified Username Field Change
2011-05-26 20:33 oldpink New Issue
2011-05-27 10:35 j-b-m Note Added: 0006746
2011-05-27 10:35 j-b-m Assigned To => j-b-m
2011-05-27 10:35 j-b-m Status new => feedback
2011-05-27 22:47 oldpink Note Added: 0006750
2011-05-27 22:47 oldpink Status feedback => assigned
2011-05-27 23:29 j-b-m Note Added: 0006751
2011-05-28 02:20 oldpink Note Added: 0006752
2011-05-28 09:13 j-b-m Note Added: 0006753
2011-05-28 10:41 oldpink Note Added: 0006754
2011-05-28 10:45 oldpink Note Added: 0006755
2011-05-28 10:59 j-b-m Note Added: 0006756
2011-05-28 14:52 oldpink Note Added: 0006757
2011-05-28 20:16 j-b-m Note Added: 0006758
2011-05-28 22:28 oldpink Note Added: 0006760
2011-05-29 12:14 j-b-m Note Added: 0006763
2011-05-29 14:01 oldpink Note Added: 0006765
2011-05-29 15:04 j-b-m Note Added: 0006767
2011-05-29 21:18 j-b-m Note Added: 0006779
2011-05-30 02:31 oldpink Note Added: 0006782
2011-05-30 12:14 j-b-m Status assigned => resolved
2011-05-30 12:14 j-b-m Resolution open => no change required
2011-07-05 12:15 j-b-m Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker