Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002147KdenliveUser Interfacepublic2011-05-28 00:452011-11-01 18:56
Reporterneoarttec 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel 32 bitOSopenSuseOS Version11.4
Product Version0.8 
Target VersionFixed in Version0.8.2 
Summary0002147: Kdenlive crash on load project
DescriptionI had opened and edited a project.
Played the main timeline and then paused playback.
Kdenlive crashed with NO crash reporting assistant.
Each time I try to load ANY project now, when it reaches 75% loaded kdenlive crashes, this time with a crash reporting assistant.
When I choose restart application from the crash reporting assistant, Kdenlive starts.
But when I attempt to open an project again it crashes again at 75% loaded.
It then continues to repeatedly crash with a new a restart from the crash assistant and project load.

HOWEVER, if I start Kdenlive again from the desktop and NOT through the crash assistant, the project loads again.

However, upon playback and pause, I have the original crash again with no error reporting.

All of this then repeats from the top of my description again.

The crash report from the project loading failure is attached.
Steps To ReproduceLoad project.
Play timeline.
Pause timeline. ! CRASH !
Start Kdenlive
Load project. 75% loaded !CRASH !
Start Kdenlive from crash reporter.
Load project. 75% loaded !CRASH !

ad infinitum...

Until Kdenlive is started from Desktop and works again...
Repeat from the top again.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon kdenlive-20110528-000109.kcrash [^] (6,526 bytes) 2011-05-28 00:45 [Show Content]
? file icon kdenlive-20110529-130952.kcrash [^] (9,574 bytes) 2011-05-29 14:09 [Show Content]

- Relationships

-  Notes
(0006762)
neoarttec (reporter)
2011-05-29 00:36
edited on: 2011-05-29 00:37

Here is the final output to the command line from Kdenlive when it crashes.

KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/neoarttec/.kde4/socket-guild-media-02/kdeinit4__0
QSocketNotifier: Invalid socket 8 and type 'Read', disabling...
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
kdenlive: Fatal IO error: client killed
QSocketNotifier: Invalid socket 21 and type 'Read', disabling...

I am now having to load earlier simpler versions of the project file fist, then a later one (V.5), and then the final (V.14) so that Kdenlive does not crash on the project load. If I load the final version (V.14) straight up after Kdenlive starts, 90% it will crash.

The lack of stability is very frustrating.

I am adding the project files.

(0006766)
neoarttec (reporter)
2011-05-29 14:09

I've attached a crash report this time with all debugging symbols.
(0006768)
j-b-m (administrator)
2011-05-29 15:08

Thanks. The crash happens while generating the audio thumbnails, not sure why. But as a workaround, you can try to disable audio thumbs before opening your project. Let me know if the project opens correctly with audio thumbs disabled.
(0006770)
neoarttec (reporter)
2011-05-29 15:44
edited on: 2011-05-29 15:46

OK, found the option.

Settings / Configure Kdenlive / Timeline

That appears to be a temporary fix for the problem with loading the project files. Thank you.

The crash with the audio thumbnails is intermittent, but often.

However, I still have the problem of Kdenlive crashing after pausing playback about three times. As mentioned earlier, there is no crash report. If I start Kdenlive from the commandline, this is the only output that I receive.

KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/neoarttec/.kde4/socket-guild-media-02/kdeinit4__0
kdenlive: Fatal IO error: client killed
QSocketNotifier: Invalid socket 21 and type 'Read', disabling...

(0006771)
j-b-m (administrator)
2011-05-29 18:44

Good news, I think I found and fixed the crash related to audio thumbnails (svn rev. 5616)! If someone can test and report here to confirm. Now the pause crash is a different issue.
(0006774)
neoarttec (reporter)
2011-05-29 19:36

hmmm... looks like that someone might have to be me since I reported the issue. I will have to download the source and compile then. I haven't done that in a while and have been using packaged installs.

Regarding the crash on pause issue, I will log that as a separate bug then.
(0006776)
neoarttec (reporter)
2011-05-29 20:22

I have identified that my crash on pause issue is the same as bug 0002121

http://kdenlive.org/mantis/view.php?id=2121 [^]

I have added extra information.


Regarding this bug # 2147 I have noticed that the clip monitor playback is drastically improved by turning off the audio thumbnails. I've never been able to achieve a smooth play back of my Canon EOS 500D 700p videos, until now.
(0006937)
neoarttec (reporter)
2011-06-22 14:18

I can confirm that is a fix. Thank you JBM. 8)

- Issue History
Date Modified Username Field Change
2011-05-28 00:45 neoarttec New Issue
2011-05-28 00:45 neoarttec File Added: kdenlive-20110528-000109.kcrash
2011-05-29 00:36 neoarttec Note Added: 0006762
2011-05-29 00:37 neoarttec Note Edited: 0006762 View Revisions
2011-05-29 14:09 neoarttec File Added: kdenlive-20110529-130952.kcrash
2011-05-29 14:09 neoarttec Note Added: 0006766
2011-05-29 15:08 j-b-m Note Added: 0006768
2011-05-29 15:08 j-b-m Assigned To => j-b-m
2011-05-29 15:08 j-b-m Status new => feedback
2011-05-29 15:22 neoarttec Note Added: 0006769
2011-05-29 15:22 neoarttec Status feedback => assigned
2011-05-29 15:44 neoarttec Note Added: 0006770
2011-05-29 15:44 neoarttec Note Deleted: 0006769
2011-05-29 15:46 neoarttec Note Edited: 0006770 View Revisions
2011-05-29 18:44 j-b-m Note Added: 0006771
2011-05-29 18:44 j-b-m Status assigned => feedback
2011-05-29 19:36 neoarttec Note Added: 0006774
2011-05-29 19:36 neoarttec Status feedback => assigned
2011-05-29 20:22 neoarttec Note Added: 0006776
2011-06-22 14:18 neoarttec Note Added: 0006937
2011-06-22 21:02 j-b-m Status assigned => resolved
2011-06-22 21:02 j-b-m Fixed in Version => Recent git
2011-06-22 21:02 j-b-m Resolution open => fixed
2011-07-05 12:15 j-b-m Fixed in Version Recent git => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker