Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002195KdenliveUser Interfacepublic2011-06-25 23:032011-11-01 18:56
Reporterigloo 
Assigned Toj-b-m 
PrioritylowSeveritycrashReproducibilityrandom
StatusclosedResolutionfixed 
Platformamd64OSDebian LinuxOS Versionunstable
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002195: random crash when quitting
DescriptionWith r5728, I sometimes get a crash when quitting.
Additional InformationApplication: Kdenlive (kdenlive), signal: Segmentation fault
[KCrash Handler]
0000006 mlt_deque_pop_back (self=0x0) at mlt_deque.c:130
0000007 0x00007ff33dd498ec in producer_avformat_close (self=0x2056f80) at producer_avformat.c:2573
0000008 0x00007ff35ed27636 in cache_object_close (object=<value optimized out>, data=0x0, cache=<value optimized out>) at mlt_cache.c:131
0000009 0x00007ff35ed277c2 in mlt_cache_close (cache=0x2016960) at mlt_cache.c:229
0000010 0x00007ff35ed1657a in mlt_property_clear (self=0x2017510) at mlt_property.c:107
0000011 mlt_property_close (self=0x2017510) at mlt_property.c:475
0000012 0x00007ff35ed16b90 in mlt_properties_close (self=0x2016540) at mlt_properties.c:1258
0000013 mlt_properties_close (self=0x2016540) at mlt_properties.c:1229
0000014 0x00007ff35ed1657a in mlt_property_clear (self=0x2016910) at mlt_property.c:107
0000015 mlt_property_close (self=0x2016910) at mlt_property.c:475
0000016 0x00007ff35ed16b90 in mlt_properties_close (self=0xfa09d0) at mlt_properties.c:1258
0000017 mlt_properties_close (self=0xfa09d0) at mlt_properties.c:1229
0000018 0x00007ff35ed24cd1 in mlt_factory_close () at mlt_factory.c:375
0000019 0x00007ff35eaf9c07 in Mlt::Factory::close() () from /home/ian/code/melt/inst/lib/libmlt++.so.3
0000020 0x0000000000468035 in MainWindow::~MainWindow (this=0xf7dea0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /home/ian/code/kdenlive/kdenlive/src/mainwindow.cpp:626
0000021 0x0000000000468119 in MainWindow::~MainWindow (this=0xf7dea0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /home/ian/code/kdenlive/kdenlive/src/mainwindow.cpp:627
0000022 0x00007ff35e2d6d58 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
0000023 0x00007ff359c8675b in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000024 0x00007ff35a04146b in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000025 0x00007ff35de2926e in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
0000026 0x00007ff359c366d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000027 0x00007ff359c3b561 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000028 0x00007ff35dd2cfb6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000029 0x00007ff35e2c05fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000030 0x00007ff35e2c3944 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
0000031 0x00007ff35e2eacc3 in ?? () from /usr/lib/libQtCore.so.4
0000032 0x00007ff357e9d4a3 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000033 0x00007ff357e9dc80 in ?? () from /lib/libglib-2.0.so.0
0000034 0x00007ff357e9df1d in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000035 0x00007ff35e2eb11f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000036 0x00007ff359cda68e in ?? () from /usr/lib/libQtGui.so.4
0000037 0x00007ff35e2bf802 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000038 0x00007ff35e2bf9ff in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000039 0x00007ff35e2c3bd7 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000040 0x0000000000451fbb in main (argc=2, argv=0x7fff708aa298) at /home/ian/code/kdenlive/kdenlive/src/main.cpp:89
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0007029)
j-b-m (administrator)
2011-07-05 13:20

Was caused by the "Do not validate clips on opening" option from Kdenlive Settings->Misc. That option is now disabled, and crash is solved.

- Issue History
Date Modified Username Field Change
2011-06-25 23:03 igloo New Issue
2011-07-05 13:20 j-b-m Note Added: 0007029
2011-07-05 13:20 j-b-m Status new => resolved
2011-07-05 13:20 j-b-m Fixed in Version => 0.8.2
2011-07-05 13:20 j-b-m Resolution open => fixed
2011-07-05 13:20 j-b-m Assigned To => j-b-m
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker