Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002201KdenliveEffectspublic2011-06-29 20:112011-11-01 18:56
ReporterAlexK 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSDebian LinuxOS Version4.0
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002201: Audio crackles + second keyframe ineffective within `Volume (keyframeable)'
DescriptionMany issues with the Volume (keyframeable) effect:

1 Audio crackles (static) in use
2 Second keyframe ineffective*
3 Effect Stack window several pixels short at RHS
4 Position control does not work**

*Change from 1->2 is effective; then returns to kf#1 setting. Clip shows kf#2 level.
**Slider works; up/down chevrons work; numeric digits do not (display only, but can be selected)
Steps To Reproduce1 drop clip in timeline
2 select Volume (keyframeable) effect
3 add keyframe
4 leave kf#1 at 100%; set kf#2 at 10%; move kf#2 a few seconds along
5 play clip

(crackles throughout)
(volume returns to 100% after reaching kf#2)
Additional Information~$ kdenlive/20110628/start-kdenlive --version
Kdenlive Builder Wizard version: 11
libvpx: commit 9bcf07ae4a1ebd83713350ce7ef9c1d47de9d30f Date: Tue Jun 28 12:54:25 2011 -0700
x264: commit 4c552d873ada1be3cf2d77965427fab599d051a0 Date: Thu Jun 9 01:34:14 2011 +0400
frei0r: commit 6c65d6a48b8c0d51791bc3ba7e25a161c95fac30 Date: Wed Mar 16 00:54:34 2011 -0700
ffmpeg: commit dbe5f0172b4f123b15bc8ada82dd17b13c4bbbd7 Date: Tue Jun 28 22:23:52 2011 +0200
mlt: commit febfd488055a5994c96c5bc6b33213a609a7b054 Date: Sun Jun 26 23:07:08 2011 -0700
kdenlive: Revision: 5745 Last Changed Date: 2011-06-28 22:15:05 +0100 (Tue, 28 Jun 2011)
Qt: 4.7.3
KDE Development Platform: 4.4.5 (KDE 4.4.5)
Kdenlive: 0.8.1 (rev. 5745)

Also suffering occasional sudden crash on pressing play button in Monitor.

Setting a third keyframe at far rhs will then work as expected. Crackle volume varies with effect volume level.
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0006986)
AlexK (reporter)
2011-06-30 00:04

My note about the crackles is wrong: I was performing the experiment within a project corrupted by an earlier bug. Re-checking without any project loaded shows a clean audio track.

The info on reversion to 100% audio is accurate.
The visual within the clip shows audio to remain at the same level as kf#2 (10%) until the end. The actual level is 100% after the track progresses beyond kf#2.
Placing a 3rd kf at clip end at 10% is the workaround (or possibly design).
(0006996)
j-b-m (administrator)
2011-06-30 16:48

Ah, good to hear. The volume effect works in a way that is begins at first keyframe and ends at last keyframe, so it is nor:mal to have 100% volume after last keyframe.

This behaviour is not consistent with all effects, since some effects keep the last value after last keyframe. Last night, I made a small change to the timeline display so that if an effect is not applied before first kfr / after the last one, there is no line drawn before first / after last keyframe in the timeline keyframes, so it's slightly easier to understand.
(0006997)
AlexK (reporter)
2011-06-30 21:15
edited on: 2011-06-30 22:43

Consistency is good.

I was bitching to an artist friend about my problems with kdenlive. He pointed out some of the hair-pulling problems he experiences with Premiere Pro. Chances of Premier Pro bugs ever being fixed?

Thank you kindly, j-b-m. That is a sensible change; it was the disparity between visual feedback & reality that is the source of this report.

This report may be marked `closed' (I love saying that).

Added after update to SVN 5751: yes, that will do it nicely. It is obvious now that extra keyframes (may) need adding.


- Issue History
Date Modified Username Field Change
2011-06-29 20:11 AlexK New Issue
2011-06-30 00:04 AlexK Note Added: 0006986
2011-06-30 16:48 j-b-m Note Added: 0006996
2011-06-30 21:15 AlexK Note Added: 0006997
2011-06-30 22:43 AlexK Note Edited: 0006997 View Revisions
2011-07-05 13:11 j-b-m Status new => resolved
2011-07-05 13:11 j-b-m Fixed in Version => 0.8.2
2011-07-05 13:11 j-b-m Resolution open => fixed
2011-07-05 13:11 j-b-m Assigned To => j-b-m
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker