Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002205KdenliveFile Loadingpublic2011-07-01 13:472011-11-01 18:56
Reporterigloo 
Assigned Toj-b-m 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformamd64OSDebian LinuxOS Versionunstable
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002205: Crash when loading projects
DescriptionWhen I load one of my projects, kdenlive crashes. The "clip" list on the left hand side is still greyed out when it crashes, but the small progress bar window has closed.

I have r5754.
Additional InformationApplication: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4960d36780 (LWP 23558))]

Thread 2 (Thread 0x7f4930638700 (LWP 23563)):
#0 0x00007f495e78363b in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f495fdff61e in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
0000002 0x00007f495fdf3d6f in ?? () from /usr/lib/libQtCore.so.4
0000003 0x00007f495fdff215 in ?? () from /usr/lib/libQtCore.so.4
0000004 0x00007f495e77eb40 in start_thread () from /lib/libpthread.so.0
0000005 0x00007f495a5082ed in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4960d36780 (LWP 23558)):
[KCrash Handler]
0000006 mlt_deque_pop_back (self=0x0) at mlt_deque.c:130
0000007 0x00007f493f96e8ec in producer_avformat_close (self=0x24742f0) at producer_avformat.c:2573
0000008 0x00007f496094c636 in cache_object_close (object=<value optimized out>, data=0x0, cache=<value optimized out>) at mlt_cache.c:131
0000009 0x00007f496094cb58 in mlt_cache_put (cache=0x1dcc860, object=0x19b6990, data=0x1674730, size=0, destructor=0x7f493f96e7d0 <producer_avformat_close>) at mlt_cache.c:355
0000010 0x00007f493f9729b1 in producer_avformat_init (profile=0x10c4f20, service=<value optimized out>, file=0x17c6b98 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_avformat.c:215
0000011 0x00007f496094a18a in mlt_factory_producer (profile=0x10c4f20, service=0x17efa70 "avformat", input=0x17c6b98) at mlt_factory.c:250
0000012 0x00007f493fb7fe42 in create_from (profile=0x10c4f20, file=0x17c6b98 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_loader.c:43
0000013 create_producer (profile=0x10c4f20, file=0x17c6b98 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_loader.c:98
0000014 0x00007f493fb8013c in producer_loader_init (profile=0x10c4f20, type=<value optimized out>, id=0xbec7b0 "loader", arg=<value optimized out>) at producer_loader.c:198
0000015 0x00007f496094a18a in mlt_factory_producer (profile=0x10c4f20, service=0xbec7b0 "loader", input=0x17c6b98) at mlt_factory.c:250
0000016 0x00007f4960722d7e in Mlt::Producer::Producer(Mlt::Profile&, char const*, char const*) () from /home/ian/code/melt/inst/lib/libmlt++.so.3
0000017 0x00000000004c4aea in Render::getFileProperties (this=0x10c5020, xml=..., clipId=..., imageHeight=36, replaceProducer=false, selectClip=false) at /home/ian/code/kdenlive/kdenlive/src/renderer.cpp:598
0000018 0x00000000004c9ae6 in Render::qt_metacall (this=0x10c5020, _c=<value optimized out>, _id=22, _a=0x7f49280078b0) at /home/ian/code/kdenlive/kdenlive/build/src/cmake_bindir/renderer.moc:156
0000019 0x00007f495fefbd2a in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
0000020 0x00007f495b3b76d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000021 0x00007f495b3bc561 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000022 0x00007f495f951fb6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000023 0x00007f495fee55fc in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000024 0x00007f495fee8944 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
0000025 0x00007f495ff0fcc3 in ?? () from /usr/lib/libQtCore.so.4
0000026 0x00007f495961e4a3 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000027 0x00007f495961ec80 in ?? () from /lib/libglib-2.0.so.0
0000028 0x00007f495961ef1d in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000029 0x00007f495ff1011f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000030 0x00007f495b45b68e in ?? () from /usr/lib/libQtGui.so.4
0000031 0x00007f495fee4802 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000032 0x00007f495fee49ff in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000033 0x00007f495fee8bd7 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000034 0x00000000004524bb in main (argc=2, argv=0x7fffe5377228) at /home/ian/code/kdenlive/kdenlive/src/main.cpp:89
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0007006)
igloo (reporter)
2011-07-03 03:12

I've just tried updating to the latest melt (9828e9f2f8829940bfd0a11c6d85d173616374fc) and it still happens. Below is what it looks like in gdb. It seems to play OK with melt (skipping through it with 'L'; also, looks like melt uses the proxy files to play it). Please let me know if any more info would be useful.

Program received signal SIGSEGV, Segmentation fault.
mlt_deque_pop_back (self=0x0) at mlt_deque.c:130
130 return self->count > 0 ? self->list[ -- self->count ].addr : NULL;
(gdb) bt
#0 mlt_deque_pop_back (self=0x0) at mlt_deque.c:130
#1 0x00007fffd6bf790c in producer_avformat_close (self=0x23696d0)
    at producer_avformat.c:2574
0000002 0x00007ffff7bd5716 in cache_object_close (object=<value optimized out>,
    data=0x0, cache=<value optimized out>) at mlt_cache.c:131
0000003 0x00007ffff7bd5c38 in mlt_cache_put (cache=0x1cc1c20, object=0x196d680,
    data=0x1a22100, size=0,
    destructor=0x7fffd6bf77f0 <producer_avformat_close>) at mlt_cache.c:355
0000004 0x00007fffd6bfb9d1 in producer_avformat_init (profile=0xfc0bc0,
    service=<value optimized out>,
    file=0x1a2fd88 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_avformat.c:215
0000005 0x00007ffff7bd326a in mlt_factory_producer (profile=0xfc0bc0,
    service=0x165cbe0 "avformat", input=0x1a2fd88) at mlt_factory.c:250
0000006 0x00007fffd6e08e32 in create_from (profile=0xfc0bc0,
    file=0x1a2fd88 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_loader.c:43
0000007 create_producer (profile=0xfc0bc0,
    file=0x1a2fd88 "/home/ian/ext1/wedding/2_ceremony/kdenlive/proxy/1277f8406663555d9cc382daa2c727db.ts") at producer_loader.c:98
0000008 0x00007fffd6e0912c in producer_loader_init (profile=0xfc0bc0,
    type=<value optimized out>, id=0xae5650 "loader",
    arg=<value optimized out>) at producer_loader.c:198
0000009 0x00007ffff7bd326a in mlt_factory_producer (profile=0xfc0bc0,
    service=0xae5650 "loader", input=0x1a2fd88) at mlt_factory.c:250
0000010 0x00007ffff79abd7e in Mlt::Producer::Producer(Mlt::Profile&, char const*, char const*) () from /home/ian/code/melt/inst/lib/libmlt++.so.3
0000011 0x00000000004c4aea in Render::getFileProperties (this=0xfc0cc0, xml=...,
    clipId=..., imageHeight=36, replaceProducer=false, selectClip=false)
    at /home/ian/code/kdenlive/kdenlive/src/renderer.cpp:598
0000012 0x00000000004c9ae6 in Render::qt_metacall (this=0xfc0cc0,
    _c=<value optimized out>, _id=22, _a=0x196bb70)
    at /home/ian/code/kdenlive/kdenlive/build/src/cmake_bindir/renderer.moc:156
0000013 0x00007ffff7184d2a in QObject::event(QEvent*) ()
   from /usr/lib/libQtCore.so.4
0000014 0x00007ffff26406d4 in QApplicationPrivate::notify_helper(QObject*, QEvent*)
    () from /usr/lib/libQtGui.so.4
0000015 0x00007ffff2645561 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libQtGui.so.4
0000016 0x00007ffff6bdafb6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdeui.so.5
0000017 0x00007ffff716e5fc in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib/libQtCore.so.4
0000018 0x00007ffff7171944 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
0000019 0x00007ffff7198cc3 in ?? () from /usr/lib/libQtCore.so.4
0000020 0x00007ffff08a74a3 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000021 0x00007ffff08a7c80 in ?? () from /lib/libglib-2.0.so.0
0000022 0x00007ffff08a7f1d in g_main_context_iteration ()
   from /lib/libglib-2.0.so.0
0000023 0x00007ffff719911f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000024 0x00007ffff26e468e in ?? () from /usr/lib/libQtGui.so.4
0000025 0x00007ffff716d802 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000026 0x00007ffff716d9ff in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000027 0x00007ffff7171bd7 in QCoreApplication::exec() ()
   from /usr/lib/libQtCore.so.4
0000028 0x00000000004524bb in main (argc=2, argv=0x7fffffffddf8)
    at /home/ian/code/kdenlive/kdenlive/src/main.cpp:89
(gdb) up
#1 0x00007fffd6bf790c in producer_avformat_close (self=0x23696d0)
    at producer_avformat.c:2574
2574 while ( ( pkt = mlt_deque_pop_back( self->apackets ) ) )
(gdb) p self
$1 = (producer_avformat) 0x23696d0
(gdb) p *self
$2 = {parent = 0x23699c0, dummy_context = 0x0, audio_format = 0x0,
  video_format = 0x0, audio_codec = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0,
    0x0, 0x0}, video_codec = 0x0, av_frame = 0x0, audio_resample = {0x0, 0x0,
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, audio_expected = 0,
  video_expected = 0, audio_index = 0, video_index = 0, start_time = 0,
  first_pts = 0, last_position = 0, seekable = 0, current_position = 0,
  nonseek_position = 0, got_picture = 0, top_field_first = 0, audio_buffer = {
    0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, audio_buffer_size = {0,
    0, 0, 0, 0, 0, 0, 0, 0, 0}, decode_buffer = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0,
    0x0, 0x0, 0x0, 0x0}, audio_used = {0, 0, 0, 0, 0, 0, 0, 0, 0, 0},
  audio_streams = 0, audio_max_stream = 0, total_channels = 0,
  max_channel = 0, max_frequency = 0, invalid_pts_counter = 0,
  resample_factor = 0, image_cache = 0x0, colorspace = 0, video_mutex = {
    __data = {__lock = 0, __count = 0, __owner = 0, __nusers = 0, __kind = -1,
      __spins = 0, __list = {__prev = 0x0, __next = 0x0}},
    __size = '\000' <repeats 16 times>"\377, \377\377\377", '\000' <repeats 19 times>, __align = 0}, audio_mutex = {__data = {__lock = 0, __count = 0,
      __owner = 0, __nusers = 0, __kind = -1, __spins = 0, __list = {
        __prev = 0x0, __next = 0x0}},
    __size = '\000' <repeats 16 times>"\377, \377\377\377", '\000' <repeats 19 times>, __align = 0}, apackets = 0x0, vpackets = 0x0, packets_mutex = {
    __data = {__lock = 0, __count = 0, __owner = 0, __nusers = 0, __kind = -1,
      __spins = 0, __list = {__prev = 0x0, __next = 0x0}},
    __size = '\000' <repeats 16 times>"\377, \377\377\377", '\000' <repeats 19 times>, __align = 0}}
(gdb) p *self->parent
$3 = {parent = {parent = {child = 0x23699c0, local = 0x2369a40,
      close = 0x7ffff7bc95c0 <mlt_service_close>, close_object = 0x23699c0},
    get_frame = 0x7ffff7bcaa90 <producer_get_frame>,
    close = 0x7ffff7bc9f60 <mlt_producer_close>, close_object = 0x23699c0,
    local = 0x2367ee0, child = 0x23699c0},
  get_frame = 0x7fffd6bf7e60 <producer_get_frame>,
  close = 0x7fffd6bf86d0 <producer_close>, close_object = 0x23699c0,
  local = 0x0, child = 0x23696d0}
(0007014)
j-b-m (administrator)
2011-07-04 08:55

Can you check if you enabled the "Do not validate the video files when loading a project (faster)" option in Kdenlive Settings->Misc

I found at least one case where it caused a crash. Please also update to latest MLT since there was a possible crash fix committed yesterday.
(0007019)
igloo (reporter)
2011-07-04 13:44

Aha, I did have that on, and if I turn it off then the project loads. That also fixes 0002206.

Thanks!
(0007022)
j-b-m (administrator)
2011-07-04 23:07

I disabled the "Do not validate" trick on project opening, svn rev. 5763

- Issue History
Date Modified Username Field Change
2011-07-01 13:47 igloo New Issue
2011-07-03 03:12 igloo Note Added: 0007006
2011-07-04 08:55 j-b-m Note Added: 0007014
2011-07-04 08:55 j-b-m Assigned To => j-b-m
2011-07-04 08:55 j-b-m Status new => feedback
2011-07-04 13:44 igloo Note Added: 0007019
2011-07-04 13:44 igloo Status feedback => assigned
2011-07-04 23:07 j-b-m Note Added: 0007022
2011-07-04 23:07 j-b-m Status assigned => resolved
2011-07-04 23:07 j-b-m Fixed in Version => Recent git
2011-07-04 23:07 j-b-m Resolution open => fixed
2011-07-05 12:15 j-b-m Fixed in Version Recent git => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker