Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002214KdenliveFile Loadingpublic2011-07-05 15:512011-11-01 18:56
Reporterigloo 
Assigned Toj-b-m 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Platformamd64OSDebian LinuxOS Versionunstable
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002214: Corrupted project
DescriptionWhen I load the attached project I get a message
"Broken clip producer producer0"
with an "OK" button.

If I click OK, the project loads, but there is an "INVALID" red clip in the clip list, and it appears in 3 places in the timeline. There is no indication of what file these clips are meant to be from.

However, I believe they are all supposed to be part of 00015_00016.MTS, and other parts of that clip are correctly in the timeline.

Additionally, as I click around on the timeline, the "project monitor" doesn't correspond to where I'm clicking. Sometimes I click in an area where there is no clip, and I see an image. Other times I click somewhere there is a click but just see black.

I have r5754.

Do you know what happened? Or how I can fix it? Please let me know if you need any more information.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files? file icon bad_producer.kdenlive [^] (269,472 bytes) 2011-07-05 15:51

- Relationships

-  Notes
(0007033)
alphazo (reporter)
2011-07-05 16:01

I experienced the exact same problem.
(0007035)
j-b-m (administrator)
2011-07-05 16:58

Thanks for the report and the attached project. There was a bug that corrupted the project on opening when a missing producer was detected.

"Broken producer" message means Kdenlive did something wrong during the editing, but it is normally easily recovered automatically. However, due to a a bug in proxy handling, the whole project got corrupted on opening.

Should now be fixed in svn rev. 5764
(0007037)
igloo (reporter)
2011-07-05 17:36

Looks good. Loading gave a message:

Replaced wrong clip producer producer0 with 5
Replaced wrong clip producer producer0 with 5
Replaced wrong clip producer producer0 with 5

but it seemed fine once loaded. Saved the project, and now it loads without complaint.
(0007038)
alphazo (reporter)
2011-07-05 17:47

Seems good to me too with 5764. Although I had to load an older version of the project (thanks to the new incremental backup feature) to get rid of some invalid red boxes in the timeline.

- Issue History
Date Modified Username Field Change
2011-07-05 15:51 igloo New Issue
2011-07-05 15:51 igloo File Added: bad_producer.kdenlive
2011-07-05 16:01 alphazo Note Added: 0007033
2011-07-05 16:58 j-b-m Note Added: 0007035
2011-07-05 16:58 j-b-m Assigned To => j-b-m
2011-07-05 16:58 j-b-m Status new => feedback
2011-07-05 17:36 igloo Note Added: 0007037
2011-07-05 17:36 igloo Status feedback => assigned
2011-07-05 17:47 alphazo Note Added: 0007038
2011-07-06 00:18 j-b-m Status assigned => resolved
2011-07-06 00:18 j-b-m Fixed in Version => 0.8.2
2011-07-06 00:18 j-b-m Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker