Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002265KdenliveRenderingpublic2011-07-31 12:222011-11-01 18:56
Reporterstelvio.p 
Assigned Tottill 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSDebian GNU/LinuxOS VersionSid unstable
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002265: No audio in Vorbis rendering (both OGV and WebM)
DescriptionHi,
when I render a project in a format with vorbis audio, I got a video file with a silent audio track. It happens with WebM and Theora, but NOT with Theora 720x576!!

Maybe something wrong with profile defaults.

Steps To ReproduceOpen a project (with audio of course), and render in WebM or Theora (not theora 720x576). Open new file with kdenlive (or any player) and it will have a totally mute track audio.

Additional InformationDebian Sid 64 bit
Kdenlive build from script

$ ./start-kdenlive -v
Kdenlive Builder Wizard version: 11
libvpx: commit 6f080f9cec229bac78f78b5726849793aea91fd5 Date: Fri Jul 29 11:57:48 2011 -0700
x264: commit 392e762151d1657abc8ae5d345c144c3ef280819 Date: Wed Jul 27 02:23:12 2011 +0200
frei0r: commit 83d6bc91914fc1fe7964acde847ea427693f8788 Date: Thu Jul 21 18:37:28 2011 +0200
ffmpeg: commit 8400607267458371398b0d3f170b6c0d9c688453 Date: Sun Jul 31 00:34:34 2011 +0200
mlt: commit b0e27fe79ba477055ce7d7deab212f1449c062ac Date: Thu Jul 28 23:21:55 2011 -0700
kdenlive: Revision: 5814 Last Changed Date: 2011-07-31 00:13:47 +0200 (Sun, 31 Jul 2011)
Qt: 4.7.3
KDE Development Platform: 4.6.5 (4.6.5)
Kdenlive: 0.8.1 (rev. 5814)

RENDER PROFILE

Theora
#### This does'n work ####
acodec=vorbis ab=128k ar=44100 vcodec=libtheora minrate=0 b=%bitrate+'k' aspect=%dar pass=%passes

Theora 720x576
#### This work ####
acodec=vorbis ab=384k aq=30 ar=44100 vcodec=libtheora minrate=0 b=12000k s=720x576 aspect=%dar pass=%passes
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0007158)
ttill (developer)
2011-08-09 16:56

Thanks for you report!
Should be fixed in svn r5826. We have to set aq for vorbis to work. With older versions of ffmpeg this was optional.
(0007161)
stelvio.p (reporter)
2011-08-09 20:14

Hi!

I think you've got the problem: I can't try svn5826, because I have also melt problem (crash on startup, issue 2277), but I've tried to add "aq=30" to old (svn5823) vorbis profile and it work as expected!!

Thank you for your help,
bye!!

Stelvio

- Issue History
Date Modified Username Field Change
2011-07-31 12:22 stelvio.p New Issue
2011-08-09 16:56 ttill Note Added: 0007158
2011-08-09 16:56 ttill Assigned To => ttill
2011-08-09 16:56 ttill Status new => feedback
2011-08-09 20:14 stelvio.p Note Added: 0007161
2011-08-09 20:14 stelvio.p Status feedback => assigned
2011-08-10 10:07 ttill Status assigned => resolved
2011-08-10 10:07 ttill Resolution open => fixed
2011-08-10 10:07 ttill Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker