Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002269KdenliveEffectspublic2011-08-01 20:332011-11-01 18:56
Reportermoorsey 
Assigned Tottill 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformUbuntuOSUbuntuOS Version10.10
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002269: Obscure effect stops working when keyframe is added
DescriptionUsing latest sunab build, 1920=1080 MTS clips with proxy clips enabled

Adding the obscure effect works as expected, resizable box appears on video, everything in the box is blurred.

As soon as a keyframe is added, the box remains, but nothing is obscured by the effect any more. Removing the keyframe causes the blurring to return
Steps To Reproduceadd clip
add obscure effect
add keyframe to effect
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0007127)
ttill (developer)
2011-08-02 10:24

The way keyframes work in the MLT obscure filter is a bit unusual and we currently do not support it.
So I disabled keyframes again (someone accidentally turned them on).
(0007131)
moorsey (reporter)
2011-08-02 11:28

ah, thanks ttill, no problem.

Looks like I will have to look elsewhere for blanking number plates! Not sure there is another keyframable effect to do this though, Tried automask, but found it did not pick up with number plate well enough.

Thanks
(0007155)
ttill (developer)
2011-08-09 15:54

You can either overlay something and move it using the affine transition or you can place two copies of the clip above each other, add composite transition, blur or pixelate the top one and use 'rotoscoping', or 'alpha shapes' on the top clip to define the area.
I implemented tracking for rotoscoping but it doesn't work very good so it isn't in the official mlt branch yet. Maybe at some point...
(0007189)
moorsey (reporter)
2011-08-10 21:40

ahh ok, that makes sense, some clever ways of getting around the problem, thanks for the help.

This can be closed anyway, original issue has an answer

- Issue History
Date Modified Username Field Change
2011-08-01 20:33 moorsey New Issue
2011-08-02 10:24 ttill Note Added: 0007127
2011-08-02 10:24 ttill Assigned To => ttill
2011-08-02 10:24 ttill Status new => feedback
2011-08-02 11:28 moorsey Note Added: 0007131
2011-08-02 11:28 moorsey Status feedback => assigned
2011-08-09 15:54 ttill Note Added: 0007155
2011-08-10 21:40 moorsey Note Added: 0007189
2011-08-12 12:20 ttill Status assigned => resolved
2011-08-12 12:20 ttill Fixed in Version => 0.8.2
2011-08-12 12:20 ttill Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker