Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002284KdenliveBuild Systempublic2011-08-16 02:402011-11-01 18:56
Reportercolesen 
Assigned To 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel 32 bitOSFedoraOS Version15
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0002284: build-kdenlive.sh exits with error
Descriptionthe script
build-kdenlive.sh
from
http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts [^]
exits with error
with the last part of the log as follows

- cut -
LOG: Done configuring kdenlive
LOG: Number of steps completed : 38
LOG: Building kdenlive - this could take some time
LOG: About to run command: make -j3
Scanning dependencies of target kdenlive_automoc
Scanning dependencies of target kdenlive_render_automoc
Scanning dependencies of target westleypreview_automoc
Generating renderjob.moc
Generating moc_westleypreview.cpp
[ 0%] Built target kdenlive_render_automoc
Scanning dependencies of target kdenlive_sampleplugin_automoc
Generating moc_sampleplugin.cpp
- cut -
Generating clipdurationdialog.moc
[ 5%] Built target pofiles
[ 6%] Built target pofiles
Scanning dependencies of target pofiles
[ 6%] Generating kdenlive.gmo
Scanning dependencies of target pofiles
[ 6%] Generating kdenlive.gmo
[ 6%] Built target pofiles
[ 6%] Scanning dependencies of target pofiles
Built target pofiles
[ 6%] Generating kdenlive.gmo
Scanning dependencies of target pofiles
[ 6%] Generating projectlist.moc
Generating kdenlive.gmo
kdenlive.po:3850: `msgid' and `msgstr' entries do not both end with '\n'
kdenlive.po:7744: `msgid' and `msgstr' entries do not both end with '\n'
/usr/bin/msgfmt: found 2 fatal errors
make[2]: *** [po/pt_BR/kdenlive.gmo] Error 1
make[1]: *** [po/pt_BR/CMakeFiles/pofiles.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 6%] Built target pofiles
Generating rotowidget.moc
- cut -
Generating moc_dvdwizardmenu.cpp
[ 6%] Built target kdenlive_automoc
make: *** [all] Error 2
ERROR: Unable to build kdenlive
LOG: Process has finished. Reason: FAILURE Some kind of error occured: Unable to build kdenlive

===========================

as workaround I made 2 changes to ~/kdenlive/src/kdenlive/po/pt_BR/kdenlive.po as follows

from

#: src/dvdwizard.cpp:696
msgid "Folder %1 already exists. Overwrite?\n"
msgstr ""
"Pasta %1 já existe.\n"
"Você deseja sobrescrevê-lo?"

to

#: src/dvdwizard.cpp:696
msgid "Folder %1 already exists. Overwrite?\n"
msgstr "Pasta %1 já existe. Sobrescrevê?\n"

and

from

#: src/kdenlivesettingsdialog.cpp:261 src/kdenlivesettingsdialog.cpp:304
msgid "Supported capture modes:\n"
msgstr "Modo de Captura suportado: %1"

to

#: src/kdenlivesettingsdialog.cpp:261 src/kdenlivesettingsdialog.cpp:304
msgid "Supported capture modes: %1"
msgstr "Modo de Captura suportado: %1"

with which the build script completes without errors. But that workaround is just that and not necessarily the fix.
Steps To Reproducefollow the procedure under "Run the script" for kdenlive on
http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts [^]
Additional InformationI used that build script method to update kdenlive from 0.7.8 which is the lastest for Fedora 15 (why hasn't Fedora 15 been updated with a more recent version of kdenlive?)
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Files

- Relationships

-  Notes
(0007205)
sunab (reporter)
2011-08-16 12:11

FTBS caused by the latest brazilian translation : commit 5833
(0007206)
soares_souza (reporter)
2011-08-17 20:30

I will fix this problem and send a new revision of the translation. Thank you.
(0007208)
sunab (reporter)
2011-08-20 10:29

Fixed in svn trunk.

Thanks

- Issue History
Date Modified Username Field Change
2011-08-16 02:40 colesen New Issue
2011-08-16 12:11 sunab Note Added: 0007205
2011-08-17 20:30 soares_souza Note Added: 0007206
2011-08-20 10:29 sunab Note Added: 0007208
2011-08-25 19:58 ttill Status new => resolved
2011-08-25 19:58 ttill Resolution open => fixed
2011-08-25 19:58 ttill Fixed in Version => 0.8.2
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker