Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002306KdenliveEffectspublic2011-09-08 22:382011-09-09 23:56
Reportertcrass 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
PlatformAMD64OSDebian unstableOS Version3.0.0-1-686-pae
Product Version 
Target VersionFixed in Version 
Summary0002306: "Audio correction/Volume (keyframable)" shows up as several "dead" Volume effects after saving & reloading a project
DescriptionWhen applying a keyframable volume effect to an audio clip, the effect is missing from the clip's effect stack after saving and reloading the project. Instead, a number of "normal" volume effects show up, the number of which correspond to the number of keyframes initially set. However, when selecting any of these volume effects, neither gain nor keyframe position can be adjusted (no widgets are shown at all).
The funny thing is, the original keyframable volume effect seems to somehow get restored when re-loading the project-- at least, the track's volumne envelope sounds like originally defined.
Steps To Reproduce1. Create a new project
2. Import an audio clip into the project
3. Drag the audio clip onto any audio track
4. Add a keyframable volume affect to the clip and add some keyframes
5. Save the project and exit kdenlive
6. Restart kdenlive and re-load the project
7. Click on the audio clip and have a look at its effect stack
Additional InformationAttachments:
- the original project file
- the a file containing the re-loaded project, saved again
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon volume-keyframable-test.kdenlive [^] (6,451 bytes) 2011-09-08 22:38
? file icon volume-keyframable-test-reloaded.kdenlive [^] (6,501 bytes) 2011-09-08 22:39

- Relationships

-  Notes
(0007290)
j-b-m (administrator)
2011-09-08 23:58

If I remember correctly, this problem comes from using a recent MLT version (> 0.7.2) which is not supported by Kdenlive 0.8. You should revert to MLT 0.7.2 to fix the issue.

Let me know if this is the problem.

We are doing our best to release Kdenlive 0.8.2 that will fix many issues and work with the latest MLT versions.
(0007299)
tcrass (reporter)
2011-09-09 23:56

j-b-m,

thanks for the quick reply. Unfortunately, Debian won't let me install a previous MLT version without removing kdenlive, which somehow contradicts the whole idea... So I guess I'll just have to wait for 8.2

Regards --

tcrass

- Issue History
Date Modified Username Field Change
2011-09-08 22:38 tcrass New Issue
2011-09-08 22:38 tcrass File Added: volume-keyframable-test.kdenlive
2011-09-08 22:39 tcrass File Added: volume-keyframable-test-reloaded.kdenlive
2011-09-08 23:58 j-b-m Note Added: 0007290
2011-09-08 23:58 j-b-m Assigned To => j-b-m
2011-09-08 23:58 j-b-m Status new => feedback
2011-09-09 23:56 tcrass Note Added: 0007299
2011-09-09 23:56 tcrass Status feedback => assigned


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker