Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002331KdenliveUser Interfacepublic2011-09-24 21:452011-11-01 18:56
ReporterBueschi 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformPhenom X3 705e; NFS RootOSGentoo Linux x86OS VersionBase 2.0.3
Product Version0.7.8 
Target VersionFixed in Version0.8.2 
Summary0002331: crashes on title generator font selection
DescriptionHello,

if i want to select a font in the title generator the complete desktop session (icewm as windowmanager) freezes and only a kill -9 will help to get back access to the screen. The time and the mouse cursor moves on.
Steps To Reproduceselect a font in the drop down menue. The same effect is on V0.8 at the gentoo repository.
Additional InformationWhen i use strace with kdenlive the following data will be pulled out at crash:
......
read(13, "", 1) = 0
read(13, "", 16384) = 0
read(13, "", 1) = 0
read(13, "", 16384) = 0
read(13, "", 1) = 0
read(13, "", 16384) = 0
read(13, "", 1) = 0
read(13, "", 16384) = 0
read(13, "", 1) = 0
read(13, "", 16384) = 0
read(13, "", 1) = 0
read(13, "", 16384) = 0
read(13, "", 1) = 0
read(13, "", 16384) = 0
read(13, ) = ? <unavailable>
+++ killed by SIGKILL +++
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0007422)
j-b-m (administrator)
2011-10-09 11:03

Cannot reproduce. Maybe you have some corrupted fonts on your system. Can you try another KDE application that uses a font selection dialog to see if the freeze also happens? For example the Konqueror Settings dialog has a font selection combo in the Appearance > Font tab...
(0007428)
Bueschi (reporter)
2011-10-09 22:42
edited on: 2011-10-09 22:53

OK, have testet with Konqueror 4.6.5.
The same here, want to scroll down in the fonts, the hole screen crash.
Other non-KDE apps like OpenOffice don't have this problem.

I have found a masked package "media-fonts/artwiz-fonts" installed on my system.
After unmerge this Konqueror and KDEnlive work!

You can close this case, thank you.


- Issue History
Date Modified Username Field Change
2011-09-24 21:45 Bueschi New Issue
2011-10-09 11:03 j-b-m Note Added: 0007422
2011-10-09 11:03 j-b-m Assigned To => j-b-m
2011-10-09 11:03 j-b-m Status new => feedback
2011-10-09 22:42 Bueschi Note Added: 0007428
2011-10-09 22:42 Bueschi Status feedback => assigned
2011-10-09 22:53 Bueschi Note Edited: 0007428 View Revisions
2011-10-10 14:05 j-b-m Status assigned => resolved
2011-10-10 14:05 j-b-m Fixed in Version => 0.8.2
2011-10-10 14:05 j-b-m Resolution open => no change required
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker