Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002338KdenliveRenderingpublic2011-09-30 09:372011-11-01 18:56
ReporterSnild 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Platform64 bitOSUbuntuOS Version10.10
Product Version0.7.8 
Target VersionFixed in Version0.8.2 
Summary0002338: Simultaneous 2-pass renders: log file clobbering
DescriptionIt seems simultaneous 2-pass renders overwrites each others' log files; all of them are using x264_2pass.log. For me, this led to a couple of rendered files without any video. The problem is probably timing-dependent.
Steps To Reproduce1. Enqueue multiple two-pass renderings (I used the default H.264 2000k 2-pass, modified to use 256kbps audio). The first one will auto-start.
2. Select an enqueued job and click the "Start Job" button.
3. These are now both using the same log file for their pass logs.
Additional InformationWhen I encountered the problem (haven't actually tried again, because I'm fairly sure I've identified the cause), I had one long-running render running first, then started two shorter ones. Both of the short renders came out as audio only (though during the first pass, both files grew large enough to indicate video was being written at that point). When I noticed this and realized the cause, I aborted the long-running render (since it would be running for a couple of hours more).
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0007412)
j-b-m (administrator)
2011-10-07 00:10

This is actually an FFmpeg issue, see report in the libav bugtracker:
http://roundup.libav.org/issue303 [^]

Nothing can be done on the Kdenlive side...
(0007413)
j-b-m (administrator)
2011-10-07 01:24

In fact, the issue was recently fixed in FFmpeg, so in svn rev. 5946, Kdenlive now sets the log file name to the name of the rendered file + ".log", so that simultaneous encoding will now work

(This requires a recent FFmpeg)

- Issue History
Date Modified Username Field Change
2011-09-30 09:37 Snild New Issue
2011-10-07 00:10 j-b-m Note Added: 0007412
2011-10-07 00:10 j-b-m Assigned To => j-b-m
2011-10-07 00:10 j-b-m Status new => acknowledged
2011-10-07 01:24 j-b-m Note Added: 0007413
2011-10-07 01:24 j-b-m Status acknowledged => resolved
2011-10-07 01:24 j-b-m Fixed in Version => 0.8.2
2011-10-07 01:24 j-b-m Resolution open => fixed
2011-11-01 18:56 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker