Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002367KdenliveUser Interfacepublic2011-11-01 05:012011-12-08 22:51
Reporterpez4brian 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in VersionRecent git 
Summary0002367: PATCH: Add "Date" column to project tree view
DescriptionThe attached patch adds a date column to the project tree view. For clips that are files, it will display the modified date of the file. The items can be sorted by the date column. The date column can be hidden (just like the description and rating columns)

Please consider this addition for Kdenlive.
Additional InformationMy workflow goes as follows:
1) Download clips from my various cameras over time to my computer
2) After some time, I have many clips in many folders (some with the same file name) from different times.
3) Load all clips into Kdenlive
4) Put in chronological order
5) Edit and cut to taste
6) export for archival

Step four is a pain. I would like it if Kdenlive would just order the clips chronologically for me. The attached patch does just that. It adds a column to the project tree view that shows the file modified date. The clips can be ordered by the date column. Then, I can "ctl-a" and drag the clips to the timeline. They end up in the timeline in the same order they are in the tree (chronological). This speeds up my workflow considerably because I don't have to try to find the date for each file.
TagsNo tags attached.
Build/Install Method(select)
Attached Filestxt file icon date_column_20111031.txt [^] (2,276 bytes) 2011-11-01 05:02 [Show Content]
png file icon date_column_20111031.png [^] (51,097 bytes) 2011-11-01 05:02

- Relationships

-  Notes
(0007580)
j-b-m (administrator)
2011-11-14 22:07

Patch applied to git master, thanks

- Issue History
Date Modified Username Field Change
2011-11-01 05:01 pez4brian New Issue
2011-11-01 05:02 pez4brian File Added: date_column_20111031.txt
2011-11-01 05:02 pez4brian File Added: date_column_20111031.png
2011-11-14 22:07 j-b-m Note Added: 0007580
2011-11-14 22:07 j-b-m Status new => resolved
2011-11-14 22:07 j-b-m Fixed in Version => Recent git
2011-11-14 22:07 j-b-m Resolution open => fixed
2011-11-14 22:07 j-b-m Assigned To => j-b-m
2011-12-08 22:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker