Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002368KdenliveFile Loadingpublic2011-11-01 21:112011-12-08 22:51
Reporterokor 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version10.04
Product VersionRecent git 
Target VersionFixed in Version0.8.2.1 
Summary0002368: Crashes when trying to open project file
DescriptionCrashes when trying to open project file
Steps To Reproduce- Open kdenlive (0.8.2 from Sunab ppa)
- Click the "File" menu
- Select "Open"
- CRASH
Additional InformationStarting program: /usr/bin/kdenlive
[Thread debugging using libthread_db enabled]
Object::connect: No such signal NotesWidget::aboutToShowContextMenu(QMenu *)
project monitor connected
clip monitor connected
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
[New Thread 0x7fffd9127700 (LWP 5190)]
[New Thread 0x7fffd8926700 (LWP 5191)]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff42105bb in QDomNode::QDomNode(QDomNode const&) () from /usr/lib/libQtXml.so.4
(gdb) thread apply all bt

Thread 3 (Thread 0x7fffd8926700 (LWP 5191)):
#0 0x00007ffff5aab85c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007fffe1136921 in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007ffff5aa69ca in start_thread () from /lib/libpthread.so.0
0000003 0x00007ffff21a770d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fffd9127700 (LWP 5190)):
#0 0x00007ffff5aabbc9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007ffff7bcf350 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.4
0000002 0x00007ffff7bd053e in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.4
0000003 0x00007fffe113701c in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007ffff5aa69ca in start_thread () from /lib/libpthread.so.0
0000005 0x00007ffff21a770d in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffff7fbe780 (LWP 5189)):
#0 0x00007ffff42105bb in QDomNode::QDomNode(QDomNode const&) () from /usr/lib/libQtXml.so.4
#1 0x00007ffff672839f in KBookmarkManager::internalDocument() const () from /usr/lib/libkio.so.5
0000002 0x00007ffff67283e3 in KBookmarkManager::root() const () from /usr/lib/libkio.so.5
0000003 0x00007ffff672849d in ?? () from /usr/lib/libkio.so.5
0000004 0x00007ffff6727905 in KBookmarkManager::parse() const () from /usr/lib/libkio.so.5
0000005 0x00007ffff6728386 in KBookmarkManager::internalDocument() const () from /usr/lib/libkio.so.5
0000006 0x00007ffff67283e3 in KBookmarkManager::root() const () from /usr/lib/libkio.so.5
0000007 0x00007fffd3300eeb in KFilePlacesModel::KFilePlacesModel(QObject*) () from /usr/lib/libkfile.so.4
0000008 0x00007fffd32f437e in KFileWidget::KFileWidget(KUrl const&, QWidget*) () from /usr/lib/libkfile.so.4
0000009 0x00007fffd353cf14 in ?? () from /usr/lib/kde4/kfilemodule.so
0000010 0x00007ffff674dc82 in KFileDialog::KFileDialog(KUrl const&, QString const&, QWidget*, QWidget*) () from /usr/lib/libkio.so.5
0000011 0x00007ffff674f0d8 in ?? () from /usr/lib/libkio.so.5
0000012 0x00007ffff674f2fc in KFileDialog::getOpenUrl(KUrl const&, QString const&, QWidget*, QString const&) () from /usr/lib/libkio.so.5
0000013 0x0000000000489324 in _start ()
(gdb)
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships
duplicate of 0002363closedj-b-m Crash when trying to save project as a new file using "save as" 

-  Notes
(0007483)
sunab (reporter)
2011-11-01 23:12

Unable to reproduce here in a fresh install of ubuntu 10.04.3 (virtual machine).

Could you report kde version, and kde packages origin (kubuntu-backports ppa?)
(0007486)
okor (reporter)
2011-11-02 20:15

Sure, I'm using KDE 4.4.5 . As far as kde packages origin...I'm using the standard repos that come with ubuntu x64 and the sunab ppa, that's it. It may be worth noting that this system was built with ubuntu 10.04, not the more updated 10.04.3 .
(0007487)
okor (reporter)
2011-11-02 20:19

I think it it related to the "save file as" bug, which I can also replicate. If I completely remove the "~/.kde" directory, the bugs are gone. UNTIL, I open it a second time, at that time all bugs return.

- Issue History
Date Modified Username Field Change
2011-11-01 21:11 okor New Issue
2011-11-01 23:12 sunab Note Added: 0007483
2011-11-02 20:15 okor Note Added: 0007486
2011-11-02 20:19 okor Note Added: 0007487
2011-11-02 21:30 j-b-m Relationship added duplicate of 0002363
2011-11-22 00:47 j-b-m Status new => resolved
2011-11-22 00:47 j-b-m Fixed in Version => 0.8.2.1
2011-11-22 00:47 j-b-m Resolution open => duplicate
2011-11-22 00:47 j-b-m Assigned To => j-b-m
2011-12-08 22:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker