Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000237KdenliveUser Interfacepublic2008-10-21 10:582008-12-29 15:52
Reporterjmpoure 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDebianOSGNU/LinuxOS VersionSID
Product Version 
Target Version0.7.1Fixed in Version0.7.1 
Summary0000237: Unable to open Kdenlive 0.4 project (project file version 0.5) - let user know not supported
DescriptionWhenever I try to open any Kdenlive 0.5 project, Kdenlive enters an infinite loop. Here is the copy of an old Kdenlive 0.5 family movie. If Kdenlive 0.5 projects are not supported, then Kdenlive should check project version and avoid loading project.
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Files? file icon manege.kdenlive [^] (26,260 bytes) 2008-10-21 10:58
? file icon kbw.gdb.output.Eqy21604 [^] (39,531 bytes) 2008-10-21 20:42
patch file icon old_documents_refusal.svn2803.patch [^] (11,261 bytes) 2008-12-18 01:39 [Show Content]

- Relationships
related to 0000229assignedxzhayon Invalid XML in .kdenlive file sometimes crashes Kdenlive sometimes results in no errors - implement validation and response 

-  Notes
(0000532)
madsdyd (administrator)
2008-10-21 20:43

When I try to load the manage.kdenlive file, Kdenlive crashes (gdb log attached).

I have made this issue related to issue 229.
(0000896)
madsdyd (administrator)
2008-11-08 19:38

Could you try this again with svn rev. 2636 - it does not solve everything (far from it), but crashes I get now does not seem related to the file format, but rather to not having the media ...
(0001776)
xzhayon (developer)
2008-12-18 00:15
edited on: 2008-12-18 00:20

i can load the file, but i get a crash when i start playing. some clips are being removed as they're declared "invalid"... this isn't because they're not found, they should be left as placeholders
i'm going to see why

(0001777)
xzhayon (developer)
2008-12-18 01:39

project version is 0.5, i didn't even know of it...
since it is currently unsupported (should we consider supporting it?), i wrote a patch to refuse its loading
i've rewritten a bit the kdenlivedoc constructor (now it's similar to your old version, mads)
IMPORTANT: this patch requires the one from 358 to be applied
(0001784)
madsdyd (administrator)
2008-12-18 12:55

Resolved in commit 2807 - patch by Alberto Villa. Thanks.

- Issue History
Date Modified Username Field Change
2008-10-21 10:58 jmpoure New Issue
2008-10-21 10:58 jmpoure File Added: manege.kdenlive
2008-10-21 20:42 madsdyd Relationship added related to 0000229
2008-10-21 20:42 madsdyd File Added: kbw.gdb.output.Eqy21604
2008-10-21 20:43 madsdyd Note Added: 0000532
2008-10-21 20:43 madsdyd Status new => acknowledged
2008-10-21 20:43 madsdyd Category Rendering => User Interface
2008-10-23 00:26 madsdyd Target Version => 0.7.0
2008-10-30 09:00 madsdyd Target Version 0.7.0 => 0.7.1
2008-11-08 19:38 madsdyd Note Added: 0000896
2008-11-17 20:54 madsdyd Target Version 0.7.1 => future version
2008-12-18 00:15 xzhayon Note Added: 0001776
2008-12-18 00:20 xzhayon Note Edited: 0001776
2008-12-18 01:39 xzhayon Note Added: 0001777
2008-12-18 01:39 xzhayon File Added: old_documents_refusal.svn2803.patch
2008-12-18 12:55 madsdyd Build/Install Method => Other Method?
2008-12-18 12:55 madsdyd Note Added: 0001784
2008-12-18 12:55 madsdyd Status acknowledged => resolved
2008-12-18 12:55 madsdyd Resolution open => fixed
2008-12-18 12:55 madsdyd Fixed in Version => Recent git
2008-12-18 12:55 madsdyd Summary Unable to open Kdenlive 0.5 project => Unable to open Kdenlive 0.4 project (project file version 0.5) - let user know not supported
2008-12-29 15:36 madsdyd Fixed in Version Recent git => 0.7.1
2008-12-29 15:37 madsdyd Status resolved => closed
2008-12-29 15:52 madsdyd Target Version future version => 0.7.1


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker