Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002396KdenliveBuild Systempublic2011-11-08 19:142011-12-08 22:51
Reportercolesen 
Assigned Toj-b-m 
PriorityurgentSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
Platformi386OSfedoraOS Version16
Product VersionRecent git 
Target VersionFixed in VersionRecent git 
Summary0002396: run of kdenlive build script fails on just released Fedora 16
DescriptionRun of the kdenlive build script

http://www.mltframework.org/twiki/pub/MLT/BuildScripts/build-kdenlive.sh [^]

fails with

kdenlive/src/kdenlive/src/videoglwidget.cpp:80:35: error:
'gluOrtho2D' was not declared in this scope

on Fedora 16 released today
Steps To Reproducesee under kdenlive on http://www.mltframework.org/twiki/pub/MLT/BuildScripts [^]
Additional InformationThe reason is that
qgl.h
as included by
QtOpenGL
as included by
videoglwidget.cpp
no longer includes
glu.h
which declares
gluOrtho2D

With the following line
#include "GL/glu.h"
appended to the lines of the other includes in
videoglwidget.cpp
the build script completes succesfully
but I do not know if that is a proper fix
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-11-08 19:14 colesen New Issue
2011-11-14 19:42 j-b-m Status new => resolved
2011-11-14 19:42 j-b-m Fixed in Version => Recent git
2011-11-14 19:42 j-b-m Resolution open => fixed
2011-11-14 19:42 j-b-m Assigned To => j-b-m
2011-12-08 22:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker