Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002404KdenliveUser Interfacepublic2011-11-12 09:072011-12-08 22:51
Reporternorms2 
Assigned Toj-b-m 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntuOS Version10.10
Product VersionRecent git 
Target VersionFixed in Version0.8.2.1 
Summary0002404: Added transitions do not show up in timeline
DescriptionAdd a dissolve to clip appears to works but does not show in timeline.
Adding new Composite has no effect at all.
Steps To ReproduceWhen loading existing project transitions do not show but still work.
It seems I cannot add any further transitions
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships

-  Notes
(0007551)
evorster (reporter)
2011-11-12 09:35

Hi.
Can you check that you have the latest version of mlt installed?
I usually see similar effects on kdenlive when my mlt gets too old.
(0007553)
sunab (developer)
2011-11-12 10:04
edited on: 2011-11-12 10:05

problem confirmed here with latest kdenlive AND mlt git builds.

kdenlive rev. 08fd8d1c

mlt rev. 86f608ba

(0007554)
norms2 (reporter)
2011-11-12 11:44

@ evorster:

I am using both revisions as specified in sunab's post.
(0007555)
evorster (reporter)
2011-11-12 12:27

I am using kdenlive of yesterday's git, but only the last release of mlt.
I am not seeing this at all.
I might try to upgrade mlt to latest git, and see if that introduces this error.
(0007556)
sunab (developer)
2011-11-12 14:42

I ran some more tests:

Kdenlive 0.8.2 + Mlt git 86f608ba : no problem


Kdenlive git 08fd8d1c + Mlt 0.7.6 : transitions applied but not visible in timeline

It seems the problem is in kdenlive.

hint : when adding a transition the terminal output is :

QPropertyAnimation: you're trying to animate a non-existing property rect of your QObject
(0007557)
diveo (reporter)
2011-11-12 16:59
edited on: 2011-11-12 16:59

Just upgraded my Kubuntu 11.10 64bit box to kdenlive 0.8.3+git20111111.08fd8d1c-0ubuntu0~sunab~oneiric1. Same problem here, the timeline now does not show transitions anymore; there are only a dark yellow lines where formerly the transition effects happend to be. Selection is not possible anymore.

(0007558)
j-b-m (administrator)
2011-11-12 21:26

I confirm the bug on git master, but it works fine for the 0.8.2 branch and the transition code was not touched. It must be some build system changes that trigger this, I will investigate asap..
(0007560)
j-b-m (administrator)
2011-11-13 15:27

For some reason I don't yet understand, the Qt animations are disabled since this change in the build system:
http://quickgit.kde.org/?p=kdenlive.git&a=commit&h=87914857d36c5b051b006f3f74d489af3801af4d [^]

I fixed the problem by checking if animations are enabled or not and reacting accordingly, so now this issue should be solved.
(0007562)
purdeaandrei (reporter)
2011-11-13 15:52

It doesn't work for me in rev. 1638e21 either
Also, something else i noticed, probably related: delete animations are missing too. The same error messages are produced.
(0007563)
j-b-m (administrator)
2011-11-13 17:30

Strange.. it works for me. Will test on another computer. Animation deletion were removed since they are now started with the flag 'QAbstractAnimation::DeleteWhenStopped' which mean they auto-delete on exit
(0007564)
j-b-m (administrator)
2011-11-13 19:45

Ok, should now be fixed (rev. b6f15d1). Strangely it seems like the "QProperty" macro cannot be included in #if since the buildsystem change... please confirm if it works for you.
(0007565)
purdeaandrei (reporter)
2011-11-13 20:38

Okay, it is fixed. The delete-from-timeline animations are also back working.

Thanks

- Issue History
Date Modified Username Field Change
2011-11-12 09:07 norms2 New Issue
2011-11-12 09:35 evorster Note Added: 0007551
2011-11-12 10:04 sunab Note Added: 0007553
2011-11-12 10:05 sunab Note Edited: 0007553 View Revisions
2011-11-12 11:44 norms2 Note Added: 0007554
2011-11-12 12:27 evorster Note Added: 0007555
2011-11-12 14:42 sunab Note Added: 0007556
2011-11-12 16:59 diveo Note Added: 0007557
2011-11-12 16:59 diveo Note Edited: 0007557 View Revisions
2011-11-12 21:26 j-b-m Note Added: 0007558
2011-11-12 21:26 j-b-m Assigned To => j-b-m
2011-11-12 21:26 j-b-m Status new => acknowledged
2011-11-13 15:27 j-b-m Note Added: 0007560
2011-11-13 15:27 j-b-m Status acknowledged => feedback
2011-11-13 15:52 purdeaandrei Note Added: 0007562
2011-11-13 17:30 j-b-m Note Added: 0007563
2011-11-13 19:45 j-b-m Note Added: 0007564
2011-11-13 20:38 purdeaandrei Note Added: 0007565
2011-11-13 20:40 j-b-m Status feedback => resolved
2011-11-13 20:40 j-b-m Fixed in Version => 0.8.4
2011-11-13 20:40 j-b-m Resolution open => fixed
2011-11-14 19:16 j-b-m Fixed in Version 0.8.4 => 0.8.2.1
2011-12-08 22:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker