Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002414KdenliveBuild Systempublic2011-11-20 01:492011-12-08 22:51
ReporterFabriceLaussy 
Assigned Toj-b-m 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSKubuntuOS Version10.04
Product Version0.8.2 
Target VersionFixed in Version0.8.2.1 
Summary0002414: Crash when using open/save as/save/add clip, etc.
DescriptionApplication: kdenlive (0.8.2)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-35-generic x86_64
Distribution: Ubuntu 10.04.3 LTS

-- Information about the crash:
Software works normally, in particular it can export videos, but when using certain services from the menu, such as open, save as, add clip, ..., it crashes. Others, like New or Open don't cause the crash. It occurs both on the version installed with apt-get or compiled from sources. I cleaned rc files and other directories, removed & purged, reinstalled, to no-avail.

The crash can be reproduced every time.

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f3bbd2177a0 (LWP 11891))]

Thread 4 (Thread 0x7f3b9f7f9700 (LWP 11892)):
#0 0x00007f3bb6b20f93 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1 0x00007f3bb5c444a9 in ?? () from /lib/libglib-2.0.so.0
0000002 0x00007f3bb5c448fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000003 0x00007f3bbc55d566 in QEventDispatcherGlib::processEvents (this=0x34ae5e0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
0000004 0x00007f3bbc532992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
0000005 0x00007f3bbc532d6c in QEventLoop::exec (this=0x7f3b9f7f8d70, flags=) at kernel/qeventloop.cpp:201
0000006 0x00007f3bbc43cd59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
0000007 0x00007f3bbc513178 in QInotifyFileSystemWatcherEngine::run (this=0x3480010) at io/qfilesystemwatcher_inotify.cpp:248
0000008 0x00007f3bbc43f775 in QThreadPrivate::start (arg=0x3480010) at thread/qthread_unix.cpp:248
0000009 0x00007f3bbae069ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
0000010 0x00007f3bb6b2d70d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000011 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3b9e60d700 (LWP 11893)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1 0x00007f3bbcf368d0 in mlt_consumer_get_frame (self=0x2e0ec20) at mlt_consumer.c:536
0000002 0x00007f3bbcf37abe in mlt_consumer_rt_frame (self=0x2e0ed3c) at mlt_consumer.c:1329
0000003 0x00007f3ba8d6601c in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007f3bbae069ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
0000005 0x00007f3bb6b2d70d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3b9de0c700 (LWP 11894)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1 0x00007f3ba8d65921 in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f3bbae069ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
0000003 0x00007f3bb6b2d70d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3bbd2177a0 (LWP 11891)):
[KCrash Handler]
0000005 QBasicAtomicInt::ref (this=0x7fffdbcbf5b0, n=...) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
0000006 QDomNode (this=0x7fffdbcbf5b0, n=...) at dom/qdom.cpp:2035
0000007 0x00007f3bbba8848f in KBookmarkManager::internalDocument (this=0x34781c0) at ../../kio/bookmarks/kbookmarkmanager.cc:340
0000008 0x00007f3bbba884d3 in KBookmarkManager::root (this=0x346c440) at ../../kio/bookmarks/kbookmarkmanager.cc:465
0000009 0x00007f3bbba8858d in KBookmarkMap::update (this=0x346d280) at ../../kio/bookmarks/kbookmarkmanager.cc:101
0000010 0x00007f3bbba879f5 in KBookmarkManager::parse (this=0x3641610) at ../../kio/bookmarks/kbookmarkmanager.cc:394
0000011 0x00007f3bbba88476 in KBookmarkManager::internalDocument (this=0x3641610) at ../../kio/bookmarks/kbookmarkmanager.cc:337
0000012 0x00007f3bbba884d3 in KBookmarkManager::root (this=0x346c440) at ../../kio/bookmarks/kbookmarkmanager.cc:465
0000013 0x00007f3baeffceeb in KFilePlacesModel (this=0x2ddc1b0, parent=<value optimized out>) at ../../kfile/kfileplacesmodel.cpp:99
0000014 0x00007f3baeff037e in KFileWidget (this=0x3613630, _startDir=<value optimized out>, parent=<value optimized out>) at ../../kfile/kfilewidget.cpp:338
0000015 0x00007f3b94ee9f14 in KFileModule::createFileWidget (this=<value optimized out>, startDir=..., parent=0x7fffdbcc0660) at ../../kfile/kfilemodule.cpp:37
0000016 0x00007f3bbbaadd72 in KFileDialog (this=0x7fffdbcc0660, startDir=..., filter=..., parent=<value optimized out>, customWidget=<value optimized out>) at ../../kio/kfile/kfiledialog.cpp:269
0000017 0x00007f3bbbab050d in KFileDialogPrivate::getSaveFileName (dir=..., filter=..., parent=<value optimized out>, caption=..., options=) at ../../kio/kfile/kfiledialog.cpp:754
0000018 0x00007f3bbbab0d32 in KFileDialog::getSaveFileName (dir=..., filter=..., parent=0x0, caption=...) at ../../kio/kfile/kfiledialog.cpp:710
0000019 0x0000000000469d24 in MainWindow::saveFileAs (this=0x23bd0b0) at /home/laussy/comp/kdenlive/kdenlive/src/mainwindow.cpp:1955
0000020 0x000000000048ce28 in MainWindow::qt_metacall (this=0x23bd0b0, _c=QMetaObject::InvokeMetaMethod, _id=8165072, _a=0x7fffdbcc0c90)
    at /home/laussy/comp/kdenlive/kdenlive/build/src/cmake_bindir/mainwindow.moc:401
0000021 0x00007f3bbc546e3f in QMetaObject::activate (sender=0x32b3130, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3293
0000022 0x00007f3bb7730032 in QAction::triggered (this=0x7fffdbcbf5b0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
0000023 0x00007f3bb77320ab in QAction::activate (this=0x32b3130, event=<value optimized out>) at kernel/qaction.cpp:1255
0000024 0x00007f3bb7b7139d in QMenuPrivate::activateCausedStack (this=<value optimized out>, causedStack=..., action=0x32b3130, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1011
0000025 0x00007f3bb7b76dda in QMenuPrivate::activateAction (this=0x33fed50, action=0x32b3130, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1103
0000026 0x00007f3bbc08d48e in KMenu::mouseReleaseEvent (this=0x33febd0, e=0x346c440) at ../../kdeui/widgets/kmenu.cpp:471
0000027 0x00007f3bb778c582 in QWidget::event (this=0x33febd0, event=0x7fffdbcc18e0) at kernel/qwidget.cpp:7998
0000028 0x00007f3bb7b78f9b in QMenu::event (this=0x33febd0, e=0x7fffdbcc18e0) at widgets/qmenu.cpp:2414
0000029 0x00007f3bb773622c in QApplicationPrivate::notify_helper (this=0x23565e0, receiver=0x33febd0, e=0x7fffdbcc18e0) at kernel/qapplication.cpp:4300
0000030 0x00007f3bb773cecb in QApplication::notify (this=0x7fffdbcc25e0, receiver=0x33febd0, e=0x7fffdbcc18e0) at kernel/qapplication.cpp:3865
0000031 0x00007f3bbbfb0a16 in KApplication::notify (this=0x7fffdbcc25e0, receiver=0x33febd0, event=0x7fffdbcc18e0) at ../../kdeui/kernel/kapplication.cpp:302
0000032 0x00007f3bbc53406c in QCoreApplication::notifyInternal (this=0x7fffdbcc25e0, receiver=0x33febd0, event=0x7fffdbcc18e0) at kernel/qcoreapplication.cpp:704
0000033 0x00007f3bb773c0ae in QCoreApplication::sendEvent (receiver=0x33febd0, event=0x7fffdbcc18e0, alienWidget=0x0, nativeWidget=0x33febd0, buttonDown=<value optimized out>,
    lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
0000034 QApplicationPrivate::sendMouseEvent (receiver=0x33febd0, event=0x7fffdbcc18e0, alienWidget=0x0, nativeWidget=0x33febd0, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>,
    spontaneous=true) at kernel/qapplication.cpp:2965
0000035 0x00007f3bb77bc3dd in QETWidget::translateMouseEvent (this=0x33febd0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4302
0000036 0x00007f3bb77ba8ac in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffdbcc2200) at kernel/qapplication_x11.cpp:3501
0000037 0x00007f3bb77e6882 in x11EventSourceDispatch (s=0x235a350, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
0000038 0x00007f3bb5c408c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000039 0x00007f3bb5c44748 in ?? () from /lib/libglib-2.0.so.0
0000040 0x00007f3bb5c448fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000041 0x00007f3bbc55d513 in QEventDispatcherGlib::processEvents (this=0x233cfe0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
0000042 0x00007f3bb77e646e in QGuiEventDispatcherGlib::processEvents (this=0x7fffdbcbf5b0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
0000043 0x00007f3bbc532992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
0000044 0x00007f3bbc532d6c in QEventLoop::exec (this=0x7fffdbcc2530, flags=) at kernel/qeventloop.cpp:201
0000045 0x00007f3bbc536aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
0000046 0x000000000045ef05 in main (argc=<value optimized out>, argv=<value optimized out>) at /home/laussy/comp/kdenlive/kdenlive/src/main.cpp:89
Steps To Reproduce* launch kdenlive
* click on "Save as"
Additional InformationMight be related to Qt, but no other application seem to suffer from a similar bug.
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Files

- Relationships
duplicate of 0002363closedj-b-m Crash when trying to save project as a new file using "save as" 

-  Notes
(0007598)
j-b-m (administrator)
2011-11-20 12:54

This is a known issue caused by a problem in the KDE version shipped with Ubuntu 10.04. The crash should be solved in the development version of Kdenlive. Could you please test it so that we can make sure it is solved?

Development version is available from sunab's experimental ppa:
https://launchpad.net/~sunab/+archive/kdenlive-svn [^]
(0007613)
FabriceLaussy (reporter)
2011-11-22 00:23

Okay, you're right. I tested it and can confirm that 0.8.3 does not bug when saving. Thanks a lot.

- Issue History
Date Modified Username Field Change
2011-11-20 01:49 FabriceLaussy New Issue
2011-11-20 12:52 j-b-m Relationship added duplicate of 0002363
2011-11-20 12:54 j-b-m Note Added: 0007598
2011-11-20 12:54 j-b-m Assigned To => j-b-m
2011-11-20 12:54 j-b-m Status new => feedback
2011-11-22 00:23 FabriceLaussy Note Added: 0007613
2011-11-22 00:23 FabriceLaussy Status feedback => assigned
2011-11-22 00:46 j-b-m Status assigned => resolved
2011-11-22 00:46 j-b-m Fixed in Version => 0.8.2.1
2011-11-22 00:46 j-b-m Resolution open => fixed
2011-12-08 22:51 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker