Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002421KdenliveBuild Systempublic2011-11-24 18:432011-12-08 22:50
Reportersunab 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformallOSUbuntu < 10.10OS Version
Product VersionRecent git 
Target VersionFixed in VersionRecent git 
Summary0002421: FTBS with libqt4 < 4.7
DescriptionKdenlive git rev.0d8de4d8 fails to build from source :

/build/buildd/kdenlive-0.8.3+git20111123-21.0d8de4d8/src/choosecolorwidget.cpp: In member function 'QString ChooseColorWidget::getColor()':
/build/buildd/kdenlive-0.8.3+git20111123-21.0d8de4d8/src/choosecolorwidget.cpp:105: error: 'class KColorButton' has no member named 'isAlphaChannelEnabled'
/build/buildd/kdenlive-0.8.3+git20111123-21.0d8de4d8/src/choosecolorwidget.cpp: In member function 'void ChooseColorWidget::setAlphaChannelEnabled(bool)':
/build/buildd/kdenlive-0.8.3+git20111123-21.0d8de4d8/src/choosecolorwidget.cpp:110: error: 'class KColorButton' has no member named 'setAlphaChannelEnabled'
make[3]: *** [src/CMakeFiles/kdenlive.dir/choosecolorwidget.o] Error 1
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships

-  Notes
(0007626)
sunab (developer)
2011-11-24 18:46

Sorry, seems already fixed in rev.bc2f33b9.

stupid me!
(0007627)
j-b-m (administrator)
2011-11-24 19:18

I fixed it because I noticed the build failure on your PPA, it's a nice way to find out build failures.

- Issue History
Date Modified Username Field Change
2011-11-24 18:43 sunab New Issue
2011-11-24 18:46 sunab Note Added: 0007626
2011-11-24 19:18 j-b-m Note Added: 0007627
2011-11-24 19:18 j-b-m Status new => resolved
2011-11-24 19:18 j-b-m Fixed in Version => Recent git
2011-11-24 19:18 j-b-m Resolution open => fixed
2011-11-24 19:18 j-b-m Assigned To => j-b-m
2011-12-08 22:50 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker