Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002448KdenliveFile Loadingpublic2011-12-21 14:102012-05-15 10:58
Reportertrueg 
Assigned Toj-b-m 
PriorityurgentSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSGentoo LinuxOS Version2008.0
Product VersionRecent git 
Target VersionFixed in Version0.9 
Summary0002448: Crash when switching profile
DescriptionApplication: kdenlive (0.8.3 (rev. v0.8.2-166-g39c2d28))
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.6-gentoo x86_64

-- Information about the crash:
<In detail, tell us what you were doing when the application crashed.>

The crash can be reproduced every time.

-- Backtrace:
Application: Kdenlive (kdenlive), signal: Aborted
[Current thread is 1 (Thread 0x7f6b4e3367a0 (LWP 14233))]

Thread 4 (Thread 0x7f6b3ce15700 (LWP 14253)):
#0 0x000000305c60c7cb in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1 0x000000305fe7d0c1 in wait (this=<value optimized out>, mutex=0x35d1db0, time=30000) at thread/qwaitcondition_unix.cpp:86
0000002 QWaitCondition::wait (this=<value optimized out>, mutex=0x35d1db0, time=30000) at thread/qwaitcondition_unix.cpp:160
0000003 0x000000305fe7020f in QThreadPoolThread::run (this=0x35c7d30) at concurrent/qthreadpool.cpp:140
0000004 0x000000305fe7c98a in QThreadPrivate::start (arg=0x35c7d30) at thread/qthread_unix.cpp:331
0000005 0x000000305c607c5c in start_thread () from /lib64/libpthread.so.0
0000006 0x000000305bed9fcd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f6b3ee19700 (LWP 14256)):
#0 0x000000305c60c7cb in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1 0x0000003754e19fde in mlt_consumer_get_frame () from /usr/lib64/libmlt.so.4
0000002 0x0000003754e1a89e in mlt_consumer_rt_frame () from /usr/lib64/libmlt.so.4
0000003 0x00007f6b40db7a44 in consumer_thread () from /usr/lib64/mlt/libmltsdl.so
0000004 0x000000305c607c5c in start_thread () from /lib64/libpthread.so.0
0000005 0x000000305bed9fcd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f6b3e618700 (LWP 14257)):
#0 0x000000305c60c44c in pthread_cond_wait () from /lib64/libpthread.so.0
#1 0x00007f6b40db70db in consumer_thread () from /usr/lib64/mlt/libmltsdl.so
0000002 0x000000305c607c5c in start_thread () from /lib64/libpthread.so.0
0000003 0x000000305bed9fcd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f6b4e3367a0 (LWP 14233)):
[KCrash Handler]
0000006 0x000000305be35a55 in raise () from /lib64/libc.so.6
0000007 0x000000305be36d55 in abort () from /lib64/libc.so.6
0000008 0x000000305fe71d64 in qt_message_output (msgType=<value optimized out>, buf=<value optimized out>) at global/qglobal.cpp:2291
0000009 0x000000305fe71efd in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x305ffd89e8 "ASSERT failure in %s: \"%s\", file %s, line %d", ap=0x7fffc99b58c0) at global/qglobal.cpp:2337
0000010 0x000000305fe72095 in qFatal (msg=<value optimized out>) at global/qglobal.cpp:2520
0000011 0x000000305fe779b9 in QMutex::unlock (this=0x3588758) at thread/qmutex.cpp:369
0000012 0x00000000005a0bcc in DocClipBase::deleteProducers (this=0x35886c0) at /home/trueg/kde/dev/kde/src/kdenlive/src/docclipbase.cpp:421
0000013 0x0000000000526582 in ClipManager::clearUnusedProducers (this=0x33e6cf0) at /home/trueg/kde/dev/kde/src/kdenlive/src/clipmanager.cpp:431
0000014 0x00000000004d2ee8 in MainWindow::slotUpdateProjectProfile (this=0x2b74920, profile=...) at /home/trueg/kde/dev/kde/src/kdenlive/src/mainwindow.cpp:2347
0000015 0x00000000004e3454 in MainWindow::qt_metacall (this=0x2b74920, _c=QMetaObject::InvokeMetaMethod, _id=28, _a=0x7fffc99b5ee0) at /home/trueg/kde/dev/kde/build/kdenlive/src/mainwindow.moc:420
0000016 0x000000305ff8a18f in QMetaObject::activate (sender=0x2d13320, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fffc99b5ee0) at kernel/qobject.cpp:3278
0000017 0x00000000006ab69f in ProjectList::updateProfile (this=0x2d13320, _t1=...) at /home/trueg/kde/dev/kde/build/kdenlive/src/projectlist.moc:562
0000018 0x00000000006a1290 in ProjectList::adjustProjectProfileToItem (this=0x2d13320, item=0x35d2aa0) at /home/trueg/kde/dev/kde/src/kdenlive/src/projectlist.cpp:2128
0000019 0x00000000006a0861 in ProjectList::slotReplyGetFileProperties (this=0x2d13320, clipId=..., producer=0x3524f60, properties=..., metadata=..., replace=true) at /home/trueg/kde/dev/kde/src/kdenlive/src/projectlist.cpp:2060
0000020 0x00000000006aa3ee in ProjectList::qt_metacall (this=0x2d13320, _c=QMetaObject::InvokeMetaMethod, _id=29, _a=0x35f7f60) at /home/trueg/kde/dev/kde/build/kdenlive/src/projectlist.moc:399
0000021 0x000000305ff89c2a in QObject::event (this=0x2d13320, e=<value optimized out>) at kernel/qobject.cpp:1217
0000022 0x0000003061622a4c in QWidget::event (this=0x2d13320, event=0x35fa610) at kernel/qwidget.cpp:8754
0000023 0x00000030615c9d54 in QApplicationPrivate::notify_helper (this=0x29a83e0, receiver=0x2d13320, e=0x35fa610) at kernel/qapplication.cpp:4481
0000024 0x00000030615cf051 in QApplication::notify (this=<value optimized out>, receiver=0x2d13320, e=0x35fa610) at kernel/qapplication.cpp:4360
0000025 0x00007f6b51c0b645 in KApplication::notify (this=0x7fffc99b7580, receiver=0x2d13320, event=0x35fa610) at /home/trueg/kde/dev/kde/src/kdelibs/kdeui/kernel/kapplication.cpp:311
0000026 0x000000305ff7376b in QCoreApplication::notifyInternal (this=0x7fffc99b7580, receiver=0x2d13320, event=0x35fa610) at kernel/qcoreapplication.cpp:787
0000027 0x000000305ff7767e in sendEvent (receiver=0x0, event_type=0, data=0x29839f0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
0000028 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x29839f0) at kernel/qcoreapplication.cpp:1428
0000029 0x000000305ffa16d3 in sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
0000030 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
0000031 0x000000305ae44f6e in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
0000032 0x000000305ae45758 in ?? () from /usr/lib64/libglib-2.0.so.0
0000033 0x000000305ae459ed in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
0000034 0x000000305ffa186f in QEventDispatcherGlib::processEvents (this=0x29a7fa0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
0000035 0x000000306167aaee in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
0000036 0x000000305ff72212 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
0000037 0x000000305ff72455 in QEventLoop::exec (this=0x7fffc99b74b0, flags=...) at kernel/qeventloop.cpp:201
0000038 0x000000305ff77979 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
0000039 0x00000000004b2c7f in main (argc=1, argv=0x7fffc99b7ba8) at /home/trueg/kde/dev/kde/src/kdenlive/src/main.cpp:89

Report to http://kdenlive.org/mantis [^]
Steps To ReproduceAdd a video with a different resolution than that of the current profile to an empty project. Kdenlive will ask to switch the profile. Both accepting and rejecting that dialog results in the crash.
Additional InformationThe crash is mutex related:

kdenlive(14180) Render::checkMaxThreads: // TRACTOR PROBLEM
ASSERT failure in QMutex::unlock(): "A mutex must be unlocked in the same thread that locked it.", file thread/qmutex.cpp, line 370
TagsNo tags attached.
Build/Install MethodManual build from Git
Attached Files

- Relationships
has duplicate 0002487closedj-b-m Crash after adding a clip 

-  Notes
(0007676)
trueg (reporter)
2011-12-21 14:11

I marked this as urgent since I cannot do anything with Kdenlive since adding a video to the project results in this crash. :/
Have fun with the multi-thread debugging. ;)
(0007678)
j-b-m (administrator)
2011-12-22 21:29

I cannot reproduce...

From your log:

in qFatal (msg=<value optimized out>) at global/qglobal.cpp:2520
in QMutex::unlock (this=0x3588758) at thread/qmutex.cpp:369
in DocClipBase::deleteProducers (this=0x35886c0) at /home/trueg/kde/dev/kde/src/kdenlive/src/docclipbase.cpp:421

It looks like the mutex in docclipbase line 421 is accessed from different threads but on I checked on my computer, and it is always accessed from the main thread, I don't see how it could be called from a different thread.

Can you please make sure that the problem is not in MLT, try playing your clip with the command line player:

melt myclip.mpg

Does it work?

regards
(0007679)
j-b-m (administrator)
2011-12-22 21:36

And by the way, you can disable the option to adjust project profile to the first added clip in Kdenlive Settings dialog > Misc:

Check if first added clip matches project profile

Might be interesting to see it you still get crashes when adding a clip without that option enabled
(0007680)
trueg (reporter)
2011-12-22 21:45

melt does play the videos without problems and without the profile switch it still crashes.
Could it be related to my 4 core 64bit system?

- Issue History
Date Modified Username Field Change
2011-12-21 14:10 trueg New Issue
2011-12-21 14:11 trueg Note Added: 0007676
2011-12-22 21:29 j-b-m Note Added: 0007678
2011-12-22 21:29 j-b-m Assigned To => j-b-m
2011-12-22 21:29 j-b-m Status new => feedback
2011-12-22 21:36 j-b-m Note Added: 0007679
2011-12-22 21:45 trueg Note Added: 0007680
2011-12-22 21:45 trueg Status feedback => assigned
2012-01-17 13:36 j-b-m Relationship added has duplicate 0002487
2012-01-17 15:15 j-b-m Status assigned => resolved
2012-01-17 15:15 j-b-m Fixed in Version => Recent git
2012-01-17 15:15 j-b-m Resolution open => fixed
2012-05-15 10:57 j-b-m Fixed in Version Recent git => 0.9
2012-05-15 10:58 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker